Menu

Additionner des résultats de recherche v x valeurs

- - Dernière réponse :  Malicou - 25 mars 2019 à 09:19
Bonjour à tous,

je souhaite simplifier une formule.

Voici la situation, j'ai une base de données dans un tableau 1 avec tous mes équipements et notamment, le montant de leur amortissement annuel, ...

Dans un 2nd (petit) tableau j'ai quelques équipements issus de cette base et combien de temps ils sont utilisés.

Pour ce 2nd tableau, je souhaiterai calculer le total : nombre d'heures d'utilisation * amortissement pour chacune des lignes. Je pense qu'on peut faire quelque chose comme une matrice mais il y a des recherchev dans ma formule donc je ne sais pas le faire...

Voici le type de formule à simplifier : =(RECHERCHEV(B1;Table_equipements;13;FAUX)*C1)+(RECHERCHEV(B2+1;Table_equipements;13;FAUX)*C2)+(RECHERCHEV(B3;Table_equipements;13;FAUX)*C3)+....


et le lien
https://drive.google.com/file/d/1BQm6PjKr1ve873pgplVpBfw3SefbJ4hh/view?usp=sharing

Merci pour votre aide :)

Alice
Afficher la suite 

5 réponses

Messages postés
24116
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 juin 2019
4641
0
Merci
Bonjour
le plus simple serait de prévoir une colonne D/ E F pour chaque rubrique avec la formule de recherche pour chaque ligne et de faire les sommes de D/E/F ensuite
ces colonnes pouvant être masquées, voire sur une autre feuille
crdlmnt
Bonjour,

merci pour cette réponse rapide :)

Là j'ai simplifié les choses, j'ai mis un seul forfait, mais j'en au une 30aine dans mon tableau d'origine, donc j'aurai aimé éviter ce côté caché et si possible avoir une formule.
Commenter la réponse de Vaucluse
Messages postés
504
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
5 juin 2019
37
0
Merci
Bonjour,

Pour moi, le "+1" de "B2+1 empêche tout. Est-ce que tu ne peux pas l'éviter ?

Daniel
Bonjour Daniel,

merci pour votre réponse.

Le +1 est une erreur, il est à supprimer.
Dans cet exemple j'ai mis de B1 à B3 mais on peut aller jusqu'à B ou C30 sans problème.

Alice
danielc0
Messages postés
504
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
5 juin 2019
37 > Malicou -
Essaie la formule suivante (à valider avec Ctrl+Maj+Entrée), la colonne D étant la colonne de gauche de "Table_equipements" :

=SOMME(EQUIV(B1:B3;D1:D3;0)*P1:P3)

En redimensionnement les plages.

Daniel
danielc0
Messages postés
504
Date d'inscription
mardi 5 juin 2018
Statut
Membre
Dernière intervention
5 juin 2019
37 -
Au temps pour moi, c'est faux.
Daniel
Commenter la réponse de danielc0
Messages postés
22757
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 juin 2019
5514
0
Merci
Bonjour,

rien à voir avec ton pb mais en B2 je vois :
=SOMME(B4:B53) 

Tu n'as pas l'impression que tu y mets le doubles ?
Tu as inséré des sous-totaux, chaque valeur est comptée 2 fois...

D'autre part tu ne respectes pas les règles pour avoir une BDD exploitable.
Lignes vides, colonnes vides, sous-totaux, tu fais tout pour te compliquer la vie.
A lire d'urgence ;-) : http://www.xlerateur.com/divers/2010/05/14/les-13-regles-d%E2%80%99or-pour-utiliser-excel-comme-gestionnaire-de-donnees-612/
eric

Commenter la réponse de eriiic
Messages postés
1933
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
22 juin 2019
746
0
Merci
Bonsoir à tous,

Tu peux regarder ma réponse là : https://forum.excel-pratique.com/viewtopic.php?f=2&t=122262

Je n'avais pas vu ta demande sur Ccm.

Cdlt
Commenter la réponse de JvDo
0
Merci
ça fonctionne, merci à tous pour vos retours!
Commenter la réponse de Malicou