Menu

Calculer le nombre de bon numéro pour tirage type "loto"

-
Bonjour,

Je vais avoir un tableau structuré de la façon suivante :

Tirage | 4 | 12 | 76 | 86 | 6 | 24 | 13 | 55 | 33 | 67

Joueur A | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | Nbr de bon numéros

Avec une ligne par joueurs.

Comment calculer automatiquement la case "nombre de bon numéros" en fonction du tirage ?

Merci :)
Afficher la suite 

Votre réponse

1 réponse

Messages postés
1854
Date d'inscription
dimanche 3 mai 2009
Dernière intervention
21 mars 2019
452
0
Merci
Bonjour
En attendant mieux faire une somme de NB.SI et en espérant que ça peut aller sur le tableur de Google (les formules ci-dessous sont faites sur excel 2013)

Les numéros de tirage en B1 à K1
JoueurA de B2 à K2

=SI(NBVAL(B2:K2)>0;SOMME(NB.SI($B$1:$K$1;B2);NB.SI($B$1:$K$1;C2);NB.SI($B$1:$K$1;D2);NB.SI($B$1:$K$1;E2);NB.SI($B$1:$K$1;F2);NB.SI($B$1:$K$1;G2);NB.SI($B$1:$K$1;H2);NB.SI($B$1:$K$1;I2);NB.SI($B$1:$K$1;J2);NB.SI($B$1:$K$1;K2));"")

A incrémenter vers le bas pour les autres joueurs

Pour éviter l'oubli de blocage de la zone $B$1:$K$1 nommer cette zone "tirage" (par exemple) ce qui donne

=SI(NBVAL(B2:K2)>0;SOMME(NB.SI(tirage;B2);NB.SI(tirage;C2);NB.SI(tirage;D2);NB.SI(tirage;E2);NB.SI(tirage;F2);NB.SI(tirage;G2);NB.SI(tirage;H2);NB.SI(tirage;I2);NB.SI(tirage;J2);NB.SI(tirage;K2));"")

Le NBVAL du début est là pour éviter que le tableur marque 0 si le joueur n'a pas joué

Cordialement
Commenter la réponse de PapyLuc51