Menu

Quelle formule ? [Résolu]

Messages postés
514
Date d'inscription
samedi 11 août 2012
Dernière intervention
20 février 2019
-
Bonjour,
Je viens chercher de l'aide car je n'arrive pas a trouver la formule correspondante; J'en ai une partie, mais je bloque sur la suite.
J'ai crée un tableau avec : colonne B, la liste de mes saisonniers; colonne C, leur date d'entrée; colonne D, leur date de sortie. Je voudrais que dans la cellule jaune, en D3, s'affiche le total des personnes encore présentes , donc en tenant compte de celles entrées, moins celles sorties. Je suis arrivée a faire une formule pour les personnes entrées, ( en mettant le total si case pleine), mais je n'arrive pas a compéter avec la soustraction des cellules avec dates de sortie....
J'espère avoir été claire. Ci dessous, un extrait du tableau pour plus de clarté.
Si quelqu'un pouvait me donner un coup de pouce, ce serait top.
Merci beaucoup.


Configuration: Windows / Firefox 65.0
Afficher la suite 

Votre réponse

2 réponses

Messages postés
23535
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 février 2019
5636
0
Merci
Bonjour

vous ne dites pas si , en colonne B on peut avoir des dates qui ne sont pas encore dépassées, alors pour prendre en compte ensemble tous les cas:
  • si la date en A est antérieure à aujourd'hui
  • si la date en B est postérieure à aujourd'hui ou vide:

=NB.SI.ENS(A:A;"<="&AUJOURDHUI();A:A;">0";B:B;">="&AUJOURDHUI())+NB.SI.ENS(A:A;"<="&AUJOURDHUI();A:A;">0";B:B;"")
crdlmnt

ps si en colonne B une date est spécifiée uniquement pour les sorties, et ne risque pas d'être > que le jour en cours, la seconde partie de la formule après le + suffit

maryleg
Messages postés
514
Date d'inscription
samedi 11 août 2012
Dernière intervention
20 février 2019
31 -
merci pour ta contribution; Je vais opter pour la formule de JCB40, un peu plus simple.
Bonne aprem
Commenter la réponse de Vaucluse
Messages postés
437
Date d'inscription
lundi 2 juillet 2018
Dernière intervention
21 février 2019
40
0
Merci
Bonjour

Avec la cellule D3 au format standart

=NBVAL(B5:B8)-NBVAL(D5:D8)
Crdlt
maryleg
Messages postés
514
Date d'inscription
samedi 11 août 2012
Dernière intervention
20 février 2019
31 -
Merci pour ton aide. je me compliquais trop la vie ! extra ! enfin la solution que je cherchais.
Bonne aprem.
Vaucluse
Messages postés
23535
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 février 2019
5636 -
si vous voulez, mais dans votre exemple, elle vous comptera le 4/03/2019 comme présent alors que nous ne sommes que le 6/2?
maryleg
Messages postés
514
Date d'inscription
samedi 11 août 2012
Dernière intervention
20 février 2019
31 > Vaucluse
Messages postés
23535
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 février 2019
-
oui, mais en fait, j'ai mis des dates au hasard... dans la pratique, les dates sont au jour le jour.... donc ça n'a pas d'importance, puisque j'enregistre le personnel au fur et a mesure qu'il rentre en fait. voila pour l'explication.
Merci de me l'avoir fait remarquer.
Commenter la réponse de JCB40