Menu

Formule avec 3 réponses possibles

Messages postés
3
Date d'inscription
mardi 5 février 2019
Dernière intervention
6 février 2019
- - Dernière réponse : michel_m
Messages postés
15674
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
16 février 2019
- 6 févr. 2019 à 10:30
Bonsoir,

Je travaille sur un tableau excel pour le suivi de mon activité commerciale. L'idée est d'avoir un onglet par mois dans lequel j'indique mes commandes. Dans cet onglet, j'ai une cellule "date de facturation" (D2).

L'idée est de pouvoir indiquer mois par mois le montant qui a été facturé.

Si D2 est compris entre le 1er et le 28 février, reporter le montant de la case G2 de l'onglet février et si la case D2 du mois de janvier est compris entre les mêmes dates, reporter le montant de la case G2 de l'onglet Janvier, sinon mettre 0.

J'ai testé cette formule qui ne fonctionne pas : =SI(ET((D2>=DATE(2019;2;1);D2<=DATE(2019;2;29);G2;SI(ET(Janvier!D2>=date(2019;2;1);Janvier!D2<=date(2019;2;29);Janvier!G2;0)))))

Pouvez-vous m'indiquer ou se trouve l'erreur ?

Par ailleurs, y a t il une formule plus simple, car je vais devoir ajouter des conditions jusqu'au mois de décembre...?

Je vous remercie par avance et reste à votre disposition si nécessaire.

Antoine.
Afficher la suite 

Votre réponse

5 réponses

Messages postés
7410
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
16 février 2019
438
0
Merci
bonjour, "qui ne fonctionne pas": message d'erreur, résultat inattendu, ?
Commenter la réponse de yg_be
Messages postés
3
Date d'inscription
mardi 5 février 2019
Dernière intervention
6 février 2019
0
Merci
Bonjour,

J'obtiens effectivement le message "désolé, nous avons trouvé une erreur dans cette formule...", et je ne vois pas d'où vient cette erreur.

Merci pour votre aide et bonne journée.

Antoine.
Commenter la réponse de antoine_76150
Messages postés
1903
Date d'inscription
mercredi 27 juillet 2005
Dernière intervention
16 février 2019
933
0
Merci
Bonjour à tous,

Tes parenthèses sont placées n'importe comment.
Derrière ton premier ET, il y a une parenthèse de trop.
Il faut une parenthèse fermante pour tes 2 ET.
A la fin de ta formule, tu auras 2 ou 3 parenthèses fermantes à virer.

Cordialement
Commenter la réponse de JvDo
Messages postés
1874
Date d'inscription
lundi 6 mai 2013
Dernière intervention
6 février 2019
231
0
Merci
Bonjour,
parenthèses au mauvais endroit
=SI(ET(D2>=DATE(2019;2;1);D2<=DATE(2019;2;29));G2;SI(ET(Janvier!D2>=DATE(2019;2;1);Janvier!D2<=DATE(2019;2;29));Janvier!G2;0))

Cdlt
antoine_76150
Messages postés
3
Date d'inscription
mardi 5 février 2019
Dernière intervention
6 février 2019
-
Parfait, merci beaucoup et bonne journée.
Commenter la réponse de Frenchie83
Messages postés
15674
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
16 février 2019
3607
0
Merci
Bonjour

=INDIRECT(TEXTE(D2;"mmmm")&"!G2")
Commenter la réponse de michel_m