Menu

Exclure #Valeur!

Messages postés
14
Date d'inscription
vendredi 23 février 2018
Dernière intervention
6 janvier 2019
- - Dernière réponse : Raymond PENTIER
Messages postés
47959
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 janvier 2019
- 6 janv. 2019 à 18:22
Bonjour !

Je veux dans une cellule E1 faire la somme A1&A2&A3 ETC, Tout en excluant les cellules dont les valeurs sont erronées.

Quelqu'un pourrait m'aider s.v.p. ? :)
Afficher la suite 

Votre réponse

6 réponses

Messages postés
347
Date d'inscription
lundi 2 juillet 2018
Dernière intervention
19 janvier 2019
31
0
Merci
Bonjour
Qu'entends tu par valeurs erronées?
Un exemple de ton fichier serait le bienvenu.
Crdlt
System1212
Messages postés
14
Date d'inscription
vendredi 23 février 2018
Dernière intervention
6 janvier 2019
-
Bonjour,

https://www.cjoint.com/c/IAeqfau1l3I

Premier Onglet, colonne M, la formule fonctionne. Dans le deuxième Onglet, elle ne fonctionne pas puisque il y a des cases '' Valeur!''. J'aimerais donc que la formule fonctionne même avec ses erreurs.
Commenter la réponse de JCB40
Messages postés
347
Date d'inscription
lundi 2 juillet 2018
Dernière intervention
19 janvier 2019
31
0
Merci
Modifie la formule qui se trouve en K2 de cette façon et étires vers le bas

=SI(A1="";"";GAUCHE(A2;NBCAR(A2)-4))
Commenter la réponse de JCB40
Messages postés
347
Date d'inscription
lundi 2 juillet 2018
Dernière intervention
19 janvier 2019
31
0
Merci
Petite erreur

=SI(A2="";"";GAUCHE(A2;NBCAR(A2)-4))
System1212
Messages postés
14
Date d'inscription
vendredi 23 février 2018
Dernière intervention
6 janvier 2019
-
Merci beaucoup ca fonctionné! Super :)
Commenter la réponse de JCB40
Messages postés
39090
Date d'inscription
lundi 21 janvier 2008
Statut
Modérateur
Dernière intervention
19 janvier 2019
9041
0
Merci
Bonjour

Merci d'avoir participé à ce forum.
Il semble que votre problème ai trouvé une réponse.

Si la réponse vous satisfait je vous invite à mettre en résolue, c'est très simple.

Merci de cliquer sur >CE LIEN<

PS: Si vous l'avez résolu vous même, il pourrait être intéressant de poster la solution pour les autres internautes.

Cordialement
Commenter la réponse de madmyke
Messages postés
347
Date d'inscription
lundi 2 juillet 2018
Dernière intervention
19 janvier 2019
31
0
Merci
Bonjour

Si la solution est bonne,tu passes le sujet en résolu "roue crantée"
Crdlt
Commenter la réponse de JCB40
Messages postés
47959
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 janvier 2019
15486
-1
Merci
C'est dans la cellule K2 qu'il faut compléter la formule
=SI(A2<>"";GAUCHE(A2;NBCAR(A2)-4);"")
Raymond PENTIER
Messages postés
47959
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 janvier 2019
15486 -
J'ignore, bien évidemment, qui a cru opportun de mettre un [ -1 ] à mon post #5.

J'indique à cette personne, certainement bien intentionnée, qu'il vaut toujours mieux, dans un fichier Excel comme dans n'importe quelle démarche scientifique ou technique (ou même dans la vie courante), éviter la survenue d'un défaut plutôt que de tenter de corriger les conséquences négatives de ce défaut.
Si cette personne a un profil artistique ou littéraire, je peux lui pardonner ...

--
Commenter la réponse de Raymond PENTIER