Menu

Planning congé

- - Dernière réponse : Raymond PENTIER
Messages postés
47696
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 décembre 2018
- 7 déc. 2018 à 23:29
Bonjour,

Je cherche quelqu'un qui pourrait m'aider à continuer mon planning pour synthétiser les congés de mon équipe. Ex: Plusieurs personnes et plusieurs types de congé, faire le décompte (le solde) etc.. Mettre aussi les différents type de congés en liste déroulante etc..

Je vous remercie d'avance. Cordialement

https://cjoint.com/c/HLhkfXG6Vnu
Afficher la suite 

Votre réponse

2 réponses

Messages postés
47696
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 décembre 2018
0
Merci
Bonjour.
Préliminaires : listes déroulantes.
Tu n'as défini que la plage "congés", qui pour toi se limite à la seule cellule BK1 !
Il faut saisir "demi" en BI1 et "congés" en BK1, sélectionner BI1:BM18, aller dans FORMULES/Noms définis/Depuis sélection, cocher "Ligne du haut" et valider.
Tu obtiens les sources de tes 3 listes déroulantes de cellule.
Merci pour la réponse, je vois comment faire cela maintenant. Maintenant ce que j'aimerais c'est que si je pose qu'un "1/2 congé" que sa rempli que la moitié de la cellule, le haut si je pose les 4 premières heures et le bas si je pose les 4 dernières heures. Et je souhaite mettre aussi les MFC correspondant avec les couleur de droite.

Cordialement M.Pentier
Commenter la réponse de Raymond PENTIER
Messages postés
47696
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 décembre 2018
0
Merci
Suite : Formules à recopier.

Quand en AL7 tu mets la formule =NB.SI(C7:AG7;"CA") cela entraîne une erreur en la recopiant ...
En effet Excel pense te faire plaisir en adaptant les références des cellules, et
la recopie en AM7 te donnera =NB.SI(D7:AG7;"CA") tandis que
la recopie en AL8 te donnera =NB.SI(C8:AG8;"CA").
Et au lieu d'écrire chaque fois "CA" ou "RTT" il est plus productif de faire référence à la ligne 6.
Ainsi en AL7 ta formule sera =NB.SI($C7:$AG7;$6:$6)
qui restera =NB.SI($C7:$AG7;$6:$6) dans les cellules AM7 à AV7 et
deviendra =NB.SI($C8:$AG8;$6:$6) dans les cellules AL8 à AV8.
Oui d'accord je vois le principe même si c'est pas évident pour moi. En ce qui concerne les cellules, comment puis je avoir tout le temps une cellule de 20 de haut par exemple avec en liste déroulant les congés et que cela me fasse dans la même cellule 2 cellule de 10 de haut pour mes congé en "demi", pour pouvoir soit poser qu'une parti de la journée soit posé une demi journée avec tel type de congé et une autre demi avec un autre type de congé. Exemple Lundi 25 mars 2019: 1/2 CP et 1/2 RTT (soit la journée complète mais en 2 demi).

Cordialement M.Pentier
Raymond PENTIER
Messages postés
47696
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
16 décembre 2018
-
... donc tu fais un copier-coller de la cellule AL7 dans toutes les cellules AL7:AV13 ; AL21:AV27 ; AL35:AV41 etc.

Mais il y a une anomalie : les cellules en AL6:AV6 ; AX6:BG6 ; AL21:AV21 etc devraient avoir les mêmes données que la liste "congé" en BK2:BK14, ce qui n'est pas le cas !
Les résultats de mes formules sont donc partiellement faux, forcément.
Commenter la réponse de Raymond PENTIER