Menu

Formule pour facture

Messages postés
6
Date d'inscription
vendredi 2 novembre 2018
Dernière intervention
4 décembre 2018
- - Dernière réponse : DjiDji59430
Messages postés
2150
Date d'inscription
samedi 19 avril 2008
Dernière intervention
8 décembre 2018
- 5 déc. 2018 à 16:31
Bonjour,

Je souhaite faire une facture semi-automatique à partir d'un planning de production.
Les 2 documents sont dans le même document sur 2 feuilles différentes.
Mon tarif varie en fonction de la quantité livrée (supérieur ou égale à 100kg et inférieur à 100kg) et en fonction du type de produit cerneaux de noix bio ou conventionnels

L'idéal serait de sélectionner sur la facture via un menu déroulant le nom du client (ça j'ai réussi). Une fois le clients choisi, dans la colonne date de production il faudrait que j'ai accès aux dates de production du client via un menu déroulant. Je choisi donc les dates de production que je souhaite facturer et si j'ai plusieurs dates comme ici pour monsieur moulin patrick. Il me faut une seule ligne par date de production donc une synthèse. Et dans ce cas présent si on ajoute les 2 jours de production on est supérieur à 100kg ce qui doit modifier le tarif.

Planning de production:


Extrait facture:


Merci pour votre aide. Je peux faire passer un fichier si c'est plus simple.
Afficher la suite 

Votre réponse

4 réponses

Messages postés
9956
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
10 décembre 2018
0
Merci
Bonsoir,

Oui il faut ton fichier pour avoir une base de travail
Poste le sur cjoint.com, fais créer un lien, copies le et reviens le coller ici

Dans l'attente
Cdlmnt
Via
Commenter la réponse de via55
Messages postés
6
Date d'inscription
vendredi 2 novembre 2018
Dernière intervention
4 décembre 2018
0
Merci
https://www.cjoint.com/c/HLdhSdeGuKr

Voici le lien de mon fichier
Commenter la réponse de kiou26
Messages postés
9956
Date d'inscription
mercredi 16 janvier 2013
Dernière intervention
10 décembre 2018
0
Merci
Re

Si j’ai bien compris, en E18 de la facture mettre la formule :
=RECHERCHEV(B18;$G$21:$I$23;SI($C$21<100;2;3);0)

Cdlmnt
Vai
Commenter la réponse de via55
Messages postés
2150
Date d'inscription
samedi 19 avril 2008
Dernière intervention
8 décembre 2018
0
Merci
Bonjour a vous deux

J'ai amélioré(?) un peu. Est ce suffisant ?

https://www.cjoint.com/c/HLdlETiEDA5

Crdlmt
kiou26
Messages postés
6
Date d'inscription
vendredi 2 novembre 2018
Dernière intervention
4 décembre 2018
-
Bonsoir,

On y est presque bravo, il faudrait enlever le menu déroulant de la colonne B pour que le saisie soit liée au client comme pour les autres colonnes.
Et peut-on envisager que les lignes produites le même jour soient regroupées une seul ligne.

Merci d'avance

Cdt

Séverine Belle
DjiDji59430
Messages postés
2150
Date d'inscription
samedi 19 avril 2008
Dernière intervention
8 décembre 2018
-
Re

https://www.cjoint.com/c/HLfpBvq4GPM

regarde le tcd, c'est intéressant (Ça peut te faire des bilans, des statistique, tu peux filtrer, etc, sans toucher a ta base.
Parce que le principe d'une base de donnée, que tu as appelée Prestation, c'est d'etre remplie, au fil de l'eau, et on en extrait après, par différents moyens, les informations que l'on désire

Crdlmt
Commenter la réponse de DjiDji59430