Menu

Compter le nombre fois qu'une occurence apparait suivant 2 critères [Résolu]

Messages postés
1364
Date d'inscription
lundi 28 janvier 2008
Dernière intervention
18 février 2019
- - Dernière réponse : Mike-31
Messages postés
16855
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 février 2019
- 11 nov. 2018 à 20:27
salut,

le tableau sur google sheet est composé ainsi
feuille 1 : les réponses d'un formulaire
colonne A date
colonne B lieu
colonne C à Z des noms
feuille 2 : un récap
ligne 1 les differents lieux
colonne A les differentes personnes
je voudrais faire le cumul par personne par lieu donc en case B2 savoir le nombre de fois que l'on a vu la personne en A2 dans le lieu B1
j'ai donc fait :
=countifs('feuille 1'!C2:Z100;A2;'feuille 1'!B2:B100;B1)
et ça me donne
Erreur
Les arguments de tableau de la fonction COUNTIFS ne sont pas de la même taille.

merci de votre lumière

--
Afficher la suite 

Votre réponse

2 réponses

Messages postés
16855
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 février 2019
5034
0
Merci
Bonjour,

sous réserve d'avoir bien compris
nom titi lieu A
=SOMMEPROD((Feuil1!C1:Z1="titi")*(Feuil1!B2:B10="A")*(Feuil1!C2:Z10<>""))
mais tu aurais intérêt à nommer tes plages
exemple
Feuil1!C1:Z1 nommé Nom
Feuil1!B2:B10 nommée Col_b
Feuil1!C2:Z10 nommé Plag
la formule devient
=SOMMEPROD((Nom="titi")*(Col_b="A")*(Plag<>""))

et si tu mets tes critères nom et lieu dans deux cellules exemple en AA1 et AA3
la formule devient
=SOMMEPROD((Nom=AA1)*(Col_b=AA3)*(Plag<>""))

et en Anglais SOMMEPRD devient SUMPRODUCT ce qui devrait donner
=SUMPRODUCT((Nom=AA1)*(Col_b=AA3)*(Plag<>""))
votre psychiatre
Messages postés
1364
Date d'inscription
lundi 28 janvier 2008
Dernière intervention
18 février 2019
337 -
merci ça a l'air de fonctionner
Commenter la réponse de Mike-31
Messages postés
16855
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 février 2019
5034
0
Merci
Re,

alors je passe le statut de la discussion en résolu, mais n'hésite pas d'y revenir si tu rencontres un problème
Commenter la réponse de Mike-31