Formule avec condition date [Résolu/Fermé]

Signaler
Messages postés
32
Date d'inscription
lundi 21 mai 2012
Statut
Membre
Dernière intervention
23 décembre 2019
-
 lili03410 -
Bonsoir à toutes et tous,

Voilà je bute sur 1 formule avec une date.

formule souhaitée : si la date saisie en A1 est inférieur au 01/04/2014 alors B1 = 20550 sinon 21375 mais si A2 coché alors B1 = 29225 sinon 28770

11 réponses

Messages postés
17087
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 mars 2020
3 910
Bonsoir,

qu'entends tu par mais si A2 coché
Bonsoir Mike

A2 cochée avec un X
Messages postés
17087
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 mars 2020
3 910
Re,

alors comme cela

=SI(A1<"01/04/2018";20550;SI(A1="X";29225;28770))

mais attention si A1 est vide Excel la considère comme 0 comme une date 00/01/1900
pour éviter cela je te conseille de traiter la cellule vide

=SI(A1="";"";SI(A1<"01/04/2018";20550;SI(A1="X";29225;28770)))
Super merci Mike
Mike

La formule ne fonctionne pas :-(
Messages postés
17087
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 mars 2020
3 910
Re,
je ne comprends pas, tu dis Super merci ce qui laisse présager que ça fonctionne, puis la formule ne fonctionne pas ce qui ne fait pas avancer si tu ne donnes pas d'explication sur le dysfonctionnement.
l'idéal serait que tu crées un exemple de fichier anonymisé et que tu le joignes à la discussion
pour joindre ton fichier
1) Tu vas dans https://www.cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers

dans le même style tu as https://mon-partage.fr/
Désolée Mike pour ma réponse précipitée. Je te remerciais pour la formule mais il est vrai que je ne l'avais pas encore testée :-(

Je t'écris la formule souhaitée par rapport aux cellules du fichier ci-joint :

si la date en Z10 est inférieur au 01/04/2014 alors la cellule I42 doit afficher 20550 sinon I42 doit afficher 21375 MAIS si la cellule N34 est coché par un X alors I42 doit afficher 29225 sinon I42 affiche 28770

https://www.cjoint.com/c/HJwq7I587WD
Messages postés
17087
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 mars 2020
3 910
Re,

ta demande est différente de ta demande initiale et donc normal que la formule ne fonctionne pas.

une petite précision
pas de problème si Z10 est inférieure au 01/14/2014, mais si Z10 est inférieure au 01/04/2014 et que N34 est cochée, quelle valeur faut il afficher

et si la date en Z10 est supérieure au 01/04/2014 et N34 est cochée que faut il afficher
Si Z10 inférieure au 01/04/2014 et que N34 est coché il faut afficher 29225

Si Z10 supérieure au 01/04/2014 et que N34 est coché il faut afficher 28770
Mike-31
Messages postés
17087
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 mars 2020
3 910
pour construire la formule il me manque deux possibilités, ta réponse s'est croisée avec mes 4 questions
Messages postés
17087
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 mars 2020
3 910
Re,

peux tu répondre à ces 4 cas de figure s'il te plait

si Z10 est inférieure au 01/04/2014, mais N34 est cochée quelle valeur faut il afficher

Si Z10 est inférieure au 01/04/2014, mais N34 est décochée quelle valeur faut il afficher

mais si Z10 est supérieure au 01/04/2014, mais N34 est cochée quelle valeur faut il afficher

et si Z10 est supérieure au 01/04/2014 et N34 est décochée quelle valeur faut il afficher

Si Z10 < au 01/04/2014 mais N34 coché alors I42 doit afficher 29225

Si Z10 < au 01/04/2014 mais N34 décoché alors I42 doit afficher 21375

Mais si Z10 > au 01/04/2014 mais N34 coché alors I42 doit afficher 28770

Et si Z10 > au 01/04/2014 mais N34 décoché alors I42 doit afficher 20550
Messages postés
17087
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 mars 2020
3 910
Re,

voilà essaye comme cela
=SI(ET(Z10<"01/04/2014";N34="x");29225;SI(ET(Z10<"01/04/2014";N34="");21375;SI(ET(Z10>"01/04/2014";N34="x");28770;SI(ET(Z10>"01/04/2014";N34="");20550;""))))

reste à savoir si Z10 est inférieur et égale à 01/04/2018
ou si Z10 est supérieur et égale à 01/04/2014 il faut impérativement qu'un des deux cas soit traité avec égale sinon la date 01/04/2014 ne sera pas traité dans le cas d'une naissance à cette date
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Z10 supérieure et égale au 01/04/2014
Messages postés
17087
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 mars 2020
3 910
Re,

j'ai répondu trop rapidement et la formule a une erreur,
prend celle ci

=SI(ET(Z10<"1/4/2014"*1;N34="x");29225;SI(ET(Z10<"1/4/2014"*1;N34="");21375;SI(ET(Z10>="1/4/2014"*1;N34="x");28770;SI(ET(Z10>="1/4/2014"*1;N34="");20550;""))))
Messages postés
17087
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 mars 2020
3 910
Pour ma part j'ajouterais une conditionnelle pour traiter le cas ou la cellule Z10 est vide

=SI(Z10="";"";SI(ET(Z10<"1/4/2014"*1;N34="x");29225;SI(ET(Z10<"1/4/2014"*1;N34="");21375;SI(ET(Z10>="1/4/2014"*1;N34="x");28770;SI(ET(Z10>="1/4/2014"*1;N34="");20550;"")))))
Z10 soit obligatoirement être remplir donc je vais tester l'avant dernière formule
Mike-31
Messages postés
17087
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 mars 2020
3 910
Comme tu veux mais pour ma part je prendrais la dernière formule, si tu as au départ un formulaire vierge ou si Z10 est vide Excel considérera la valeur de cette cellule comme < au 01/04/2014 et affichera 29225 ou 21375
Coucou Mike,

Je viens de tester ta formule et elle fonctionne.

Merci pour ton aide ;-)