Menu

Calculer nbde valeurs différentes avec conditions [Résolu]

Messages postés
5
Date d'inscription
vendredi 7 septembre 2018
Dernière intervention
11 septembre 2018
- 7 sept. 2018 à 14:50 - Dernière réponse :
Messages postés
5
Date d'inscription
vendredi 7 septembre 2018
Dernière intervention
11 septembre 2018
- 11 sept. 2018 à 11:22
Bonjour,

J'ai un pb que je n'arrive pas à résoudre malgrès les recherches sur internet et j'ai besoin de votre aide :

Je souhaite calculer le nombre de valeurs (dates) différentes dans ma colonne, mais en tenant compte d'un critère lié à une autre colonne.
Exple :
A / b / c
agence / nom / date
69 / tartempion / 01-01-18
69/ nicole / 01-01-18
69/ jean /
69 / gérard / 25-6-18
42 / rose /
42 / tim / 3-05-18

je voudrais calculer (avec fonctions et non VBA que je ne maîtrise pas) le nombre de dates différentes pour l'agence 69, soit 2 (et idem pour l'autre agence 42 dont le résultat attendu serait 1)

Dans la colonne C j'ai des cellules vides.

J'ai trouvé une formule qui calcule le nb de cellules différente en C mais qui ne tient pas compte de mon critère agence. J'ai essayé en imbriquant des somme.si mais cela génère une erreur.

Merci pour votre aide précieuse
Afficher la suite 

Votre réponse

7 réponses

Messages postés
22994
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 novembre 2018
- 7 sept. 2018 à 14:59
0
Merci
Bonjour
pour rester simple, vous pouvez créer une colonne qui concatène l'agence et la date (par ex: =A1&B1) et appliquer votre formule à cette colonne
et si vous voulez éliminer les vides en C:
=SI(C1="";"";A1&C1)
crdlmnt
Commenter la réponse de Vaucluse
Messages postés
5
Date d'inscription
vendredi 7 septembre 2018
Dernière intervention
11 septembre 2018
- 7 sept. 2018 à 15:39
0
Merci
Bonjour et merci pour la réactivité !

J'ai essayé sur mon fichier, mais je me retrouve avec le même problème dans ma nouvelle colonne concaténée : je dois intégrer dans ma formule 2 conditions : celle de l'agence (69, 42...) et celle des valeurs différentes (dates transformées en nb).
Sachant aussi que rajouter une colonne ne m'arrange pas vraiment car je dois faire la même manipulation pour les 60 colonnes suivantes (+ les nouvelles à venir): ajouter une colonne pour concaténer x 60...

si ce n'est pas clair dites-le moi ;)
cdt
Messages postés
22994
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 novembre 2018
- 7 sept. 2018 à 15:59
je comprend que vous vouliez compter le nombre de références avec des dates différentes, ce que ne fait pas ma première proposition
toujours avec une colonne de renvoi, je vous propose :
de créer cette colonne avec cette formule, si les ref commencent en A2 et les dates en B2, en C2 à tirer
=SI(NB.SI.ENS($A$2:A2;A2;B2:$B$2:B2;B2)=1;A2;"")
et compter ensuite combien il y a de référence dans le résultat avec un tableau et NB.SI(C:C;ref cherchée)
mais je en vois pas très bien ce que vous devez faire avec les 60 colonnes, ni ou vous voulez afficher les résultats
est il possible d'avoir un petit bout de votre modèle pour aider ceux qui voudront bien s'attaquer au problème (je regardes sans colonne ajoutée, mais je ne suis pas sur d'avoir la solution)
crdlmnt
Commenter la réponse de mio69
Messages postés
5
Date d'inscription
vendredi 7 septembre 2018
Dernière intervention
11 septembre 2018
- 10 sept. 2018 à 11:34
0
Merci
Bonjour,

Voici un extrait - très réduit en nombre de lignes et de colonnes - pour mieux comprendre ma demande.
Je voudrais connaître, sous chacune des colonnes (causerie), combien de causeries ont été réalisées pour chacune des agences :
https://www.cjoint.com/c/HIkjG6Qp7vr

j'espère que ce sera plus clair ;)
Commenter la réponse de mio69
Messages postés
22994
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 novembre 2018
- 10 sept. 2018 à 12:22
0
Merci
Bonjour
essayez de déposer ici
mon AV a des soucis avec cjoint et je ne veux pas le contrarier
http:mon-partage.fr
crdlmnt
Commenter la réponse de Vaucluse
Messages postés
5
Date d'inscription
vendredi 7 septembre 2018
Dernière intervention
11 septembre 2018
- 10 sept. 2018 à 12:52
0
Merci
voici un nouveau lien :
https://mon-partage.fr/f/2w8XVrp2/
Commenter la réponse de mio69
Messages postés
5
Date d'inscription
vendredi 7 septembre 2018
Dernière intervention
11 septembre 2018
- 11 sept. 2018 à 11:22
0
Merci
Bonjour,

J'ai trouvé les réponses à mon problème sur le forum de excel-downloads sujet "Calculer nombre de valeur différente avec condition(s)"

Merci pour votre aide
Commenter la réponse de mio69