Menu

Comment ne pas faire apparaitre #N/A [Résolu]

laerous - 12 juil. 2017 à 11:31 - Dernière réponse : Vaucluse 21878 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention
- 17 juil. 2017 à 12:18
bonjour,

Je souhaiterais ne pas faire apparaitre dans mes cellules #N/A qui s'affichent suite à une formule RECHERCHEV.
J'ai plusieurs cellules qui contiennent cette formule et qui se retrouvent, lorsqu'il n'y a pas de réponse, avec #N/A.
Au bout de ma ligne, j'ai également rajouté une formule CONCATENER. Cependant j'ai inséré une dernière colonne avec NBVAL afin de comptabiliser le nombre de cellule remplie avec CONCATENER.
Seulement NBVAL me comptabilise également les cellules avec #N/A.
Je souhaiterais uniquement que NBVAL me calcule le nombre de cellule non vide mais sans prendre en compte les cellules contenant #N/A.

Je vous remercie par avance pour votre aide.

bien cordialement
Afficher la suite 

6 réponses

Répondre au sujet
Vaucluse 21878 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - Modifié par Vaucluse le 12/07/2017 à 11:39
0
Utile
Bonjour

avec Excel >= 2007

=SIERREUR(RECHERCHEV(........K.);"")
toutefois, cette option vous enlèvera les affichages #N/A, mais sera quand même compter par le code NB.VAL

pour compter le nombre de cellules sans erreur (donc différentes du résultats "":

=NB.SI(Champ;"><")
à notre que cette formule élimine aussi les cellules avec #N/A et donc que vous pouvez aussi conserver votre affichage


respectez bien le sens des >< car avec NB.SI,, "><") compte les cellules #"" et "<>" compte toutes les cellules ayant une formule quelque soit le résultat


crdlmnt


La qualité de la réponse dépend surtout de la clarté de la question, merci!
Commenter la réponse de Vaucluse
0
Utile
Merci Vaucluse ca fonctionne parfaitement bien, vous êtes vraiment incollable et d'une aide très précieuse.

bien cordialement
Commenter la réponse de laerous
0
Utile
@Vaucluse,

J'ai le même soucis via une autre formule. =SIERREUR(RECHERCHEV($A4;GLOBAL!$A$4:$CY$82;COLONNE();0);"")
lorsqu'il n'y a rien a afficher la cellule reste vide, mais en bout de ligne lorsque je mets CONCATENER, dans mes cellules vides apparait des 0 (zéro) et non pas #N/A. Du coup j'ai bien pensé à aller dans les options pour enlever l'affichage des 0 (zero), j'ai également changé la formule que vous m'avez indiqué tout à l'heure en indiquant 0 à la place >< =NB.SI(DA4:DI4;"0") il me trouve 7 cellules au lieu de 2
j'ai même essayé =NB.SI(DA4:DI4;""), malheureusement ce là m'indique 9 au lieu de 2

merci encore
Commenter la réponse de laerous
Vaucluse 21878 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - Modifié par Vaucluse le 12/07/2017 à 17:12
0
Utile
Bonjour

s'il apparaît des 0 en résultats c'est que la formule de recherche dans la cellule n'est pas en erreur renvoi bien 0. Donc, cela veut dire qu'elle trouve la valeur A4 cherchée en GLOBAL A4:A82, mais que la valeur à renvoyer _en position COLONNE() est vide

Deux solutions alors pour ne pas afficher les 0

soit dans chaque cellule
=SIERREUR(SI(RECHERCHEV($A4;GLOBAL!$A$4:$CY$82;COLONNE();0)=0;"";RECHERCHEV($A4;GLOBAL!$A$4:$CY$82;COLONNE();0));"")

ou alors dans la concaténation:

=SI(A1=0;"";A1)&SI(A2=0;"";A2)&SI(A3=0;"";A3)...etc..

crdlmnt

Ps: en complément, j"avais zappé le fait que vous comptiez les valeurs :


=NB.SI(champ;"><")+NB.SI(champ;0)

devrait faire l'affaire

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Commenter la réponse de Vaucluse
0
Utile
1
merci beaucoup Vaucluse

bien à vous
Vaucluse 21878 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 23 avril 2018 Dernière intervention - 17 juil. 2017 à 12:18
Pas de quoi
si votre problème est résolu, merci de le pointer comme tel (en dessous du titre en haut du fil)
Bonne route
crdlmnt
Commenter la réponse de laerous