VPN IPSEC cisco packet tracer [Fermé]

Signaler
Messages postés
49
Date d'inscription
mardi 31 mars 2015
Statut
Membre
Dernière intervention
6 septembre 2017
-
DubSteal
Messages postés
49
Date d'inscription
mardi 31 mars 2015
Statut
Membre
Dernière intervention
6 septembre 2017
-
Bonjour, j'ai monté un VPN IPSEC entre 2 site sur packet tracer. j'ai un problème et je n'arrive pas à trouver la solutions. SI une personne peut m'aider.
Mon problème est que : J'ai 3 routeur dont 1 considéré comme un "WAN" ils sont rélié via les port sérial. Si je ping de routeur a routeur, cela fonctionne bien. Donc il passe bien par le VPN. Cependant si j'essaye avec un ordinateur, j'ai une réponse du routeur Wan "Reply from 80.1.0.1: Destination host unreachable". Comment est-ce possible ? Sachant que le seul endroit ou il peut envoyer la trame et le routeur de l'autre coté. Je vais vous donner mes running config. Pour voir si vous voyez un problème...

SERIAL 0/0/0 de WAN vers R3 ou de R3 vers WAN
SERIAL 0/0/1 De WAN vers R1 ou de R1 vers WAN

Routeur 1 :

Building configuration...

Current configuration : 1305 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Euro-BGN
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
ip address 192.168.0.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
no ip address
clock rate 2000000
!
interface Serial0/0/1
ip address 80.1.0.2 255.255.255.252
ip nat outside
clock rate 2000000
!
interface Ethernet0/1/0
ip address 192.168.10.254 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
ip nat inside source list 100 interface Serial0/0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 80.1.0.1
!
ip flow-export version 9
!
!
access-list 100 deny ip 192.168.0.0 0.0.0.255 172.16.0.0 0.0.0.255
access-list 100 permit ip 192.168.0.0 0.0.0.255 any
access-list 100 permit ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
ip access-list extended VPN
permit ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
permit ip 172.16.0.0 0.0.0.255 192.168.0.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Routeur WAN :


Current configuration : 1174 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname WAN
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
crypto isakmp policy 10
encr aes
authentication pre-share
group 2
!
crypto isakmp key CiscoLab address 80.2.0.2
!
!
crypto ipsec security-association lifetime seconds 86400
!
crypto ipsec transform-set VPNSET esp-aes esp-sha-hmac
!
crypto map VPNMAP 10 ipsec-isakmp
set peer 80.2.0.2
set security-association lifetime seconds 86400
set transform-set VPNSET
match address VPN
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
interface Serial0/0/0
ip address 80.2.0.1 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
ip address 80.1.0.1 255.255.255.252
crypto map VPNMAP
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
ip access-list extended VPN
permit ip 192.168.0.0 0.0.0.255 172.16.0.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end


Routeur 3 :


Current configuration : 1720 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Euro-ORL
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
crypto isakmp policy 10
encr aes
authentication pre-share
group 2
!
crypto isakmp key CiscoLab address 80.1.0.2
!
!
crypto ipsec security-association lifetime seconds 86400
!
crypto ipsec transform-set VPNSET esp-aes esp-sha-hmac
!
crypto map VPNMAP 10 ipsec-isakmp
set peer 80.1.0.2
set security-association lifetime seconds 86400
set transform-set VPNSET
match address VPN
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
ip address 172.16.0.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 80.2.0.2 255.255.255.252
ip nat outside
crypto map VPNMAP
!
interface Serial0/0/1
no ip address
clock rate 2000000
!
interface Ethernet0/1/0
ip address 192.168.20.254 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
no auto-summary
!
ip nat inside source list 100 interface Serial0/0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 80.2.0.1
ip route 192.168.20.0 255.255.255.0 Ethernet0/1/0
!
ip flow-export version 9
!
!
ip access-list extended VPN
permit ip 192.168.20.0 0.0.0.255 192.168.10.0 0.0.0.255
access-list 100 deny ip 172.16.0.0 0.0.0.255 192.168.0.0 0.0.0.255
access-list 100 permit ip 172.16.0.0 0.0.0.255 any
access-list 100 permit ip 192.168.20.0 0.0.0.255 192.168.10.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end


Je sais qu'il y a quelques ACL qui ne servent à rien. Mais ne dérange en rien le VPN sachant que c'est du permit.
Merci d'avance pour votre aide. Si besoin, je peux envoyer le fichier.

Cordialement

1 réponse

Messages postés
120
Date d'inscription
jeudi 29 juin 2017
Statut
Membre
Dernière intervention
26 octobre 2018
12
Bonsoir,

J'essaie de faire votre config.
DubSteal
Messages postés
49
Date d'inscription
mardi 31 mars 2015
Statut
Membre
Dernière intervention
6 septembre 2017
18 > Hannie7205
Messages postés
120
Date d'inscription
jeudi 29 juin 2017
Statut
Membre
Dernière intervention
26 octobre 2018

Encore merci à toi, je veux bien les routes manquantes.. mais il n'y a pas que les routes par défaut normalement ?
Hannie7205
Messages postés
120
Date d'inscription
jeudi 29 juin 2017
Statut
Membre
Dernière intervention
26 octobre 2018
12 > DubSteal
Messages postés
49
Date d'inscription
mardi 31 mars 2015
Statut
Membre
Dernière intervention
6 septembre 2017

Non, il faut toutes les routes.

Euro-BGN
route par défaut que vous avez écrit 0.0.0.0/0 via 80.1.0.1
8.2.0.0/30 via 80.1.0.1

WAN
192.168.20.0/24 via 80.2.0.2
192.168.10.0/24 via 80.1.0.2

Euro-ORL
0.0.0.0 via 80.2.0.1
8.1.0.0/30 via 80.2.0.1
La route 192.168.20.0/24 via Ethernet 0/1/0 est inutile
DubSteal
Messages postés
49
Date d'inscription
mardi 31 mars 2015
Statut
Membre
Dernière intervention
6 septembre 2017
18 > Hannie7205
Messages postés
120
Date d'inscription
jeudi 29 juin 2017
Statut
Membre
Dernière intervention
26 octobre 2018

Mais du coup, ce n'est plus du VPN site a site, mais du routage ? Enfin c'est l'impression que ça donne. Car du coup je déclare les routes..
Hannie7205
Messages postés
120
Date d'inscription
jeudi 29 juin 2017
Statut
Membre
Dernière intervention
26 octobre 2018
12 > DubSteal
Messages postés
49
Date d'inscription
mardi 31 mars 2015
Statut
Membre
Dernière intervention
6 septembre 2017

Ce sont deux choses différentes en effet.
Avec le routage, vous pouvez avoir une réponse au ping entre deux ordinateurs situés sur deux sites séparés par un wan comme vous le demandiez. Je ne saurais pas mettre en place le VPN sur PacketTracer et je ne sais pas comment voir en simulation s'il y a du VPN entre deux ordinateurs puisque ce n'est pas une question de réseau.
DubSteal
Messages postés
49
Date d'inscription
mardi 31 mars 2015
Statut
Membre
Dernière intervention
6 septembre 2017
18
D'accord, merci quand même. Et oui je me suis mal exprimé dans ma demande. Merci d'avoir pris le temps.