Menu

Formule renvoit une valeur - 0,00 [Résolu/Fermé]

soum75 3 Messages postés mardi 18 avril 2017Date d'inscription 18 avril 2017 Dernière intervention - 18 avril 2017 à 10:25 - Dernière réponse : soum75 3 Messages postés mardi 18 avril 2017Date d'inscription 18 avril 2017 Dernière intervention
- 18 avril 2017 à 11:27
Bonjour,
j'ai une formule qui me renvoit une valeur - 0,00 suite à des opérations simples d'addition et soustraction (=I9-(L9+J9+N9)-Q9-R9)
le problème survient lorsque R9 est vide mais pour une seule ligne sur tout un ensemble.
quequ'un peut-il m'aider s'il vous plait?
merci
Afficher la suite 

4 réponses

Vaucluse 22003 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 22 mai 2018 Dernière intervention - 18 avril 2017 à 10:39
0
Utile
Bonjour
le problème viens surement des valeurs des cellules prises en compte, mais sans savoir ce qu'elles contiennent, difficile de vous aider!
à vous lire
crdlmnt
soum75 3 Messages postés mardi 18 avril 2017Date d'inscription 18 avril 2017 Dernière intervention - 18 avril 2017 à 11:26
Bonjour Vaucluse et merci pour votre réponse.
J'ai utilisé la solution d'arrondi (=arrondi(I9-(L9+J9+N9)-Q9-R9;12)) proposée par eriiic et ça a marché.
Cordialement
eriiic 21604 Messages postés mardi 11 septembre 2007Date d'inscriptionContributeurStatut 22 mai 2018 Dernière intervention - 18 avril 2017 à 11:16
0
Utile
Bonjour,

c'est dû aux problèmes de perte de précision dues aux conversions décimal/binaire.
=arrondi(I9-(L9+J9+N9)-Q9-R9;12)

eric
soum75 3 Messages postés mardi 18 avril 2017Date d'inscription 18 avril 2017 Dernière intervention - 18 avril 2017 à 11:27
Bonjour Eriiic et merci
Votre solution a fonctionné impeccablement et a résolu mon problème.
Cordialement