Ajouter une valeur dans une formule NB.SI.ENS [Résolu/Fermé]

Signaler
-
 Serocelot -
Bonjour,
Voici la formule inscrite dans la colonne B mon tableau :

=SI(C3<>"";SI(NB.SI.ENS($C$3:C3;C3;$P$3:P3;"")=1;1;0);"")

Signifiant que lorsque ma colonne P est remplie, ma colonne B affichera 0.
Je voudrais réécrire cette formule de sorte que ma colonne B affiche 0 soit lorsque P est remplie OU lorsque Q est remplie.... Donc ce serait la même base mais en prenant également en compte la colonne Q...

Merci de votre aide !!!

1 réponse

Messages postés
51044
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 février 2020
12 225
Bonjour.

Tu as certainement une bonne raison pour utiliser une formule aussi compliquée, alors que la formule
=SI(C3="";"";SI(ET(C3<>0;P3<>0);0;1)) suffit amplement.
Et alors la formule que tu demandes serait
=SI(C3="";"";SI(ET(C3<>0;OU(P3<>0;Q3<>0));0;1))

Mais si tu tiens absolument à conserver la structure de ta formule initiale, il faudrait l'écrire =SI(C3<>"";SI(NB.SI.ENS($C$3:C3;C3;$P$3:P3;""; $Q$3:Q3;"")=1;1;0);"")

C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
Helas je suis obligée de continuer à utiliser la formule dont je parlais car elle me permet de prendre en compte des doublons en les signalant par 1 et 0 et que lorsque je remplis la colonne P (et la Q normalement) d'un doublon, celui qui n'a pas la colonne P (ou Q) complétée devienne le 1... Un peu complexe je sais --'
Merci beaucoup !
Raymond PENTIER
Messages postés
51044
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 février 2020
12 225 > Serocelot
Mais ma formule aussi !
Tu ne l'as donc même pas testée ?
Ta formule fonctionne mais n'a pas toutes les fonctionnalités de l'autre car lorsque j'ai deux stocks du même produit il faut que le premier stocksoit associé à 1 et le deuxième stock à un 0. Et si le premier stock est vendu, il faut qu'il soit associé à un 0 et que le second stock du produit soit alors associé à un 1. Et si le deuxième stock est vendu, il faut que tous les stocks soient associés à 0 !