Rechercher un nom dans une liste [Fermé]

- - Dernière réponse : Mike-31
Messages postés
16932
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
10 septembre 2019
- 29 janv. 2016 à 16:30
bonsoir chers amis j'ai une liste de ma classe sur excel je voudrais un code VBA pour rechercher rapidement l'identité ( nom et prenom) de l'élève à partir de son matricule. juste vous dire avoir un code pour créer un bouton (rechercher) qui va me permettre une fois je clique sur le bouton recherche la fenetre s'affiche je mets le matricule de l'élève et je le retrouve en meme temps. Aidez moi s'il vous plait. meilleurs voeux à tous. sylla
Afficher la suite 

3 réponses

Messages postés
16932
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
10 septembre 2019
3584
0
Merci
Bonjour,

tu n'as pas besoin de VBA pour ça

exemple tu saisis le matricule de l'élève ou tu crées une liste de validation exemple en F2 avec une rechercheV exemple en G2 =RECHERCHEV(F2;ta base de donnée;colonne de recherche;0)

exemple ta base de données est de A1 à E50 et colonne A tes matricules, pour rechercher la valeur colonne B
=RECHERCHEV(F2;A1:E50;2;0)
pour afficher la valeur de la colonne C
=RECHERCHEV(F2;A1:E50;3;0)

si ta matrice est sur une autre feuille nomme la exemple List, la formule devient
=RECHERCHEV(F2;List;2;0) pour récupérer les données de la colonne B
=RECHERCHEV(F2;List;3;0) pour récupérer les données de la colonne C etc ...

il est possible d'améliorer la formule avec une gestion d'erreur pour éviter l'affichage #N/A
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
-
merci mike -31 je vais l'essayer merci
Messages postés
24355
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 septembre 2019
4752
0
Merci
Bonjour
vous êtes sur que vous voulez du VBA? parce que avec une base de données, un menu déroulant et une formule, ça va tout seul et c'est simple

Base de données en Feuil1:
Matricule en A, nom en B, prénom en C etc... allons jusqu'à Z pour des infos
__nommer le champ A par exemple: Matricule (sélectionnez le champ et inscrivez le nom voulu dans la case adresse à droite de la barre de formule et entre

dans la feuille d'édition
_ sélectionnez la cellule matricule supposons A2
___Ruban / Données / Validation / Cadre du haut: liste cadre du bas: =Matricule
votre cellule affichera la liste pour choisir lorsque vous sélectionnerez la flèche affichée à droite

en B2:
RECHERCHEV($A2;Feuil1!$A:$Z;2;0) pour ressortir la valeur de B

...;3;0) pour la valeur de C en C2, ect avec le N° de colonne dans le champ
ou alors s'il y en a beaucoup dans la, ligne, la formule "universelle" à tirer vers la droite:

=RECHERCHEV($A2;Feuil1!$A:$Z;COLONNE(B$1);0)

et pour éviter un affichage #N/A si A2 est vide:

=SI(A2="";"";RECHERCHEV($A2;Feuil1!$A:$Z;COLONNE(B$1);0))

attention aux signes $

crdlmnt


-
merci vaucluse je vais l'essayer merci infiniment
Messages postés
16932
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
10 septembre 2019
3584
0
Merci
Re,

Si tu rencontres un problème, construit un exemple de fichier anonymisé et joint le à une réponse à partir de ce lien
http://www.cjoint.com/