Fonction SI avec date du jour [Résolu/Fermé]

Messages postés
5
Date d'inscription
mercredi 2 juillet 2014
Statut
Membre
Dernière intervention
21 janvier 2016
- - Dernière réponse : -KiraSama-
Messages postés
5
Date d'inscription
mercredi 2 juillet 2014
Statut
Membre
Dernière intervention
21 janvier 2016
- 21 janv. 2016 à 16:25
Bonjour à tous,

Voila maintenant plusieurs semaines que je bloque sur un problème. J'ai ratissé Internet en long et en large mais personne ne semble avoir la même problématique que moi (à force de vouloir pas faire comme les autres :-)).

Bref, voici mon problème :

J'ai en stock des produits alimentaires périssables et je souhaite en faire un inventaire plus précis. Je peux envoyer ces produits à mes clients si le produit à encore 8 mois de durée de vie par rapport à la date de fabrication. Donc que le produit soit vieux de 4 mois maximum (la date de péremption "DLUO" de ces produits est de 12 mois).

Mon problème est que je n'arrive pas à créer une formule qui me permettrait de savoir, en un seul coup d'oeil, si je peux ou non envoyer le produit en fonction de la date du jour en ouvrant le fichier excel (j'ai 500 références environ et ne peux pas les vérifier une à une régulièrement).

Exemple :

Date de fabrication du produit: 01/01/2016
DLUO : 01/01/2017
date du jour : 01/10/2016
Je ne peux pas envoyer le produit au client car le produit à 9 mois (ou il ne me reste plus que 3 mois de DLUO).

Dans une case "possibilité envoi client" avec une formule SI, je voudrait donc qu'il y ait "Non" car le produit à plus de 8 mois par rapport à la date de fabrication et la date du jour (avec une case =AUJOURDHUI() ).

Merci d'avance pour votre aide à tous (j'espère avoir été assez clair !).

Bonne journée. :-)

PS : j'utilise Excel 2013


Afficher la suite 

2 réponses

Messages postés
24565
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2019
4822
0
Merci
Bonjour

avec la date de fabrication du produit en A1, voyez si cela peut faire l'affaire

=SI(DATE(ANNEE(A1);MOIS(A1)+8;JOUR(A1))<AUJOURDHUI();"non";"oui")

vous pouvez aussi utiliser cette formule dans une MFC pour mettre en surbrillance les lignes non livrables.

crdlmnt



La qualité de la réponse dépend surtout de la clarté de la question, merci!
-KiraSama-
Messages postés
5
Date d'inscription
mercredi 2 juillet 2014
Statut
Membre
Dernière intervention
21 janvier 2016
-
Bonjour Vaucluse,

Merci beaucoup pour ta réponse rapide !! Ça fonctionne !! :-)

Bonne journée.
Messages postés
3341
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
449
-1
Merci
Bonjour,

Tes explications me semblent contradictoires.

Dans la première partie, tu indiques
Je peux envoyer ces produits à mes clients si le produit à encore 8 mois de durée de vie par rapport à la date de fabrication. Donc que le produit soit vieux de 4 mois maximum (la date de péremption "DLUO" de ces produits est de 12 mois).

Et dans la deuxième partie :
Je ne peux pas envoyer le produit au client car le produit à 9 mois (ou il ne me reste plus que 3 mois de DLUO).

A+