Calcul valeur tableau de redondance selon une hierarchie [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
jeudi 9 avril 2015
Statut
Membre
Dernière intervention
9 avril 2015
-
nounours11
Messages postés
4
Date d'inscription
jeudi 9 avril 2015
Statut
Membre
Dernière intervention
9 avril 2015
-
Bonjour,

Voila j 'ai un petit soucis

J'ai une table avec trois champs remplis avec uniquement trois valeur différentes
champ1 champ2 champ3
Souhaitable Souhaitable Souhaitable
Souhaitable Souhaitable Obligatoire
Inutile Obligatoire Souhaitable
Souhaitable Inutile Obligatoire
Souhaitable Inutile Inutile
Obligatoire Obligatoire Obligatoire

La hiérarchie et le resultats:

-Pour chaque ligne il suffit qu'il y ai une fois le mot obligatoire et le résultat doit me renvoyer la valeur 2.
-Si les 3 champs = "inutile" le résultat doit renvoyer la valeur 0
-Pour tout le reste, le résultat de la fonction doit renvoyer 1

J'ai pas mal plancher dessus avec des si imbriqué sans grand résultat.
Merci de vos reponse

2 réponses

Messages postés
9220
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
22 février 2020
1 718
Bonjour

Essaies ceci
=SI(NB.SI(A2:C2;"Inutile")=3;0;SI(NB.SI(A2:C2;"Obligatoire")>=1;2;1))

Cdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 86399 internautes nous ont dit merci ce mois-ci

nounours11
Messages postés
4
Date d'inscription
jeudi 9 avril 2015
Statut
Membre
Dernière intervention
9 avril 2015

Merci de ta réponse, même resultat mais fonction plus compacte et plus rapide!
Messages postés
4
Date d'inscription
jeudi 9 avril 2015
Statut
Membre
Dernière intervention
9 avril 2015

= SI([@Colonne7]="Obligatoire";2; SI([@Colonne8]="Obligatoire";2;SI([@Colonne9]="Obligatoire";2;0)))

voila mes debut
nounours11
Messages postés
4
Date d'inscription
jeudi 9 avril 2015
Statut
Membre
Dernière intervention
9 avril 2015

=SI(OU([@Colonne7]="Obligatoire";[@Colonne8]="Obligatoire";[@Colonne9]="Obligatoire");2;SI(ET([@Colonne7]="inutile";[@Colonne8]="inutile";[@Colonne9]="inutile");0;1))

j ai trouver en fait merci,