Menu

Formule calcul différence année [Résolu/Fermé]

Messages postés
19
Date d'inscription
mercredi 29 mai 2013
Statut
Membre
Dernière intervention
12 décembre 2015
- - Dernière réponse : Laure K.
Messages postés
19
Date d'inscription
mercredi 29 mai 2013
Statut
Membre
Dernière intervention
12 décembre 2015
- 18 juin 2014 à 15:46
Bonjour,

Existe t'il une formule qui mentionne l'écart entre une année précédente et l'année en cours, mais en tenant compte d'une date de fin pour soit s'arrêter, soit remplacer l'année par "terminé".

En plus clair (enfin je l'espère), mon fichier donne ça :

A1 : Date début formation (format "13.06.2012")
B1 : Date fin de formation prévue (format "12.06.2014)
C1: Formule durée de la formation en année uniquement
D1 : J'aimerai savoir si l'étudiant se trouve en 1er, 2ème, 3ème année ou 4ème année.

Encore faut-il que je précise que mon fichier reprend les étudiants qui ont suivi les cours depuis 1997, raison pour laquelle j'aimerai qu'à la date de fin de formation, le D1 cesse de calculer les années.

Merci par avance pour votre précieuse aide.
Afficher la suite 

3 réponses

Messages postés
7759
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
17 juin 2019
1167
0
Merci
Bonjour Laure K.
Bienvenue sur le Forum

Essaies,
en C1 :
=FRACTION.ANNEE(A1;B1;1)

ou si tu veux l'arrondir à 1 chiffre après la virgule :
=ARRONDI(FRACTION.ANNEE(A1;B1;1);1)


et en D1 :
=ENT(FRACTION.ANNEE(A1;AUJOURDHUI();1)+1)

pour arrêter après la fin de formation :
=SI(B1>AUJOURDHUI();ENT(FRACTION.ANNEE(A1;AUJOURDHUI();1)+1);"")
ou
=SI(B1>AUJOURDHUI();ENT(FRACTION.ANNEE(A1;AUJOURDHUI();1)+1);"Terminé")

Cordialement
Patrice
Laure K.
Messages postés
19
Date d'inscription
mercredi 29 mai 2013
Statut
Membre
Dernière intervention
12 décembre 2015
-
WAAAAHHHH j'adôôôôre :-))) Un grand Merci Patrice, tout est parfait et fonctionne à merveille.

Bonne soirée.
Messages postés
15866
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 juin 2019
2746
0
Merci
Bonjour

en C1
=DATEDIF(A1;B1;"y")
en D1
=SI(AUJOURDHUI()<B1;DATEDIF(A1;AUJOURDHUI();"y");"Terminé")
Messages postés
19
Date d'inscription
mercredi 29 mai 2013
Statut
Membre
Dernière intervention
12 décembre 2015
0
Merci
Merci beaucoup Michel, c'est la perfection :-))