Comment mettre jour Java et autres sur mac Leopard (os x 10.5.8) [Fermé]

Signaler
Messages postés
223
Date d'inscription
mercredi 5 mars 2008
Statut
Membre
Dernière intervention
5 mars 2020
-
*_Francis_*
Messages postés
37776
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
1 avril 2020
-
Bonjour à tous,

1.- J'aide une dame très aimable qui a des problèmes avec la MAJ de quelques logiciels dans son mac OS X 10.5.8 / PowerPC

2.- En réparation -janvier 2013 - ils ont maj le système

OS X 10.4.11 (Tiger) est devenu OS X 10.5.8 (Léopard) Et puis le mac il avait bien fonctionnait jusqu'à maintenant.

3.- Un premier problème c'était que la connexion Orange fonctionnait assez mal avec Safari et Orange simplement a recommandé d'installer Firefox à la place et le problème a été ainsi résolu. (Cela fait déjà quelques mois).

4.- Un 2e problème qui a eu madame c'est voir disparaitre SKYPE qui fonctionnait bien jusqu'à au début septembre.
J'ai vérifié sur Applications et en effet Skype ne se trouvait pas.

5.- Au même temps Madame a eu des problèmes pour pouvoir réagir à l'actualité et la commenter sur le portail d'Orange. Jusqu'à quelques semaines elle pouvait le faire sans problèmes et puis cliquer sur le lien « réagir » ne donnait rien. Aucune réaction.
A ma sugestion elle a envoyé un message au moderateur, pour demander si pour raison elle avait été censuré. Orange a donné de reponses contradictoires, d'abord faissait penser que par erreur le commentaire d'autre personne avait été pris comme étant le sienne.
Et puis on avait encore vérifié si elle était censurée, ce n'était pas le cas.
Orange jusqu'à là n'a pas trouvé des erreurs pouvant venir de son coté, non plus.

Est ce que le problème peut venir d'un logiciel à mettre à jour?

6.- Quand Madame a voulu faire un test sur Firefox elle a eu le message type : il vous manque des plugins dans le navigateur et après de cliquer sur un lien : mise à jour, on a découvert qu'il fallait METTRE A JOUR quelques logiciels, voici la liste :
(Chaque logiciel étant associé à un bouton METTRE A JOUR)
* Quicktime
* Shockwave flash (adobe)
* Flip4mac
* Java

7.- Le seul bouton qui a permis de faire une correcte MAJ a été Flip4mac.

Pour Quicktime j'ai cherché un « quicktime pour mac OS X 10.5.8 qu'après téléchargement - installation - redémarrage (le seul à la proposer) a pu être aussi correctement mis à jour.

Pour Shockwave flash je suis allé sur adobe/telechargement/ voir tous les chargements
j'ai trouvé shockwave player et puis dans la première liste déroulante j'ai choisi :
mac os x et dans le deuxième shockwave 11.6.8.638 full(os x 10.5 and bellow)
Mais téléchargé et installé (« installation réussi », à la fin) - ce logiciel n'apparait surApplications et il continue apparaitre comme A METTRE A JOUR

Même résultat concernant Java. (N'apparait pas sur Application et il continue apparaitre comme A METTRE A JOUR).
Ceci après d'avoir trouvé ici :
https://support.apple.com/kb/DL1359?viewlocale=fr_FR&locale=fr_FR
Et de téléchargé et installé Java pour Mac OS X 10.5 - Mise à jour 10
Aucun JAVA sur Applications.

8.- Sur windows je sais bien qu'il faut a) maj absolument JAVA (multi-utilisations !)
Et b) desactiver JAVA dans les navigateurs pour des problèmes de sécurité.
Voici MA PREMIERE QUESTION :
Est-ce qu'il faut faire la même chose sur OS X ?

9.- Possibles explication à confirmer :
A.- Pour shockwave player : en vérifiant maintenant sur le site ici :
https://helpx.adobe.com/fr/shockwave/shockwave-end-of-life-faq.html après de choisir comme je disais
macintosh os x 10 et shockwave 11.6.8.638 full(os x 10.5 and bellow et avant de
cliquer sur Accepter et installer ... je viens de découvrir un lien :
Configuration requise quand je clique sur ...s'affiche :
Mac OS X 10.7 et 10.8 avec processeurs Intel et Safari

DONC NE CORRESPOND PAS A NOTRE MAC os x 10.5.8 et powerPC ?

QUESTION 2 :
Comment faire alors pour mettre à jour shockwave ? Ce n'est plus possible ?

QUESTION 3 :
Est-ce qu'il faut préalablement le shockwave qu'existe encore sur la mac et qui
Etait compatible avec la version OS X précédent ( 10.4.11) ? Et comment faire ?

10.- Pour Java Embedding Plugin - que me semble beaucoup plus important - j'ai une doute similaire.
Dans la page du téléchargement ici :
https://support.apple.com/kb/DL1359?viewlocale=fr_FR&locale=fr_FR

J'ai lu un paragraphe qui ne me semble pas trop clair :
La mise à jour 10 de Java pour Mac OS X 10.5 apporte des améliorations de compatibilité, sécurité et fiabilité en mettant à jour J2SE 5.0 avec la version 1.5.0_30 et Java SE 6 avec la version 1.6.0_26 pour les Mac à processeur Intel fonctionnant en 64 bits. J2SE 1.4.2 n'est plus mis à jour pour corriger les bogues ou résoudre des problèmes de sécurité, et reste désactivé par défaut dans cette mise à jour.

DONC NE CORRESPOND PAS A NOTRE MAC os x 10.5.8 et powerPC ?

QUESTION 4 :
Comment faire alors pour mettre à jour Java ?
Sur le site super-intéressante : http://www.oldapps.com
Malheureusement je n'ai rien trouvé !!

11.- MERCI D AVANCE POUR TOUS LES SUGGESTIONS. Cordialement.



13 réponses

Messages postés
37776
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
1 avril 2020
9 382
Bonjour,

Si l'installation de Mac OS 10.5 avait été faite correctement, QuickTime aurait du être présent sur le Mac.
Ensuite, en passant par le menu Pomme / Mise à jour logiciels..., toutes les applications de base, dont QuickTime, sont mises à jour automatiquement à la version maximum admissible pour Mac OS 10.5.8

En clair, tout est automatique pour ce qui concerne les applications ou modules de base installés automatiquement lors de l'installation de Mac OS 10.5
Sous Mac OS 10.5, Java fait partie de ces installations de base.

Il n'y a que les modules tiers accessoires que l'on installe alors soi même et séparément.

Vous parlez de Shockwave Player, or ce dernier ne sert à rien, hormis pour quelques utilisateurs ayant des besoins particuliers. Je suis quasiment certain que vous n'avez pas besoin de Shokwave et que vous devez confondre avec Adobe Flash Player.
Et là, pour un Mac à processeur PowerPC sous Mac OS 10.5, vous vous arréterez à la version 10.1.102.64, et malheureusement cette version ne saura pas prendre en charge la totalité des vidéos actuelles du net.

Pour lire toutes les vidéos, vous devez également installer Perian, en plus de Flip4Mac en version gratuite.

La version Java que vous citez est correcte, mais cela dit, je n'ai pas du tout installé Java depuis la version Mac OS 10.6, et cela sans le moindre soucis. Mais Java est installé d'office sous Mac OS 10.5, et mis à jour automatiquement depuis le menu Pomme, comme indiqué plus haut. Il faut en effet le désactiver dans les préférences des navigateur web, mais laisser Javascript activé. Puisque Java est installé d'office sous Mac OS 10.5, il faut le maintenir à jour pour des problèmes de sécurité, et donc accepter ces mises à jour proposé par le passage du menu Pomme / Mise à jour logiciels...
https://support.apple.com/fr-fr/HT201541
Après installation, si mes souvenirs sont bons, vous ne trouverez pas Java dans le dossier Applications, mais dans Applications / Utilitaires...

Il faut évidemment prendre tout ça, à la source même des éditeurs.

Soit pour un Mac sous Mac OS 10.5.8 et équipé d'un ancien processeur de type PowerPC:

Flash Player 10.1.102.64
http://www.oldapps.com/mac/flash_player.php?old_flash_player=13?download

QuickTime 7.7
https://support.apple.com/downloads#quicktime
ou en direct:
http://support.apple.com/kb/DL761?viewlocale=fr_FR


Perian Perian 1.2.3
https://www.perian.org/
http://perian.cachefly.net/Perian_1.2.3.dmg

Flip4Mac version 2.4.4
http://download.microsoft.com/download/C/8/9/C8951314-E056-404A-8EA8-8744E42594AA/2.4.4.2/Flip4Mac%20WMV%202.4.4.2.dmg

Notez que Skype a été repris par Microsoft, il est normal que Skype ne se trouve pas dans les applications après ré-installation de Mac OS. C'est un logiciel tiers, optionnel et qui n'est pas utilisé par tous.

Pour les soucis avec le portail d'Orange, aucune idée, si ce n'est que je me souviens avoir testé, pour une personne, leur portail sous Safari et Mac OS 10.4 et que ça merd..... sérieusement, alors que sous 10.5 ça fonctionnait... c'est peut-être l'inverse aujourd'hui, ou ça s'est aggravé, puisque ils ont modifié leur portail...

A tout hasard:
https://www.commentcamarche.net/faq/15279-entretenir-et-reparer-mac-os-x-10-6-et-versions-anterieures

Cordialement

EDIT: ça peut aider
https://www.commentcamarche.net/faq/15198-installer-ou-reinstaller-mac-os-x-10-5-alias-leopard


Bonne journée, ou Bonne Nuit..:).
Francis
Messages postés
223
Date d'inscription
mercredi 5 mars 2008
Statut
Membre
Dernière intervention
5 mars 2020
18
Bonjour Francis,

D ABORD UN ENORME MERCI POUR UNE REPONSE TRES COMPLETE ET DETAILLEE ET TRES DIDACTIQUE EN PLUS
ET POUR LES LIENS ET DOCUMENTATION CCM RECOMMANDEE (que je vais essayer de lire intégralement pour me préparer pour Jeudi quand je vais essayer de mettre en pratique les conclusions)

A.-
Je prends note et j'apprends que pour QuickTime on aurait pu passer en effet pour menu Pomme / Mise à jour logiciels et que pour Java et pour autres il faudra tenir compte de cette possibilité.

B.-
Mais ne parlons plus de QuickTime, il n'apparait plus comme plugins à METTRE A JOUR et il apparait bien sur Applications.
Même chose en ce qui concerne Flipmac4, il n'apparait plus comme plugins à METTRE A JOUR et il apparait bien sur Applications.

Je vais vérifier quand même qu'ils soient les mêmes versions que vous parlez.

C.-
Non je ne confonds pas Shockwave avec Adobe Flash Player (AFP) et je savais que ce dernier est plus important, bien que j'aimerais pouvoir savoir avec plus de précisions ce qui fait et apporte chaque produit d'Adobe.
Pour le moment je ne retiens qu'AFP prend en charge de vidéo, entre autres.

Je note et merci pour l'information que la VMP= version maximal possible de AFP est la 10.1.102.64 et je viens de le trouver ici :

D.-
Merci de me faire connaitre Perien et me donner le lien pour le télécharger.

E.-
Pour ce qui concerne la desactivation de Java (et non javascript - je sais bien que ce n'est pas la même chose) des navigateurs.
Hier j'ai lu plusieurs articles que cette recommandation a un rapport pour une version de java devenue vulnerable mais que seulement on peut l'installer sur os x
10.X X>5 donc pas applicable a os x 10.5.8 Leopard, notre cas.

Donc la desactivation de Java dans les navigateurs selon tout cela, on la fera quand même mais est-ce qui'il est finalement bien nécessaire.

Pour le nettoyage surtout de fichier cachés ... je venais de découvrir l'existence
de EASYFIND que j'aimerai un jour pouvoir utiliser, mais avec la doc CCM que vous recommandez j'ai une réponse à d'autres questions que je n'avais pas formule;
UN GRAND MERCI POUR CELA.

Je vous tendrai au courant de la suite jeudi soir ou vendredi prochain, d'accord

MERCI ENCORE ET CORDIALEMENT
*_Francis_*
Messages postés
37776
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
1 avril 2020
9 382
Bonsoir,

Petite précision à propos de Shockwave,
la version qui est prévue pour Mac OS 10.5 est normalement
celle ci

Cela dit, si même Flash Player est obsolete au regard des vidéos du net actuelles, j'imagine que c'est encore pire pour Shockwave qui, sur ce Mac, ne sera utile que pour les toutes anciennes animations 3D écrites avec Adobe Director.

Cordialement
Messages postés
223
Date d'inscription
mercredi 5 mars 2008
Statut
Membre
Dernière intervention
5 mars 2020
18
Bonsoir,
Si dans la page du lien que vous donnez, vous cliquez sur Configuration Requise on ne trouve pas OS X 10.5.8 !! (seulement des versions supérieur à Leopard)

Bon A JEUDI ET MERCI ENCORE
Messages postés
37776
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
1 avril 2020
9 382
Oui, mais c'est la bonne version.
J'ai obtenu le lien depuis cette page:
https://helpx.adobe.com/fr/shockwave/shockwave-end-of-life-faq.html
Vous pouvez le prendre également depuis ce dernier

Cordialeement
Bonjour Francis,
Je m'excuse de n'avoir pas pu répondre avant.

Jeudi nous avons eu à peine une heure et 20 minutes pour régler un problèmes
sur SKYPE. Après nous avons decidé de continuer lundi, c.a.d. demain.

a)
Je repondre à ton dernier message. Tu disais à tort ceci :
Oui, mais c'est la bonne version.
J'ai obtenu le lien depuis cette page:
http://get.adobe.com/fr/shockwave/otherversions/
Vous pouvez le prendre également depuis ce dernier

En effet juste là et dans la deuxième liste deroulante on trouve 3 options

Mais juste dessus il y a un lien CONFIGURATION REQUISE que je vous invite à cliquer, là il n'y a plus de os x 10.5 !!
DONC ce n'est pas trop clair n'est pas?

b) demain je vais verifier Java et finalement pour ShockWave je pense qu'il faudra
simplement le desactiver dans Firefox.

Mais sur Menu Pomme / Mise à jour de logiciels .... la seule chose que j'ai trouvé sur Java a été "PREFERENCES JAVA" ...
Je vais vérifier s'il apparait aussi sur Applications / Utilitaires

Je vous tendrai donc au courant

MERCI ENCORE POUR LA PATIENCE ET A LA PROCHAINE
Messages postés
37776
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
1 avril 2020
9 382
Bonjour,


Etrange, personnellement, j'ai bien le choix pour 2 versions pour Mac OS 10.5
(une version slim et une version full. légère ou pleine donc)


Bonjour,
Moi aussi j'ai çà.
Et c'est justement voulant savoir quelle différence il y avait entre
FULL et SLIM pour OS X 10.5.8 , que j'ai eu la curiosité de cliquer
sur le lien CONFIGURATION REQUISE et l'étrange est là
il figure os x 10.7 et os x 10.8

C'est étrange et incohérent.

Autre chose j'ai bien continué l'installation de FULL os x 10.5.8
en faisant abtraction de cela mais SHOCKWAVE continue apparaitre
comme METTRE A JOUR.


Voilà.
A plus tard.
Bonjour,

Sur le mac on peut travailler qu'une fois par semaine et chaque fois seulement 1
heure ou 1h30 au plus

Donc désolé pour la manque de continuité.

Le problème qui est prioritaire resoudre le probleme des liens (sur Safari et Firefox sur le portail orange le lien pour commenter ne marche pas et une lien aussi sur Mail)

La piste Java comme cause de cela ...

QUESTION 1 :
Comment savoir si une application comme JAVA fonctionne correctement, quand sur le Mac ils existent différentes versions de celle-ci ?
Je sais au moins que sur un PC, il est fortement recommandé de désinstaller les veilles versions. Voir ceci : http://www.java.com/fr/download/faq/remove_olderversions.xml
.

QUESTION 2 :
Nous allons télécharger et installer ONYX version 2.0.6 qui est la meilleure version possible pour OS X 10.5.8, il sera la première fois que nous allons utiliser cette application !
Mais est-ce que ce programme sera capable de faire le ménage concernant JAVA ?


QUESTION 3 :
Et si jamais réglé ce problème ... est-ce qu'il pourra expliquer POURQUOI des liens sur le Portail Orange (pour commenter des actualités) et des liens sur Mail ne fonctionnent pas ?

Et si la réponse est NON, quelles autres pistes seront disponibles pour expliquer les défaillances de ces liens ?
(En effet je suis en train de réfléchir que justement sur Firefox, comme n'importe quel autre navigateur on devra surtout désactiver JAVA -pour des raisons de sécurité- si ce n'est pas encore le cas. En dans ce cas, on se saurait déjà que des liens deviennent inutilisable ... depuis le temps qu'on a commencé à désactiver Java, mais je ne vois rien sur Internet)

QUESTION 4
J'ai étudié un problème similaire sur Windows (où je suis plus fort) et j'ai trouvé que UN PROBLEME DE LIEN QUE NE MARCHE PAS ... le problème peut venir d'un fichier système ou d'un .dll Et si sur Mac c'était la même chose ... comment savoir de quel fichier il s'agit et comme le changer ?

MERCI ENCORE POUR DES REPONSES ET PROPOSITIONS
CORDIALEMENT
Messages postés
37776
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
1 avril 2020
9 382
Bonjour,

Reprenons les bases même de Mac OS 10.5.x , dit Leopard.

Lorsque on installe Mac OS 10.5, on se trouve au départ avec une version x de Leopard. Soit, Mac OS 10.5.x.
Dans cette version tout est installé, mais des versions d'applications diverses, ou autres composants d'Apple ou ou de tierces parties, restent à mettre à jour. Java fait partie de ces applications. Mac OS utilise une version particulière de Java, qui est automatiquement installée lors de l'installation de Mac OS 10.5.x
Seule la version Java installée automatiquement par l'installeur de Mac OS 10.5 est valide.

Ensuite, si on fait les choses correctement, on fait toutes les mises à jour logicielles en passant par le menu Pomme / Mise à jour logiciels...
A ce moment, le serveur d'Apple identifie la version système en place et les composants et logiciels installés, et procéde aux mises à jours nécessaires, requises et adaptées au système en place.
Lors de ces mises à jour automatiques, Java est mis à jour également et cela depuis les serveurs d'Apple qui dispose de la version Java la plus récente et adaptée à Mac OS 10.5.

Lorsque cela est fait et terminé, on procéde à une réparation des autorisations du disque depuis l'applications Utilitaire de disque, et c'est fini. Mac OS 10.5.8 est à jour, et la version Java qui correspond également.
En aucun cas, on ne va chercher soi même une version de java sur tel ou tel site. Seule la version installée automatiquement par Apple est correcte et fonctionne donc correctement.

Au fur et mesure du temps qui passe, si on faille de sécurité est découverte, sur Java ou autre, Apple propose alors une mise à jour dite de sécurtité. C'est pour cela que sous n'importe quelle version de Mac OS, il faut périodiquement interroger le menu Pomme / Mise à jour logiciels....
A la limite, pour une raison X ou Y, on peut chercher manuellement la dernière mise à jour de java ou de sécurité, concernant sa version de Mac OS, sur le site Apple. Et on trouve ceci par exemple ceci:
https://support.apple.com/kb/DL1359?locale=en_US&viewlocale=fr_FR
ou cela:
https://support.apple.com/kb/DL1533?locale=en_US&viewlocale=fr_FR
https://support.apple.com/kb/index?page=search&src=support_site.globalheader.search&locale=fr_FR&q=Mac%20OS%20X%2010.5

Il n'y a pas à aller cherhcer ailleurs, car je le répète, Java pour Mac OS 10.5 ne se trouve nulle part ailleurs que sur le site d'Apple. Même si un logiciel X ou Y vous le demande.

Voir ceci:



Onyx ne s'occupe pas de Java. On n'a pas à faire le ménage de Java dans Mac OS 10.5 si nous avons installé correctement Mac OS 10.5 et n'avons pas ajouté des trucs inadaptés pris ici ou là.

Pour les liens Orange qui ne fonctionnent pas, je ne peux rien dire, il faudrait que je connaisse un de ces liens à problème, pour pouvoir tester sur mon ancien iMac encore sous mac OS 10.5.8

Je ne peux que conseiller la lecture de ces pages:
https://www.commentcamarche.net/faq/15279-entretenir-et-reparer-mac-os-x-10-6-et-versions-anterieures
https://www.commentcamarche.net/faq/15198-installer-ou-reinstaller-mac-os-x-10-5-alias-leopard

Cordialement
Bonjour Francis,
Merci encore pour tes réponses et surtout ta grande patience.

J'ai lu avec beaucoup d'attention tes réponses et tes suggestions de lecture.
L'idée d'utiliser Onyx vient justement de cela.

Mais tu es complétement sur que tous les mise à jour de logiciels dans un mac qui est passé de tiger à leopard en janvier 2013, s'est passent correctement bien?

Je reviens sur Java pour ce qui concerne la suppression de vieilles versions (si valable sur un PC pour quoi ne le sera pas sur un Mac).

Peut être que tout va bien concernant java sur ce Mac mais quand j'ai voulu voir les MISES A JOURS DE LOGICIELS INSTALLES, j'ai mes doutes

(Menu Pomme / Préférences Systèmes .../ Groupe Système/ Mise à jour de logiciels /
Onglet Mises à jour Installés) ... voilà la collection de vieilles versions j'ai trouvé pour Java :

Java 1.3.1 et 1.4.2 Seconde édition (2.0)
J2SE 5.0 Quatrième édition (4.0)
Java Release 5 pour MAC OS X 10.4 (5.0)
Java pour MAC OS X 10.4 version 6 (1.0)
Java pour MAC OS X 10.4 version 7 (1.0)
Java Release 8 pour MAC OS X 10.4 (1.0)
Java pour MAC OS X 10.4 version 9 (1.0)
Mise à jour 5 de Java pour Mac OS X 10.5 (1.0)
Java pour MAC OS X 10.5 Mise à jour 10 (1.0) <== qui correspond bien à celle que j'ai installé
QUESTION 1
Est ce que tout cela et malgré les apparences est finalement NORMAL?

Et tout cela parce sur Firefox Java Embedding ETAIT A METTRE A JOUR (et que malgré l'installation de cette dernière version continue de paraitre comme METTRE A JOUR.
Je me demande s'il ne faut pas finalement re-installer à nouveau FIREFOX !!


J'ai une autre question à propos de MISE A JOUR AUTOMATIQUES.
Dans un document que tu recommandes de lire, sur les mises à jour automatique, programmés pour être réalisé à 3 h du matin - comme sur windows, le document disais ceci sur un Mac a) éteint ou b)en veille à cette heure là, c'est MAJ ne peuvent pas se réaliser.!!

Ce que j'ai bien vérifier, car les seules MISE A JOUR enregistres récemment correspond au mise à jour que j'ai fait à la main :
Menu Pomme / Mise à jour de logiciels
(MAJ qui ont eu comme résultat : aucun mise à jour disponible!)

QUESTION 2
Entre la maj automatique programmé pour 3 h du matin et la mise jour via Menu Pomme/ Mise à jour de logiciels ? Est ce qu'il existe une différence importante entre elles?
Ou bien l'automatique est beaucoup plus complète?


MERCI D AVANCE POUR LES RÉPONSES ET CORDIALEMENT
Messages postés
37776
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
1 avril 2020
9 382
Bonjour,

Ou avez vous lu cette phrase:
Mais tu es complétement sur que tous les mise à jour de logiciels dans un mac qui est passé de tiger à leopard en janvier 2013, s'est passent correctement bien? 


Onyx est un bon utilitaire qui permet de faire des opérations standard de nettoyage ou de paramétrage. Il existe une version d'Onyx pour chaque version de Mac OS. Il faut utiliser la version qui convient. Mais Onyx n'ira pas mettre de l'ordre dans les archives des mises à jour logiciels. Et ce que vous énumérez dans la liste des mises à jour installées correspond à l'historique des différentes mises à jour effectuées au fil du temps. Ce Mac est visiblement passé de Mac OS 10.4 à 10.5 et a subi en conséquence les différentes mises à jour. La version Onyx pour Mac OS 10.5 est ici:
http://www.titanium.free.fr/download/105/OnyX.dmg

Pour Firefox, ce que je ferai, je le supprimmerai entièrement avec un utilitaire comme App Cleaner. Vous avez peut-être une version Firefox inadaptée à un Mac PowerPC sous Mac OS 10.5 ??
http://www.freemacsoft.net/appcleaner/
On glisse l'application dans la fenêtre et on valide la suppression. (sauvegarder éventuellement les signets d'abord).

Puis, je ré-installerai la dernière version compatible avec Mac OS 10.5 pour un Mac à processeur PowerPC. Ça devrait être la version 3.6.24, disponible ici:
http://www.oldapps.com/mac/firefox.php?old_firefox=9568?download


Il faut savoir que Java est totalement inutile dans 99,99% des cas, et qu'en conséquence, chez moi, dans tous mes navigateurs web, par mesure de sécurité, Java n'est pas activé. Seuls les Javascripts sont autorisés. (2 choses sans rapport entre-elles).

Au sujet des mises à jour logiciels et de ce qui est programmé pour 3h du matin, il y a confusion entre 2 choses sans rapport entre-elles. Il n'existe aucune mise à jour logicielle automatique et programmée pour 3h du matin.
Il ne faut pas confondre les mises à jour et les routines de maintenance automatiques, (programmées elles, à 3h du matin sous les anciennes versions de Mac OS, dont fait partie Mac OS 10.5). Ces routines de maintenance ne pouvant se faire lorsque le Mac est en veille ou à l'arrêt, il faut les lancer manuellement. Il s'agit des routines "Daily", "Weekly", et "Monthly".
Onyx, par exemple, peut les lancer manuellement, mais d'autres utilitaires savent le faire également, comme par exemple iTweax et d'autres encore. J'en parle dans cette page.

Parfois, lorsque on rencontre trop de bizarreries, il est bon d'effacer entièrement le disque dur et de ré-installer Mac OS à partir de zéro. Ça permet d'élimininer pas mal de verrues dues à d'anciennes installations plus ou moins bien faites ou inutiles, voire inadaptées. Cette ré-installation prend souvent, finalement moins de temps que de traiter plusieurs séries de problèmes qui s'enchaînent.

J'explique de manière détaillée dans cette page comment ré-installer Mac OS 10.5:
https://www.commentcamarche.net/faq/15198-installer-ou-reinstaller-mac-os-x-10-5-alias-leopard

Il faut également savoir que Mac OS 10.5, surtout sur un Mac à processeur PowerPC, est aujourd'hui obsolète pour certaines choses. Ainsi, par exemple entre autres, certains sites demandent la dernière version de Flash Player pour lire certaines vidéos. Or Mac OS 10.5 ne saura pas utiliser cette dernière version, et donc ne saura pas lire certaines vidéos du net.

Cordialement

Bonjour Francis,

MERCI ENCORE POUR LES RÉPONSES
1.-
J'ai bien compris que : Onyx ne pourra pas mettre de l'ordre dans les versions d'un logiciel.

2.-
J'ai pris note aussi que ce qui affiche Mise A Jour Installé c'est un historique de maj et que cela ne veut pas dire que des vieilles versions (archives) soient encore sur le Mac.

3.-
Oui, je prends soin de bien vérifier que les logiciels installés soient dans la MEILLEURE VERSION POSSIBLE pour OS X 10.5.8

4.-
Pour Firefox, c'est exactement ce que je pense proposer à madame :
a) télécharger et installer App Cleaner - tu m'avais déjà donné le bon lien
b) supprimer firefox
c) télécharger le firefox dans la version 3.6.24 dans le site indiqué
d) et re-installer le firefox

Et probablement je vais aussi installer IE que je vais trouver dans le même site, pour comparer si fonctionnent avec le même problème ou pas (Je parle de liens que ne fonctionnent pas)

5.-
Je vais m'assurer de désactiver Java sur les navigateurs.

6.-
Merci pour expliquer la différence entre les « Maj automatiques programmés à 3 h du matin » et les « Mise à Jour de Logiciels ».

7.-
Donc je vais utiliser Onyx pour remplacer les « Maj automatiques programmés à 3 h du matin » = les routines de maintenance automatiques

8.-
Évidemment l'option « d'effacer entièrement le disque dur et de ré-installer Mac OS à partir de zéro » ...cela restera comme option si ...
(Pour le moment les problèmes ne sont pas si graves pour justifier cela, au moins je crois.)
Je sais que dans l'éventualité je dispose déjà du mode d'emploi.

9.-
« un Mac à processeur PowerPC, est aujourd'hui obsolète pour certaines choses. Ainsi, par exemple entre autres, certains sites demandent la dernière version de Flash Player pour lire certaines vidéos » Oui cela est déjà largement enregistré !

MERCI ENCORE ET JE VOUS TENDRAI AU COURANT DE LA SUITE PROBABLEMENT LUNDI PROCHAIN

Cordialement
Messages postés
37776
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
1 avril 2020
9 382
Juste encore uen information,
IE est largement obsolète depuis la nuit des temps pour Mac OS. Il n'existe aucune version de IE compatible avec Mac OS 10.5. De plus la dernière version qui a existé pour Mac OS était un cauchemar tant elle était bugguée. Microsfost a reconnu la chose et a fini par ne plus du tout le produire pour Mac, et cela depuis plusieurs années. (les seules versions d'IE, à peu près utilisables, étaient celles existantes sous Mac OS 9, ce qui revient à dire depuis un siècle quand on parle d'informatique. Même la plus mauvaise version de Safari ou Firfox pour Mac était sans comparaison possible avec IE pour Mac.
Donc inutile de cherhcher une version IE pour Mac.

Bonne continuation :)