Menu

Supprimer les doublons (excel 2003) [Résolu/Fermé]

Messages postés
88
Date d'inscription
vendredi 16 janvier 2009
Statut
Membre
Dernière intervention
11 février 2014
- - Dernière réponse :  Nisson - 5 mars 2018 à 01:24
Bonsoir à tous,

Je dois réaliser un publipostage. Mais je m'aperçois que j'ai énormément de doublons.
Aussi, suis-je contrainte de les supprimer ligne/ligne, ou existe-t-il une formule qui permet d'éliminer une ligne qui apparaît deux fois?

Merci pour votre aide.

Ci-joint le type de fichiers.

http://cjoint.com/?BJkvmX5s1nG

J'utiliserai Excel 2003 au travail.

Bonne soirée.
Chantal
Afficher la suite 

5 réponses

Meilleure réponse
24
Merci
Il y a plus simple!

Dans l'onglet "données" sélectionner filtrer puis filtre élaboré.
Dans la case "plage" indiquer la plage avec les doublons
Dans la case "copier dans" une destination pour la plage sans doublon
cocher "extraction sans doublon"
et cliquez sur OK.

Vous aurez alors une liste sans doublons en vous évitant la fastidieuse étape de suppression des cases colorées

Dire « Merci » 24

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41816 internautes nous ont dit merci ce mois-ci

Super méthode!
merci beaucoup
Méthode super simple. Ca marche. 1000 Mercis
merci pour le tuyau
Bien expliqué sans fioritures, Un grand merci Nisson.
Messages postés
16903
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 juin 2019
3484
2
Merci
Salut,

Plusieurs possibilités, entièrement automatique avec un code VBA si tu as quelques notions
ou avec une mise en forme conditionnelle qui colorise les doublons et manuellement tu sélectionnes les lignes colorisées et tu les supprimes

pour Excel 2003

commence par sélectionner la plage colonne A contenant les valeurs à tester, puis Format/Mise en forme conditionnelle/ la formule à coller est

=NB.SI(DECALER($A$1;0;0;LIGNE()-1);DECALER($A$1;LIGNE()-1;0))>0

format et tu choisis une couleur de remplissage

avec cette formule seulement les cellule de la plage en doublon se coloriseront et tu les supprimes
Messages postés
88
Date d'inscription
vendredi 16 janvier 2009
Statut
Membre
Dernière intervention
11 février 2014
18
0
Merci
Merci Mike.
J'essaierai demain.
Bonne soirée.
Chantal
Messages postés
16903
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 juin 2019
3484
0
Merci
Re,

pourquoi as tu mis le statut en résolu alors que tu n'as pas encore testé ma proposition,
tiens nous tout de même au courant ou libère le statut
Messages postés
88
Date d'inscription
vendredi 16 janvier 2009
Statut
Membre
Dernière intervention
11 février 2014
18
0
Merci
Bonjour à tous,

Juste pour vous dire que la formule de Mike est géniale!!!!!!!

Mille mercis.
A bientôt.
Chantal