Menu

Spf et courriel en spam [Résolu/Fermé]

Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
- - Dernière réponse : enyrix
Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
- 19 janv. 2012 à 02:43
Bonjour,
Nous avons un serveur du quel on veut envoyer des courriel a partir du site mais qu'on recoit toujours en spam. Si on envoie a partir d'un logiciel de messagerie de notre serveur cela passe en boite de réception.

Nous avons demander a notre hebergeur d'ajouter un spf a notre hebergeur ce qui est ok:
spf v=spf1 a mx ptr ip4:xxx.xxx.xxx.xx mx:mail.domaine.com ~all
(les valeurs ont bien sur été changé pour les notres)

apres multiples tentative et vérification dans la source du courriel cela ne fonctionne toujours pas... on se demande donc si ce n'est pas notre postfix qui est mal configuré ou si il y a autre chose a savoir sur sujet...

dans config de postfix on a quelque chose du genre.. corrigez moi si ca devrait etre autre chose
dans etc/postfix/main.cf

myhostname = mail.domaine.com
myorigin = $mydomain
mydestination = localhost.localdomain, localhost
relayhost =

le rdns a aussi été configuré sur notre hébergeur.. (reste a savoir si cest bien configurer)

si quelqu'un a des exemple, un tutoriel ou solutions
toute piste de solution serait la bienvenue!

Merci de votre aide
Afficher la suite 

10 réponses

Messages postés
5169
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
18 juillet 2019
785
0
Merci
Salut enyrix,

Le descriptif de ton fichier de configuration est incomplet, cependant il est probable que le problème ne vienne pas de là.

Il est possible que les e-mails émis du serveur SMTP de ta machine soient suspectés d'être des spams si la résolution inverse de l'adresse IP de ton serveur mail ne donne pas mail.domaine.com.

Donc, si ton hôte s'appelle mail.domaine.com, il faut effectivement que l'entrée MX de ta zone pointe sur mail.domaine.com, mais aussi que l'adresse IP résolve sur mail.domaine.com en résolution inverse.

Vois ce post http://www.commentcamarche.net/forum/affich-2111978-pb-de-resolution-inverse#1 pour l'usage de la commande "host" afin de tester les choses.


Dal
Messages postés
1
Date d'inscription
dimanche 15 janvier 2012
Statut
Membre
Dernière intervention
15 janvier 2012
0
Merci
Bonjour,

Cela peut venir de plusieurs points: spf, reverse dns, mais également: blacklistage, configuration du serveur, etc...

Si vous les souhaitez je analyser tout cela, merci pour cela de me faire une demande via message privée, je vous indiquerai comment procéder.

Bonne soirée,
Cordialement
[Dal]
Messages postés
5169
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
18 juillet 2019
785 -
Salut Marc.jouan,

L'objectif du forum est de permettre, au travers d'un échange public, de conserver une trace des réponses à des problèmes que d'autres personnes pourront rencontrer dans le futur.

Un message privé peut être nécessaire pour adresser une information que enyrix ne souhaite pas rendre publique ici (par exemple son nom d'hôte pour que nous puissions faire des tests à distance), mais la résolution du problème devrait se faire ici, pour respecter l'esprit du forum.


Dal
Messages postés
5169
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
18 juillet 2019
785
0
Merci
Salut enyrix,

Pour ton fichier de configuration, comme tu ne l'as pas posté de façon complète, on ne peut pas vérifier (poste le main.cf sans les commentaires et en entier, éventuellement en confidentialisant ce que tu ne veux pas publier).

Sur la base de ce que tu as déjà indiqué, il se peut que tu doives ajouter à mydestination le paramètre $mydomain : cela sera nécessaire si tu veux être capable de recevoir des réponses.

La définition de mydomain n'apparaît pas dans ce que tu as posté, mais je suppose que tu y as bien mis ton nom de domaine.

Par ailleurs, dans ce que tu as posté, tu n'as pas mis non plus la ligne mynetworks_style. Si ta machine est hébergée par un hébergeur extérieur, et que le "site" (Web, je suppose) qui doit envoyer les e-mails est sur la même machine, tu peux paramétrer mynetworks_style = host pour éviter que ta machine n'accepte de relayer des e-mails provenant d'autres machines (ce qui peut, en effet, être une cause de blacklistage).

Une autre raison de blacklistage peut être aussi l'adresse IP utilisée pour le serveur. Elle peut appartenir un block blacklisté pour une raison ou une autre (par exemple, les adresses IP résidentielles le sont souvent d'office). Pour dépister ce genre de problème, il faut voir ce que disent les messages d'erreur éventuellement retournés par les passerelles refusant de délivrer le message.

Tu pourras alors voir sur des base de données comme http://www.spamhaus.org/lookup.lasso si, et pourquoi, il y a un blacklistage de l'IP.

Sans d'autres infos, on peut difficilement t'aider plus.


Dal
[Dal]
Messages postés
5169
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
18 juillet 2019
785 -
Note que quelque part sur ton serveur, tu dois avoir le fichier main.cf.dist (par exemple sur Debian il est là : /usr/share/postfix/main.cf.dist), qui est un fichier de configuration complet et comportant de très nombreux commentaires et exemples pour t'aider à comprendre chaque directive de configuration, si tu dois les utiliser pour ton cas particulier et comment.


Dal
enyrix
Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
4 -
j'ai ajouter
myorigin = $mydomain
mydestination = $mydomain,localhost.localdomain, localhost


également vérifier si mon ip était pas blacklisté (elle ne l'est pas)

je n'ai pas dans mon fichier de configuration de postfix cela mynetworks_style

voir mon dernier message sur dkim
Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
4
0
Merci
Merci pour vos réponse, suite a mes recherches entre-temps j'ai vu que ça prendrait une configuration dkim sur le serveur dns de l'hébergeur et que je devais configurer également mon serveur en conséquence.. ce que je vais tester.. je vous redonne des nouvelles après.

Merci
enyrix
Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
4 -
juste pour préciser que le spf est maintenant valid dans mon courriel reste encore le dkim que j'essaie tant bien que mal de configurer
Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
4
0
Merci
J'ai réussie à ajouter une signature dkim en installant dkim-filter sur mon serveur debian et en y configurant postfix. Par contre quand je valide la source du courriel qui m'est envoyer avec http://www.brandonchecketts.com/emailtest.php ça me dit que c'est invalid

result = invalid
Details: public key: not available

je cherche depuis longtemps alors peut-être auriez vous une meilleure idéé du pourquoi que ça ne se valide pas. J'ai vérifier la clé inscrit au dns et elle correspond bien a celle dans mon fichier que jai généré a partir de ma cle privé dans /etc/dkim/keys/domain.com/dkim.private

j'ai principalement suivi ce tutoriel : http://www.debiantutorials.com/setup-domainkeys-identified-mail-dkim-in-postfix/

dans mon fichier /etc/dkim-filter.conf

# Log to syslog 
Syslog   yes 
# Required to use local socket with MTAs that access the socket as a non- 
# privileged user (e.g. Postfix) 
#UMask   002 

# Sign for example.com with key in /etc/mail/dkim.key using 
# selector '2007' (e.g. 2007._domainkey.example.com) 
#Domain   domain.com 
#KeyFile   /etc/dkim/keys/domain.com/default.private 
#Selector  dkim 

# Common settings. See dkim-filter.conf(5) for more information. 
#AutoRestart  yes 
#Background  yes 
#Canonicalization simple 
#DNSTimeout  5 
#Mode   sv 
#SignatureAlgorithm rsa-sha256 
#SubDomains  yes 
#ASPDiscard  no 
#Version   rfc4871 
#X-Header  yes 

############################################### 
# Other (less-standard) configuration options # 
############################################### 
#  
# If enabled, log verification stats here 
#Statistics  /var/run/dkim-filter/dkim-stats 
# 
# KeyList is a file containing tuples of key information. Requires 
# KeyFile to be unset. Each line of the file should be of the format: 
#    sender glob:signing domain:signing key file 
# Blank lines and lines beginning with # are ignored. Selector will be 
# derived from the key's filename. 
KeyList /etc/dkim-keys.conf 
# 
# If enabled, will generate verification failure reports for any messages 
# that fail signature verification. These will be sent to the r= address 
# in the policy record, if any. 
#SendReports  yes 
# 
# If enabled, will issue a Sendmail QUARANTINE for any messages that fail 
# signature verification, allowing them to be inspected later. 
#Quarantine  yes 
# 
# If enabled, will check for required headers when processing messages. 
# At a minimum, that means From: and Date: will be required. Messages not 
# containing the required headers will not be signed or verified, but will 
# be passed through 
#RequiredHeaders yes 



dans mon /etc/postfix/main.cf

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU) 
biff = no 
disable_vrfy_command = yes 
smtpd_helo_required = yes 

# appending .domain is the MUA's job. 
append_dot_mydomain = no 

# Pour faire simple, il est conseillé d'utiliser le reverse DNS de votre serveur. 
myhostname = mail.domain.com 
myorigin = $mydomain 
mydestination = localhost.localdomain, localhost 
relayhost = 
mynetworks = xxxxxxxxxxxxxxxx
mailbox_size_limit = 0 
recipient_delimiter = + 
inet_interfaces = all 

virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_aliases.cf,mysql:/etc/postfix/mysql-virtual_aliases_comptes.cf 
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domaines.cf 
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_comptes.cf 
virtual_mailbox_base = /var/spool/vmail/ 
virtual_uid_maps = static:5000 
virtual_gid_maps = static:5000 

virtual_create_maildirsize = yes 
virtual_mailbox_extended = yes 
virtual_mailbox_limit_maps = mysql:/etc/postfix/mysql-virtual_quotas.cf 
virtual_mailbox_limit_override = yes 
virtual_maildir_limit_message = "La boite mail de votre destinataire est pleine, merci de reessayez plus tard." 
virtual_overquota_bounce = yes 


# adresses d'expedition 
smtpd_sender_restrictions = 
        permit_mynetworks, 
        warn_if_reject reject_unverified_sender 

# adresses de destination 
smtpd_recipient_restrictions = 
        permit_mynetworks, 
        reject_unauth_destination, 
        reject_non_fqdn_recipient 

# client 
smtpd_client_restrictions = 
        permit_mynetworks 

#configuration pour filter-dkim (signature des courriels avec dkim) 
milter_default_action = accept 
milter_protocol = 2 
smtpd_milters = inet:localhost:8891 
non_smtpd_milters = inet:localhost:8891 


dans mon dkim-key.conf
*@domain.com:domain.com:/etc/dkim/keys/domain.com/dkim.private 



faut-il avoir aussi domain key d'installer ?
s'agit t-il d'une mauvaise configuration de postfix ou de dkim-filter ?

Merci encore
enyrix
Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
4 -
J'ai découvert cette ligne de commande a faire sous la console, ça me retourne quelque chose débutant par:
dig -t dkim._domainkey.monsite.com
;; Warning, ignoring invalid type dkim._domainkey.monsite.com
...

J'attire également votre attention sur le fait que lors de mes test j'avais obtenu ceci sur le site pour tester mon dkim:
Details: public key: not available

J'aimerais également savoir quel est la différence entre un sélecteur mail et celui que j'utilise dkim.

En espérant trouver comment régler le problème rapidement car ça fait un bout que je cherche !
enyrix
Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
4 -
autre piste encore...
somme nous obliger d'utiliser quelque chose du genre dans notre header du courriel si on envoie le courriel a partir de notre site web (tel est mon cas) ? http://php-dkim.sourceforge.net/
Messages postés
5169
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
18 juillet 2019
785
0
Merci
Salut enyrix,

Dans ton main.cf :

- ajoute une ligne "mydomain = domain.com" (en mettant ton nom de domaine à la place de "domain.com", bien sûr)... cette ligne n'est pas dans ton fichier de configuration

- si cette machine est la seule à utiliser le serveur smtp, c'est plus simple de commenter la ligne "mynetworks" et d'ajouter la ligne "mynetworks_style = host"

- ce que tu as mis dans "myhostname" doit correspondre à ton entrée MX de DNS et à ton reverse DNS sur l'IP du serveur... est-ce bien le cas ?

- ligne "mydestination" : $mydomain, localhost.localdomain, localhost

Tu n'as pas dit :

- si ton reverse dns était réglé
- quels étaient les messages d'erreurs renvoyés par les passerelles de messagerie qualifiant le message de spam (car certains peuvent indiquer la raison)

Je n'ai jamais utilisé dkim et je ne suis pas plus compétent que toi sur le sujet.

Cependant, je remarque que les lignes suivantes sont commentées dans ton "dkim-filter.conf" :

#Domain domain.com
#KeyFile /etc/dkim/keys/domain.com/default.private
#Selector dkim

ainsi que les lignes suivantes. Je doute que tu signes correctement.

Cependant, avant de te lancer dans des choses compliquées, tu devrais essayer de bien faire fonctionner ton serveur smtp.


Dal
Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
4
0
Merci
Après une journée intensive d'essaie et de lecture de test etc... j'ai contacter mon hébergeur, de son côté la configuration DNS comportait une erreur suite a notre demande pour faire le reverse DNS...

Bref j'ai finalement opté pour installer mon propre serveur DNS avec bind et fais quelques test avec un autre nom de domaine dont jai pu le renseigner les DNS chez mon registraire pour qui pointe vers mon serveur DNS que j'ai créé.

Seulement la le problème reste le même, je ne parviens pas a faire fonctionner dkim avec mon serveur de mail postfix.. quand je le configure.. la réception de courriel ne fonctionne plus. alors j'ai du remettre comme c'était dans main.cf et master.cf..

J'ai pourtant suivi de nombreux tutoriels j'ai essayer dkim-filter et opendkim...

N'étant pas habitué a consulter les log j'en ai apris plus pour savoir ou regarder dans..
voila presétement je crois bien avoir enlever ce que javais fait puisque ça fonctionnait pas donc j'ai regarder dans /var/log/mail.warn et il y a encore ceci en répétition:

warning: connect to transport private/dksign: No such file or directory
et également parfois
warning: dict_nis_init: NIS domain name not set - NIS lookups disabled

sachant que j'ai plusieurs nom de domaine a gérer, je doute que mon postfix soit bien configuré..

des solutions des pistes ?

Merci pour vos infos que vous m'avez donné et votre patience :)
Messages postés
5169
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
18 juillet 2019
785
0
Merci
Le fait d'avoir réglé correctement ton reverse DNS pourrait déjà régler ton problème de spam.

Vois déjà si tu as résolu ces problèmes. Il y a des myriades de serveurs smtp qui n'utilisent pas de signatures, et qui ne sont pas pour autant considérés comme spammeurs.

C'est bien de procéder par étapes.

Pour ton warning concernant NIS, vois http://irbs.net/internet/postfix/0407/2779.html

Pour configurer DKIM, si je devais me lancer dans cette tâche, je le ferai dans un premier temps pour un seul domaine, et le plus simplement possible (par exemple https://help.ubuntu.com/community/Postfix/DKIM). Ne complique les choses que une fois que cela fonctionne.


Dal
Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
4
0
Merci
J'ai pu corriger quelques problèmes avec les instructions que vous m'aviez donné.
J'ai réussie a ajouter une signature dkim a mes message pour le nom de domaine que je voulais suite a ma configuration de mon serveur en utilisant mon propre dns j'ai pu le configurer a ma guise et savoir ce qui cloche...

par contre reste que google considère mes courriels dans la boite de reception mais hotmail lui refuse encore meme si dans la source le dkim est valid et que le spf pass.
Aussi je ne suis pas capable de recevoir de courriels avec ce nom de domaine...

je soupsonne encore qu'il y aie quelque chose qui cloche avec mon postfix.

Petite question: le hostname de la machine peut telle avoir une impact sur le serveur de mail ?(la commande hostname lenomquonveutchanger)
doit t-on lui mettre qqchose du genre mail.exemple.com ou exemple.com ou ça n'a pas d'importance ?
Messages postés
144
Date d'inscription
vendredi 11 novembre 2011
Statut
Membre
Dernière intervention
30 mai 2017
4
0
Merci
J'ai encore du nouveau!

J'ai résolue mon problème de réception du courriel pour mon nom de domaine spécifique. Postfix était mal configuré, voici la bonne config, l'erreur était sur la ligne mydestination:

mydomain = exemple.com
myhostname = mail.exemple.com
myorigin = $myhostname
mydestination = $myhostname localhost.$mydomain localhost


Pour ce qui est du spam avec hotmail il utiliser quelque chose qui se nomme sender-id... D'après ce que j'ai on doit maintenant leur envoyer un courriel pour que notre domaine soit ajouter a leur DNS en cache après avoir bien configurer notre SPF sur notre DNS.

https://support.msn.com/default.aspx?productKey=senderid&locale=en-us&st=1&wfxredirect=1</code>