Construire une référence de 5 champs dont 2 variables

acteemay - 5 déc. 2017 à 15:14 - Dernière réponse : Vaucluse 20835 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 décembre 2017 Dernière intervention
- 6 déc. 2017 à 13:07
Bonjour,

Je ne sais plus où chercher et j'ai épuisé toutes mes ressources, je suis prête à croire que c'est impossible et à abandonner l'idée de construire un numéro de référence de cinq champs variables (ex : 9006.002.045.00ASV.4). Il y a t'il une personne parmi vous qui serait volontaire pour tenter de résoudre mon casse-tête ? merci d'avance et à dispo pour envoyer le fichier de travail.
Cordialement,
Afficher la suite 

14 réponses

Répondre au sujet
Raymond PENTIER 44507 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 5 déc. 2017 à 15:22
0
Utile
Difficile de te croire !
Avec les textes :
"9006" en A1, "002" en B1, "045" en C1, "00ASV" en D1 et "4" en E1
la formule est =A1&"."&B1&"."&C1&"."&D1&"."&E1
Commenter la réponse de Raymond PENTIER
0
Utile
2
merci Raymond, mais heuuu... je me suis définitivement mal exprimée ! et franchement je ne sais pas comment expliquer simplement. Il me semble plus pratique de soumettre l'exemple de mon besoin... mais où et à qui ??
Merci à tous
Vaucluse 20835 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 décembre 2017 Dernière intervention - 5 déc. 2017 à 15:53
Bonjour
ici:
http://mon-partage.fr
en revenant coller ,ici le lien créé sur le site
(avec bien sur les;explications nécessaires)
à vous lire
crdlmnt
acteemay > Vaucluse 20835 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 décembre 2017 Dernière intervention - 5 déc. 2017 à 16:01
Génial, merci infiniment donc voici le lien :

https://mon-partage.fr/f/FAERJAX5/

Cordialement
Commenter la réponse de acteemay
Vaucluse 20835 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 décembre 2017 Dernière intervention - 5 déc. 2017 à 16:20
0
Utile
Re

je ne vois pas très bien ce que vous voulez faire, mais pour répondre à vos questions:

en F8:
=SI(ET(P8="";Q8<>"";R8<>"";S8="";T8="");TEXTE($Q$2&$R$2;"0000");"")

en F13:
=SI(ET(P13="";Q13="";R13="";S13<>"";T13<>"");TEXTE($S$2&$T$2;"0000");"")

à adapter au reste, et si ça ne va pas revenez en complétant les précisons!!

crdlmnt
Commenter la réponse de Vaucluse
0
Utile
Merci sincèrement Vaucluse, ça fonctionne parfaitement sur les lignes 8 et 13 (je me perdais complètement dans les guillemets et autres subtilités et me suis collé un mal de crâne)... pour l'instant je n'arrive pas encore à adapter la formule à la ligne F6 (le but étant d'automatiser la formule sur l'ensemble de mon tableau de + de 200 lignes et de compléter le champ suivant de référence en colonne H sur le même principe de si rien =0 si rempli = ligne 2. Mais bon, avec ce que vous m'avez communiqué je devrais arriver à extrapoler le raisonnement et à compléter mon tableau pour créer des références à mes objets, enfin je l'espère :-)

Merci sincèrement de votre investissement et bon après-midi
crdt
Commenter la réponse de acteemay
Raymond PENTIER 44507 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 5 déc. 2017 à 18:06
0
Utile
Bonjour.

Ma proposition en F6 (à recopier vers le bas) :
=SI(ET(P:P=0;Q:Q=0;R:R=0;S:S>0;T:T=0);"004";
SI(ET(P:P=0;Q:Q>0;R:R>0;S:S=0;T:T=0);"023";
SI(ET(P:P=0;Q:Q=0;R:R=0;S:S>0;T:T>0);"045";"000")))
Commenter la réponse de Raymond PENTIER
Raymond PENTIER 44507 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 5 déc. 2017 à 18:27
0
Utile
1
Autre proposition :
=SI(P:P=0;SI(ET(Q:Q=0;R:T=0;S:S>0);SI(T:T>0;"045";"004");
SI(ET(Q:Q>0;R:R>0;S:S=0;T:T=0);"023";"000");"000")
Raymond PENTIER 44507 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 5 déc. 2017 à 23:40
Ceux qui auront testé ma dernière proposition auront corrigé d'eux-mêmes :

=SI(P:P=0;SI(ET(Q:Q=0; R:R =0;S:S>0);SI(T:T>0;"045";"004");
SI(ET(Q:Q>0;R:R>0;S:S=0;T:T=0);"023";"000" )) ;"000")

Cordialement.
Commenter la réponse de Raymond PENTIER
Vaucluse 20835 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 décembre 2017 Dernière intervention - Modifié par Vaucluse le 5/12/2017 à 19:18
0
Utile
re

en F6

=SI(ET(S6<>"";P6="";Q6="";R6="";T6="");TEXTE($S$2;"000");"")

crdlmnt

et celle ci à reproduire sur toutes les lignes (mais donne toujours un "nombre" à quatre chiffres
(pour trois, supprimer un 0 entre les guillemets)

=TEXTE(SI(P6<>"";$P$2;"")&SI(Q6<>"";$Q$2;"")&SI(R6<>"";$R$2;"")&SI(S6<>"";$S$2;"")&SI(T6<>"";$T$2;"");"0000")

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Commenter la réponse de Vaucluse
Raymond PENTIER 44507 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - Modifié par Raymond PENTIER le 6/12/2017 à 00:22
0
Utile
Si j'ai compris ce que tu veux faire, la formule pour la colonne H est :
=SI(V:V>0;V$2;"")&SI(W:W>0;W$2;"")&SI(X:X>0;X$2;"")
&SI(Y:Y>0;Y$2;"")&SI(Z:Z>0;Z$2;"")&SI(AA:AA>0;AA$2;"")
&SI(AB:AB>0;AB$2;"")&SI(AC:AC>0;AC$2;"")&SI(AD:AD>0;AD$2;"")
&SI(AE:AE>0;AE$2;"")

D'ailleurs je me rends compte que c'est bien ce qu'avait compris Vaucluse à propos de la colonne F !
Et dans ce cas, mes formules des postes #7, 8 et 10 seraient obsolètes ...
Les lignes 16 à 18 du fichier Excel ne seraient donc que des exemples ? Parce que j'avais d'abord cru qu'il s'agissait des seuls cas à traiter !

C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
Commenter la réponse de Raymond PENTIER
0
Utile
Bonjour Raymond et Bonjour Vaucluse,
Je me sens honteuse de vous empêcher d'avoir une vie privée et de dormir au vu de l'heure de vos post et oui.... mon problème n'est pas aussi simple que de prime abord et oui... les lignes 16 à 18 ne sont que des exemples arbitraires, sinon trop facile ;-)
je vais maintenant tester vos formules.... et quel que soit le résultat, vous êtes mes héros :-)
bonne matinée, à plus tard
crdt
Commenter la réponse de Acteemay
0
Utile
1
re bonjour,

Alors c'est confirmé... Raymond et Vaucluse vous êtes mes deux super héros.

Tant :
=TEXTE(SI(P6<>"";$P$2;"")&SI(Q6<>"";$Q$2;"")&SI(R6<>"";$R$2;"")&SI(S6<>"";$S$2;"")&SI(T6<>"";$T$2;"");"000")

que :
=SI(V:V>0;V$2;"")&SI(W:W>0;W$2;"")&SI(X:X>0;X$2;"")
&SI(Y:Y>0;Y$2;"")&SI(Z:Z>0;Z$2;"")&SI(AA:AA>0;AA$2;"")
&SI(AB:AB>0;AB$2;"")&SI(AC:AC>0;AC$2;"")&SI(AD:AD>0;AD$2;"")
&SI(AE:AE>0;AE$2;"")

Je tire vers le bas et tout est parfait et correspond magnifiquement à mon besoin... hors un tout petit détail, presque de la cosmétique... j'ai tout trituré dans tous les sens, y compris mes neurones et je n'arrive pas à ce que mes cellules en colonnes H, si "rien" en colonnes V à AE, apparaissent au format 00000 (ou par exemple 00AAH ou 0000S si renseigné à quelconque cellule de ces colonnes). Est-ce une incompatibilité entre chiffres et lettres ??? Est-ce un abus de ma part de vous demander d'éclairer encore une fois ma lanterne... Merciii
crdt
Vaucluse 20835 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 10 décembre 2017 Dernière intervention - 6 déc. 2017 à 13:07
Alors en fonction de la formule que vous avez écrite en H, en H6


=SI(NB.SI(V6:AE6;"<>")=0;"00000";Votre formule)

crdlmnt
Commenter la réponse de Acteemay