Fonction sur TCD : erreur liée à une cellule TEXTE [Résolu]

remy - 29 sept. 2017 à 17:46 - Dernière réponse :  remy
- 30 sept. 2017 à 20:15
Bonjour,

Dans un classeur je dispose de 2 onglets.
Le 1er est un tableau croisé dynamique présenté pour simplifier comme suit:
- lignes = comptes
- colonnes H à L = 2013/2014/2015/2016/2017
Dans le 2eme onglet je reprends en colonne A les noms de comptes du TCD (la fonction CONCATENER est utilisée pour sélectionner les sous totaux automatiques générés par TCD) et je cherche à calculer en colonne B la moyenne des données des 5 colonnes H à L du TCD
      • Là ça marche ***

La fonction suivante fonctionne pour les colonnes de I à L:
=SOMMEPROD((DONNEES!A:A=CONCATENER("Total ";A3))*((DONNEES!I:L)))/4
      • Et là ça ne marche plus ! ***

Mais si je fais la même fonction avec les colonnes de H à L :
=SOMMEPROD((DONNEES!A:A=CONCATENER("Total ";A3))*((DONNEES!H:L)))/5

Mon explication à ce stade est que la valeur texte "YEAR" en cellule H4 du TCD m'empêche d'accéder proprement aux données de la colonne H.

Question : comment exclure cette cellule dans ma fonction, ou exclure toute la ligne 4 TCD, ou autre....pour que ça fonctionne de H à L vu que de I à L c'est ok.

De plus, n'y a t il pas moyen d'intégrer la fonction MOYENNE dans ma formule plutôt que diviser par le nombre de colonnes ?

PS je ne souhaite pas intégrer un champs calculé dans mon TCD, ce pourquoi j'utilise un onglet à part.

Merci d'avance !

Bon we

remy



Afficher la suite 

6 réponses

Répondre au sujet
Raymond PENTIER 44509 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 29 sept. 2017 à 17:53
0
Utile
 1) Tu vas dans http://cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint
Commenter la réponse de Raymond PENTIER
0
Utile
Bonjour Raymond,
merci pour l'explication
voici le lien vers un fichier exemple :
http://www.cjoint.com/c/GIEqwAOyREe
merci
rémy
Commenter la réponse de remy
Raymond PENTIER 44509 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - Modifié par Raymond PENTIER le 30/09/2017 à 19:08
0
Utile
Ton analyse est correcte : Si tu supprimes les textes en H4 et M5 tes formules marchent correctement.
"Years" en H4 ne sert absolument à rien ; on peut s'en passer !
Fais glisser "Total général" de M5 à N5, aligné à droite, sans retour à la ligne automatique, et diminue la largeur de N pour que le texte occupe les cellules M5:N5.

C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
Commenter la réponse de Raymond PENTIER
0
Utile
1
Hello
Oui mais là pour l'exemple j'ai mis un tableau simple sur l'onglet Données
Dans la réalité ce tableau est un tcd et je ne peux pas supprimer les valeurs texte contenues dans les cellules :(
D'où mon pb pour les calculs dans l'onglet Synthese
Cdt
remy
Raymond PENTIER 44509 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 30 sept. 2017 à 19:19
Alors tu fabriques un onglet intermédiaire dont la cellule A4 contient la formule =DONNEES!A4 que tu recopies dans toutes les cellules utiles, mais pas dans les cellules H4 et M5, et tu fais ta synthèse à partie de cet onglet.

Sinon tu utilises les champs calculés et les autres fonctionnalités des TCD pour que le calcul se fasse directement dans le TCD ...
Commenter la réponse de remy
0
Utile
Bonne idée !
Je retiens la solution du tableau intermédiaire sur lequel je baserai les calculs et extractions de données.
Merci
Bonne soirée
remy
Commenter la réponse de remy