Quelle formule utiliser? [Résolu]

cracotte92 2 Messages postés vendredi 29 septembre 2017Date d'inscription 29 septembre 2017 Dernière intervention - 29 sept. 2017 à 16:20 - Dernière réponse : Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention
- 29 sept. 2017 à 16:40
Bonjour,
Problème assez complexe que je n'arrive pas à solutionner...
http://img-19.ccm2.net/YrdfzO9mquv_a0vCe1WZd114Rm0=/a27ad2c57b4f412ea9d355f8d9dbdc3e/ccm-ugc/excel.png
Deux tableaux :
Un premier comprend des noms et des valeurs suivants des références (de ref1 à ref5) qui se répètent par colonne. Ces références se répètent donc plusieurs fois (on imagine que le tableau est beaucoup plus long que celui de l'exemple.
Le deuxième est une synthèse du premier tableau. L'idée de ce tableau est de faire la somme des valeurs suivant la référence.

Je cherche donc une "formule" permettant de faire par nom, la somme des valeurs pour une référence donnée.

Exemple:
en N2 il fait la somme des valeurs dont la colonne à pour nom ref1 et trouve 2 pour le nom1
en O2 il fait la somme des valeurs dont la colonne à pour nom ref2 et trouve 4 pour le nom1

Evidemment l'ordre des références peut varier dans le tableau 1 donc les formules de type "=B1+F2" avec un "recopier vers le bas" de fonctionneront pas... je recherche plus une formule de type recherchev ou sommeprod... mais je n'arrive pas à trouver le moyen...

Merci pour votre aide !
Afficher la suite 
2Messages postés vendredi 29 septembre 2017Date d'inscription 29 septembre 2017 Dernière intervention

5 réponses

Répondre au sujet
Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 29 sept. 2017 à 16:28
0
Utile
2
Bonjour
selon votre image, à adapter

en N2 à tirer sur le tableau (attention aux signes $ aux bons endroits)

=SOMMEPROD($B$1:$K$1=N$1)*($A$2:$A$4=$M2)*($B$2:$K$4))

le champ B2:K4 ne doit contenir que des cellules vides ou des valeurs numériques

crdlmnt
cracotte92 2 Messages postés vendredi 29 septembre 2017Date d'inscription 29 septembre 2017 Dernière intervention - 29 sept. 2017 à 16:34
Bonjour,
ça marche très bien ! Merci beaucoup !
bon weekend!
cordialement
Vaucluse 20837 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 11 décembre 2017 Dernière intervention - 29 sept. 2017 à 16:40
Pas de quoi,
je passe le sujet en résolu
bonne route
crdlmnt
Commenter la réponse de Vaucluse
ccm81 8202 Messages postés lundi 18 octobre 2010Date d'inscription 11 décembre 2017 Dernière intervention - 29 sept. 2017 à 16:31
0
Utile
Bonjour

Essaies ceci
http://www.cjoint.com/c/GIDoFBBoRXB

Cdlmnt
Commenter la réponse de ccm81
via55 8788 Messages postés mercredi 16 janvier 2013Date d'inscription 12 décembre 2017 Dernière intervention - 29 sept. 2017 à 16:32
0
Utile
Bonjour

En N2 la formule :
=SOMME.SI($B$1:$I$1;N$1;$B2:$I2)

A étirer ensuite à droite et vers le bas

Cdlmnt
Via
Commenter la réponse de via55