Signaler

Quelle formule utiliser? [Résolu]

Posez votre question cracotte92 2Messages postés vendredi 29 septembre 2017Date d'inscription 29 septembre 2017 Dernière intervention - Dernière réponse le 29 sept. 2017 à 16:40 par Vaucluse
Bonjour,
Problème assez complexe que je n'arrive pas à solutionner...
http://img-19.ccm2.net/YrdfzO9mquv_a0vCe1WZd114Rm0=/a27ad2c57b4f412ea9d355f8d9dbdc3e/ccm-ugc/excel.png
Deux tableaux :
Un premier comprend des noms et des valeurs suivants des références (de ref1 à ref5) qui se répètent par colonne. Ces références se répètent donc plusieurs fois (on imagine que le tableau est beaucoup plus long que celui de l'exemple.
Le deuxième est une synthèse du premier tableau. L'idée de ce tableau est de faire la somme des valeurs suivant la référence.

Je cherche donc une "formule" permettant de faire par nom, la somme des valeurs pour une référence donnée.

Exemple:
en N2 il fait la somme des valeurs dont la colonne à pour nom ref1 et trouve 2 pour le nom1
en O2 il fait la somme des valeurs dont la colonne à pour nom ref2 et trouve 4 pour le nom1

Evidemment l'ordre des références peut varier dans le tableau 1 donc les formules de type "=B1+F2" avec un "recopier vers le bas" de fonctionneront pas... je recherche plus une formule de type recherchev ou sommeprod... mais je n'arrive pas à trouver le moyen...

Merci pour votre aide !
Utile
+0
plus moins
Bonjour
selon votre image, à adapter

en N2 à tirer sur le tableau (attention aux signes $ aux bons endroits)

=SOMMEPROD($B$1:$K$1=N$1)*($A$2:$A$4=$M2)*($B$2:$K$4))

le champ B2:K4 ne doit contenir que des cellules vides ou des valeurs numériques

crdlmnt
cracotte92 2Messages postés vendredi 29 septembre 2017Date d'inscription 29 septembre 2017 Dernière intervention - 29 sept. 2017 à 16:34
Bonjour,
ça marche très bien ! Merci beaucoup !
bon weekend!
cordialement
Répondre
Vaucluse 20497Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 17 octobre 2017 Dernière intervention - 29 sept. 2017 à 16:40
Pas de quoi,
je passe le sujet en résolu
bonne route
crdlmnt
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour

Essaies ceci
http://www.cjoint.com/c/GIDoFBBoRXB

Cdlmnt
Donnez votre avis
Utile
+0
plus moins
Bonjour

En N2 la formule :
=SOMME.SI($B$1:$I$1;N$1;$B2:$I2)

A étirer ensuite à droite et vers le bas

Cdlmnt
Via
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !