Signaler

Titre colonne dans tableau [Résolu]

Posez votre question petitspieds78 2Messages postés mardi 4 août 2015Date d'inscription 12 septembre 2017 Dernière intervention - Dernière réponse le 12 sept. 2017 à 14:22 par petitspieds78
Bonjour,

Sur excel 2010, je souhaiterais ajouter dans le tableau, le titre de la colonne correspondant à la première case non vide d'une ligne.

Voici un exemple de ce que je souhaierais :

http://img-19.ccm2.net/By3gDd78xh9VXp0_QYBhaKeNLtE=/6c8f3607a9244dff9bdfdacc7831fcc5/ccm-ugc/test_excel.jpg


Je ne maîtrise pas VBA donc si la solution pouvait être assez simple.
Quoi qu'il en soit, j'essaierai toutes les solutions.

Merci d'avance pour votre aide.
Utile
+0
plus moins
Bonjour
voyez avec cette formule en B2, à tirer sur la hauteur

=SIERREUR(INDEX($A$1:$O$1;PETITE.VALEUR(SI($C2:$O2>0;COLONNE($C$1:$O$1));1));"")
notes:
  • cette formule est matricielle est doit être entrée avec la touche enter en maintenant les touches ctrl et shift enfoncées

(elle s'affiche automatiquement entre accolades dans la barre de formule)
  • les adresses de champ commencent en A pour le code INDEX en C pour les autres
  • fonctionne à condition que les autres cellules de la ligne soient vides sans formules


crdlmnt
Donnez votre avis
Utile
+0
plus moins
Merci pour votre réponse.
Effectivement cette formule répond à mes attentes.
Cordialement
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !