Signaler

Calcul par pallier [Résolu]

Posez votre question ophelie - Dernière réponse le 14 juin 2017 à 17:09 par Frenchie83
Bonjour,

Je cherche une formule avec des conditions par palliers :

Quantités vendues de 0 à 50 : quantités vendues *0.5 €
Quantités vendues de 51 à 100 : quantités vendues *1€
Quantités vendues de 101 et au delà : quantités vendues *1.5 €

Sachant que si Paul en vend 62 il sera rémunéré de 0.5€ sur ses 50 premières boites vendues et de 1 € sur les 12.
Avec cette formule je devrais trouver 37 €.

Pouvez vous m'aider, merci !
Utile
+0
plus moins
Qu'est-ce que tu as déjà essayé comme formules ?
Envoie ton fichier avec les données et toutes les formules que tu as testées.
 1) Tu vas dans http://cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint
Donnez votre avis
Utile
+0
plus moins
Bonjour
Essayez ceci, avec les quantités en A2
=SI(A2>100;((A2-100)*1,5)+50+(50*0,5);SI(A2<=50;A2*0,5;(A2-50)+((A2-(A2-50))*0,5)))

Cdlt
Donnez votre avis
Utile
+0
plus moins
http://www.cjoint.com/c/GFondGkle5m
Frenchie83 1678Messages postés lundi 6 mai 2013Date d'inscription 10 octobre 2017 Dernière intervention - 14 juin 2017 à 17:09
il suffisait de remplacer la valeur 100 par 150, mais dans la formule de votre fichier, vous avez malencontreusement supprimé le 5 du dernier 50, revoici la formule corrigée:
=SI(B5>150;((B5-150)*1,5)+50+(50*0,5);SI(B5<=50;B5*0,5;(B5-50)+((B5-(B5-50))*0,5)))
Cdlt
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour à tous

Si tu changes l'énoncé ...
formule en C5
=SI(B5<=50;B5*0,5;SI(B5<=150;50*0,5+(B5-50)*1;50*0,5+100*1+(B5-150)*1,5))

que tu peux
- tirer vers le bas
- recopier en colonnes E, G, I

Cdlmnt
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !