Calcul par pallier [Résolu]

ophelie - 13 juin 2017 à 23:57 - Dernière réponse : Frenchie83 1711 Messages postés lundi 6 mai 2013Date d'inscription 11 décembre 2017 Dernière intervention
- 14 juin 2017 à 17:09
Bonjour,

Je cherche une formule avec des conditions par palliers :

Quantités vendues de 0 à 50 : quantités vendues *0.5 €
Quantités vendues de 51 à 100 : quantités vendues *1€
Quantités vendues de 101 et au delà : quantités vendues *1.5 €

Sachant que si Paul en vend 62 il sera rémunéré de 0.5€ sur ses 50 premières boites vendues et de 1 € sur les 12.
Avec cette formule je devrais trouver 37 €.

Pouvez vous m'aider, merci !
Afficher la suite 

5 réponses

Répondre au sujet
Raymond PENTIER 44530 Messages postés lundi 13 août 2007Date d'inscriptionContributeurStatut 13 décembre 2017 Dernière intervention - 14 juin 2017 à 06:38
0
Utile
Qu'est-ce que tu as déjà essayé comme formules ?
Envoie ton fichier avec les données et toutes les formules que tu as testées.
 1) Tu vas dans http://cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message tu fais "Coller".
=>Voir la fiche http://www.commentcamarche.net/faq/29493-utiliser-cjoint
Commenter la réponse de Raymond PENTIER
Frenchie83 1711 Messages postés lundi 6 mai 2013Date d'inscription 11 décembre 2017 Dernière intervention - Modifié par Frenchie83 le 14/06/2017 à 06:45
0
Utile
Bonjour
Essayez ceci, avec les quantités en A2
=SI(A2>100;((A2-100)*1,5)+50+(50*0,5);SI(A2<=50;A2*0,5;(A2-50)+((A2-(A2-50))*0,5)))

Cdlt
Commenter la réponse de Frenchie83
0
Utile
1
http://www.cjoint.com/c/GFondGkle5m
Frenchie83 1711 Messages postés lundi 6 mai 2013Date d'inscription 11 décembre 2017 Dernière intervention - 14 juin 2017 à 17:09
il suffisait de remplacer la valeur 100 par 150, mais dans la formule de votre fichier, vous avez malencontreusement supprimé le 5 du dernier 50, revoici la formule corrigée:
=SI(B5>150;((B5-150)*1,5)+50+(50*0,5);SI(B5<=50;B5*0,5;(B5-50)+((B5-(B5-50))*0,5)))
Cdlt
Commenter la réponse de OPHELIE
ccm81 8204 Messages postés lundi 18 octobre 2010Date d'inscription 12 décembre 2017 Dernière intervention - Modifié par ccm81 le 14/06/2017 à 15:41
0
Utile
Bonjour à tous

Si tu changes l'énoncé ...
formule en C5
=SI(B5<=50;B5*0,5;SI(B5<=150;50*0,5+(B5-50)*1;50*0,5+100*1+(B5-150)*1,5))

que tu peux
- tirer vers le bas
- recopier en colonnes E, G, I

Cdlmnt
Commenter la réponse de ccm81