Signaler

Problème référence et tri [Résolu]

Posez votre question delphine - Dernière réponse le 15 juin 2017 à 12:13 par ccm81
Bonjour,
j'ai un problème de référence de valeurs dans mon calcul des pourcentages quand je modifie mon tri... pouvez-vous m'aider
voici un exemple


a 500 41% 146
b 250 59% 206
c 670 29% 345
d 120 71% 850



c 670 70% 345
a 500 41% 146
b 250 59% 206
d 120 80% 850

d'avance merci
Utile
+0
plus moins
Bonjour

Tu as certainement des pourcentages calculés (par formule), ce qui peut provoquer les erreurs

Cdlmnt
delphine- 13 juin 2017 à 12:54
oui tout à fait
les pourcentage sont obtenu à partir des cellules de la dernière colonne
Répondre
Donnez votre avis
Utile
+0
plus moins
Il faut voir comment sont écrites ces formules.
Peux tu envoyer un bout de ton fichier anonymisé, mais avec la même structure que l'original,sur cjoint.com et joindre le lien obtenu à ton prochain message. N'oublies pas d'y ajouter des explications et des exemples de résultat attendu
1) Tu vas dans http://cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien
en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse
tu fais "Coller".

Cdlmnt
delphine- 13 juin 2017 à 13:19
http://www.cjoint.com/c/GFnls15pWba
Répondre
Donnez votre avis
Utile
+0
plus moins
Il te faut en colonne G, une formule qui calcule tes moyennes sans faire référence à des lignes particulières
Essaies en G3, cette formule matricielle (à valider avec Ctrl+maj+entrée - elle se mettra alors entre accolades)
=P3/SOMME(SI($B$3:$B$70=B3;$P$3:$P$70))
J'ai limité les lignes à 70, mais tu peux allonger bien sûr)

Cdlmnt
delphine- 13 juin 2017 à 14:28
merci
c'est exactement ça
Répondre
delphine- 15 juin 2017 à 10:00
bonjour,
est-il possible de rajouter à cette formule:
le fait que si la colonne B n'affiche qu'une seule fois une valeur, la colonne G affiche la valeur 100% et non la valeur de la formule matricielle?
Répondre
delphine- 15 juin 2017 à 10:22
j'ai testé ceci, mais ca ne fonctionne que pour la réponse ci vrai, plus pour votre formule matricielle si faux
=SI((NB.SI(B3:B70;B3))=1;100%;"=P3/SOMME(SI($B$3:$B$70=B3;$P$3:$P$70))")
Répondre
Donnez votre avis
Utile
+0
plus moins
Bonjour

si la colonne B n'affiche qu'une seule fois une valeur, la colonne G affiche la valeur 100% et non la valeur de la formule matricielle?
je ne comprends pas bien ta question, en ligne 6 et 7 (fichier joint), on n'a qu'une occurrence de la valeur en colonne B et un beau 100% en colonne G
http://www.cjoint.com/c/GFpjv6yuyV6

Cdlmnt
delphine- 15 juin 2017 à 11:39
oui en effet cela marche sauf quand je n'ai pas d'élèves dans la colonne P
Hors cela m'arrive d'avoir un nombre d'élèves unique en N pour deux adresse
Répondre
delphine- 15 juin 2017 à 11:42
http://www.cjoint.com/c/GFpjO7eHTw7

c'est pour cela que j'aurais voulu rajouter que si je n'ai qu'une seule fois la valeur dans la colonne B ce soit d'office 100%
Répondre
Donnez votre avis
Utile
+0
plus moins
1. oui en effet cela marche sauf quand je n'ai pas d'élèves dans la colonne P
formule toujours matricielle
=SI(P7="";"";P7/SOMME(SI($B$3:$B$71=B7;$P$3:$P$71)))
2. Hors cela m'arrive d'avoir un nombre d'élèves unique en N pour deux adresse
??
3. c'est pour cela que j'aurais voulu rajouter que si je n'ai qu'une seule fois la valeur dans la colonne B ce soit d'office 100%
???

Cdlmnt
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !