Qui me trouve la formule [Résolu]

Guilouxx 7 Messages postés dimanche 11 juin 2017Date d'inscription 16 juin 2017 Dernière intervention - 12 juin 2017 à 21:37 - Dernière réponse : Guilouxx 7 Messages postés dimanche 11 juin 2017Date d'inscription 16 juin 2017 Dernière intervention
- 16 juin 2017 à 15:41
Bonjour à tous,


je fais appelle encore appelle à vous car je n'arrive pas imbriquer
2 fonctions dans excel

je m'explique dans la feuille de calcul j'ai deux onglets
la premiere etant celle ou je veux appliquer la formule le deuxieme onglet se trouve les valeurs que je cherche (le stock en F)

ma premier formule est de chercher 4 chiffres dans une suite de nombre et d'utiliser le resultat dans une fonction rechercheV
j'arrive à le faire sur deux formules mais pas avec une seul

la premiere formule est =CNUM(STXT(B3;8;4)) qui sur le deuxieme onglet
la deuxieme formule est =RECHERCHEV(A2;'stock '!$A$1:$G$17;6;FAUX) par exemple

en plus clair
je dois trouver en onglet 2 le gencod de A2 soit 2233 pour trouver le stock en onglet 1

je joins le fichier au cas ou

http://www.cjoint.com/c/GFmtJMRWPT2

par avance merci
Afficher la suite 

9 réponses

Répondre au sujet
DjiDji59430 1792 Messages postés samedi 19 avril 2008Date d'inscription 16 janvier 2018 Dernière intervention - 12 juin 2017 à 22:16
+1
Utile
1
Bonjour,

Je crois que ce n"est pas le bon fichier !
Cette réponse vous a-t-elle aidé ?  
Guilouxx 7 Messages postés dimanche 11 juin 2017Date d'inscription 16 juin 2017 Dernière intervention - 13 juin 2017 à 07:18
ah oui mince

je reposte le lien

http://www.cjoint.com/c/GFnft0P1pZ2

j' en pprofite pour vous dire que recherchev n'est pas la bonne formule mais index equiv serait mieux je pense
Commenter la réponse de DjiDji59430
michel_m 14970 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 16 janvier 2018 Dernière intervention - 13 juin 2017 à 14:51
+1
Utile
1
bonjour

avec une colonne intermédiaire (évite un casse t^te !!!)

le classeur en retour
https://mon-partage.fr/f/xzPbgaMg/
Cette réponse vous a-t-elle aidé ?  
Guilouxx 7 Messages postés dimanche 11 juin 2017Date d'inscription 16 juin 2017 Dernière intervention - 14 juin 2017 à 10:23
Merci Michel

c'est ce que je veux faire mais malheureusment c'est deja ce que j'ai fait.
seulement je cherche a faire la meme chose en une seule formule car le tableau de stok
est un tableau sur lequel je ne peux agir et il est renouvellé continuellement
Commenter la réponse de michel_m
michel_m 14970 Messages postés lundi 12 septembre 2005Date d'inscriptionContributeurStatut 16 janvier 2018 Dernière intervention - 13 juin 2017 à 08:34
0
Utile
1
Bonjour
bonjour djidji, excuse l'incruste

pourquoi appeler "stock" dans ta recherche alors la référence complète du produit se trouve dans "stock" et le tarif dans la feuille "tarif brut")

=RECHERCHEV(CNUM(DROITE(B3;4));'TARIF BRUT '!A$2:C$16;3;0)
DjiDji59430 1792 Messages postés samedi 19 avril 2008Date d'inscription 16 janvier 2018 Dernière intervention - 13 juin 2017 à 10:54
Bonjour,

Pas de problèmes !
Si ce n'est pas moi, c'est donc mon frère (en excel) !!

Crdmt
Commenter la réponse de michel_m
Guilouxx 7 Messages postés dimanche 11 juin 2017Date d'inscription 16 juin 2017 Dernière intervention - 13 juin 2017 à 12:54
0
Utile
la formule ne fonctionne pas sur le fichier

je me suis peut etre mal exprimer

onglet 1 (tarif brut) a un gencode court ici 2233 (quatre derniers chiffres )
je dois trouver le stock qui est en onglet 2 (stock) avec un gencode long ici13473572233 ( dout la recherche de txt et un conversion en nom (cnum)

sur mon premier onglet en D2 je dois trouver le resultat de l'onglet stock en f3

merci de aide je rame
Commenter la réponse de Guilouxx
DjiDji59430 1792 Messages postés samedi 19 avril 2008Date d'inscription 16 janvier 2018 Dernière intervention - 14 juin 2017 à 18:36
0
Utile
1
Bonjour,

Un essai :

http://www.cjoint.com/c/GFoqJj7HFQ2

Crdmt
Guilouxx 7 Messages postés dimanche 11 juin 2017Date d'inscription 16 juin 2017 Dernière intervention - 16 juin 2017 à 15:41
super
merci
genial
impec

Resolu donc
Commenter la réponse de DjiDji59430