Date dans résultat formule SI [Résolu]

Amandine6782 - 16 mai 2017 à 13:41 - Dernière réponse : diablo13800 1040 Messages postés jeudi 2 juillet 2015Date d'inscription 16 janvier 2018 Dernière intervention
- 17 mai 2017 à 11:45
Bonjour,

j'ai un souci de format de cellule par rapport au résultat d'une formule SI :

Ma formule dans la case S15 est:
SI(M15="Texte A";N15;"")

N15 est une cellule au format date.
Je voudrais que le résultat affiché dans S15 soit une date (en l’occurrence la même que dans N15, c'est le but de la formule). Excel me donne un résultat au format nombre, alors que N15 et S15 sont au format date.
Quand je tape une date manuellement dans S15 elle s'affiche bien au format date.

Comment faire pour avoir une date et pas un nombre dans S15?

Merci pour votre aide.

Amandine
Afficher la suite 

11 réponses

Répondre au sujet
diablo13800 1040 Messages postés jeudi 2 juillet 2015Date d'inscription 16 janvier 2018 Dernière intervention - 16 mai 2017 à 14:06
0
Utile
3
Bonjour,

Essayer de changer le format de la case S15 en format date, ca devrait fonctionner.
Amandine6782 - 16 mai 2017 à 14:19
Bonjour,

c'est déjà fait, la cellule S15 est au format date mais elle affiche un nombre...
Quand j'ouvre la fenêtre "Format de cellule" j'ai le format date (colonne de gauche) et 14-mars-12 (colonne de droite) qui sont surlignés, mais j'ai 42774 dans la ligne "exemple" au dessus.
diablo13800 1040 Messages postés jeudi 2 juillet 2015Date d'inscription 16 janvier 2018 Dernière intervention - 16 mai 2017 à 14:23
Bizarrement je viens de faire le test et ça fonctionne...

Est-ce que vous pouvez envoyer votre fichier grâce a ce site :
http://cjoint.com

Supprimer les données confidentiel et laisser quequechose de verifiable:)
Amandine6782 - 17 mai 2017 à 11:00
En fait je n'ai pas donné toutes les données du problème parce que je pensais que ça n'avait pas de rapport...
Ma formule est de type =SI(1=1;2;3)&SI(2=2;3;4)&SI... etc
Du coup je pense qu'Excel fait une somme et donc l'affiche sous forme de nombre
Le lien vers le fichier:
http://www.cjoint.com/c/GEri5wlTYbf

Du coup je ne sais pas comment faire... peut être avec la fonction RECHERCHE plutot?
Commenter la réponse de diablo13800
diablo13800 1040 Messages postés jeudi 2 juillet 2015Date d'inscription 16 janvier 2018 Dernière intervention - 17 mai 2017 à 11:07
0
Utile
6
Bonjour,

J'ai votre fichier sous les yeux, pouvez-vous me donnez un exemple de ce que devrait sortir le fichier et sous quel condition afin de comprendre comment cela fonctionne

Car je vois beaucoup de livrés chez ... plusieurs Cases, etc etc...

Un exemple sur une des lignes m'aiderais :) ( et précisé si ça doit être toutes les condition ou une sur plusieurs)
diablo13800 1040 Messages postés jeudi 2 juillet 2015Date d'inscription 16 janvier 2018 Dernière intervention - 17 mai 2017 à 11:27
D'accord je vois ce que vous voulez faire, votre formule est bien plus simple que tous les Si que vous avez mis les uns après les autres:)

La colonne A est prioritaire sur la E ?

Le cas ou les deux sont rempli laquelle est bonne?

Essayer quelque chose comme ca:

=SI(OU(A5="Livrés chez LINGENHELD";A5="Livrés chez EDIB");B5;SI(OU(D5="Livrés chez LINGENHELD";D5="Livrés chez EDIB");E5;""))
Amandine6782 - 17 mai 2017 à 11:32
Il n'y a pas de colonne prioritaire, si la colonne A contient un des 2 textes en questions la colonne D sera forcément vide
Et si un des 2 textes est dans la colonne D il ne pourra s'y trouver dans la colonne A
Donc le cas ou le texte est présent à la fois dans la colonne A et D n'est pas possible
diablo13800 1040 Messages postés jeudi 2 juillet 2015Date d'inscription 16 janvier 2018 Dernière intervention - 17 mai 2017 à 11:34
Essayez ma formule et dites moi si elle vous correspond:)
Amandine6782 - 17 mai 2017 à 11:41
Ça marche !

Merci beaucoup pour votre aide, vous m'épargnez des heures de galère :-D

Très bonne journée à vous
diablo13800 1040 Messages postés jeudi 2 juillet 2015Date d'inscription 16 janvier 2018 Dernière intervention - 17 mai 2017 à 11:45
Passez le message en résolu ça peut aider certaine personnes :)

Bonne journée à vous aussi
Commenter la réponse de diablo13800