Recherche avancée [Résolu]

RachelMartel 432 Messages postés mardi 14 mai 2013Date d'inscription 3 juin 2017 Dernière intervention - 15 févr. 2017 à 19:35 - Dernière réponse : RachelMartel 432 Messages postés mardi 14 mai 2013Date d'inscription 3 juin 2017 Dernière intervention
- 15 févr. 2017 à 22:05
Bonjour,

Après plusieurs tentatives, je fais appel à vous pour trouver la formule magique que je cherche.
Je vous joins un classeur exemple.

http://www.cjoint.com/c/GBpswG1yJH3

Dans ce classeur, j'ai une plage A2:C10 avec des numéros qui peuvent être en doublons. J'ai ensuite une plage A1:C1 où je peux inscrire un X.

En dessous, j'ai la liste des numéros uniques. À côté, j'aimerais qu'un X s'inscrive si le numéro se trouve dans la plage A2:C10 ET qu'il y a un x dans la plage A1:C1 au-dessus de la colonne où il se trouve.

Il faut considérer que dans mon fichier original j'ai beaucoup plus que 3 colonnes et 9 lignes.

Merci d'avance! :)

Afficher la suite 

2 réponses

Répondre au sujet
Vaucluse 20852 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 13 décembre 2017 Dernière intervention - Modifié par Vaucluse le 15/02/2017 à 19:51
+1
Utile
1
Bonsoir
essayez ça en B19, à adapter:

=SI(SOMMEPROD(($A$2:$Z$10=$A19)*($A$1:$Z$1="X"))=0;"";"X")

vous renverra X si au moins une colonne qui contient la valeur de A19 a un X en ligne 1

crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
Cette réponse vous a-t-elle aidé ?  
RachelMartel 432 Messages postés mardi 14 mai 2013Date d'inscription 3 juin 2017 Dernière intervention - 15 févr. 2017 à 22:05
Je me cassais beaucoup trop la tête! Je ne sais pas pourquoi je n'y suis pas arrivée! Merci beaucoup! :)
Commenter la réponse de Vaucluse