Signaler

Décimales sur moyenne [Résolu]

Posez votre question mkway27 - Dernière réponse le 16 févr. 2017 à 11:20 par Vaucluse
Bonjour,

je suis à la recherche d'une fonction me permettant d'avoir le bon format sur une cellule , si joint les explications

A1 0,06
A2 0,06
A3 0,06
A4 0,06
A5 0,06
A6 0,05
A7 0,05
A8 0,05
A9 0,08

A10 MIN ( a1:a9) 0,05
A11 max(a1:a9) 0,08
A12 moyenne(a1:a9) 0,058888889

Je souhaiterai que le format de la cellule A12 (moyenne) est le même nombre de décimale que la cellule A1 sachant que les valeurs des cellules A1 à A9 peuvent être différentes , soit pas de décimale , soit 3, 4 ou 5 décimales.

J'ai cherché un peu partout sur les forums mais je sèche complètement. Votre aide me sera très précieuse.
Merci par avance

Mick
Afficher la suite 
Utile
+0
moins plus
Bonjour
avec arrondi?

=ARRONDI(MOYENNE(A1:A9);2)

ou si le nombre de décimales en A1 est variable:

=ARRONDI(MOYENNE(A1:A9);NBCAR(STXT(A1;TROUVE(",";A1)+1;20)))

cette option pourra "raccourcir" les décimales, mais pas en rajouter en 0

crdlmnt
micky27 7Messages postés samedi 4 juin 2016Date d'inscription 16 février 2017 Dernière intervention - 16 févr. 2017 à 11:10
Bonjour,

merci pour la formule qui m'a permis de l'adapter à mon besoin.
A+
Répondre
Vaucluse 18974Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 27 février 2017 Dernière intervention - 16 févr. 2017 à 11:20
Ok je passe le sujet en résolu
Bonne route
crdlmnt
Répondre
Donnez votre avis
Utile
+0
moins plus
Bonjour à tous

On peut aussi envoyer l'artillerie lourde et une macro (conserve la valeur)
http://www.cjoint.com/c/GBokoHzKL2f

Cdlmnt
Donnez votre avis
Utile
-1
moins plus

Bonjour Mick.

Tu te crées des soucis inutiles ...
Il te suffit de modifier le format de cellule quand c'est nécessaire !
micky27 7Messages postés samedi 4 juin 2016Date d'inscription 16 février 2017 Dernière intervention - 16 févr. 2017 à 11:08
Bonjour,

merci pour le conseil mais ce n'était pas la manip que je cherchais. J'ai grace à tous ces conseils trouvé la solution.
A+
Répondre
Donnez votre avis

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !