Signaler

Conversion métrique vers impérial avec [Résolu]

Posez votre question jayjay1984 4Messages postés mercredi 23 novembre 2016Date d'inscription 25 novembre 2016 Dernière intervention - Dernière réponse le 25 nov. 2016 à 22:17
Bonjour,
je vais tenter de vous expliquez mon problème. Je suis en train d'étudier en estimation (construction) et dans ma feuille de quantité, j'ai une colonne avec plusieurs résultat (métrique). Ces résultats ont chacun leur propre format (25.54 m³) et j'aimerais pouvoir dire a ma colonne impériale =si(A1="# ##0.00 m³";texte(A1/35.313;"# ##0.00 p³");..... dans ma colonne j'ai des superficies, des volumes, des nombres simple. Le but est d'appliquer la bonne conversion selon le format et changer celui-çi en meme temp. Merci bcp, j'attend vos suggestion avec impatience.
Afficher la suite 
Utile
+0
moins plus
Bonjour,

Bienvenue sur le forum.

Je ne sais pas ce que vous appelez "colonne impériale" au Canada, surtout que vous n'avez pas d'empereur comme au Japon à ma connaissance.
Avec la fonction TEXTE, tu peux effectivement mettre un format mais si ta cellule est numérique, rien ne va permettre de savoir si tu as affaire à des m3 ou des m².
Il faudra bien avoir des paramètres quelque part pour le spécifier.
Ajouter un commentaire
Utile
+0
moins plus
Bonjour,

Qq chose m'échappe...
Si tu as mis m² en format personnalisé dans une cellule, dans la cellule d'à-coté tu sais que ce sont des m² que tu auras à convertir. Non ?

Ceci dit =CELLULE("format";B2) te permet d'avoir le format appliqué. Mais tu n'auras pas le détail pour les formats personnalisés.
Je t'ai fait une fonction personnalisée pour récupérer plus complètement le format.
Avec =formatCel(B2) tu récupères la totalité du format.
Avec =formatCel(B2,vrai) tu récupères la partie unité d'un format personnalisé récupéré sur le format appliqué aux nombres positifs.
http://www.cjoint.com/c/FKxwlCwUcnw

Au passage tu as la fonction Convert() pour tes conversions
eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Ajouter un commentaire
Utile
+0
moins plus
Merci bcp Éric je vais tester ça demain.
eriiic 20010Messages postés mardi 11 septembre 2007Date d'inscription ContributeurStatut 7 décembre 2016 Dernière intervention - 24 nov. 2016 à 07:49
Bonjour,

merci de rester sur le forum.
Je te re-dépose le fichier : https://mon-partage.fr/f/Vg90A9uT/
eric
Répondre
jayjay1984 4Messages postés mercredi 23 novembre 2016Date d'inscription 25 novembre 2016 Dernière intervention - 25 nov. 2016 à 13:48
j'ai pu ouvrir la feuille merci bcp par contre, comment puis-je l'appliquer dans une formule avec Si ex: =SI(B2=FormatCel(m²);B2*10.764 (avec format "p²");SI(.......
Merci j'ai demandé a plusieurs prof excel et aucun n'a réussi a trouver la solution :)
je me demande si c'est réalisable ... Bonne journée Éric !
Répondre
eriiic 20010Messages postés mardi 11 septembre 2007Date d'inscription ContributeurStatut 7 décembre 2016 Dernière intervention - 25 nov. 2016 à 15:13
Bonjour,

à utiliser comme toute autre fonction. Ex :
=SI(formatCel(B2;VRAI)="m²";B2*1.5;B2)
eric
Répondre
jayjay1984 4Messages postés mercredi 23 novembre 2016Date d'inscription 25 novembre 2016 Dernière intervention - 25 nov. 2016 à 22:17
Haha, tu es un vrai pro sa fonctionne. Merci Énormément !!!
Tu viens de faire ma journée :) A++ Éric
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !