Somme heures et minutes [Résolu/Fermé]

roro - 21 nov. 2016 à 19:06 - Dernière réponse : Mike-31 15895 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 14 décembre 2017 Dernière intervention
- 22 nov. 2016 à 08:53
Bonjour,

Je recois un rapport regulier avec dans une colonne des durées sous cette forme :
0 H 15 MIN
1 H 15 MIN
8 H 52 MIN
6 H 12 MIN
4 H 24 MIN

J'aimerais faire la somme d'une maniere le plus simple possible
cdlt


Afficher la suite 

7 réponses

Mike-31 15895 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 14 décembre 2017 Dernière intervention - Modifié par Mike-31 le 21/11/2016 à 19:35
+1
Utile
2
Bonsoir,
Bonsoir l'ami Vaucluse,
ou tu ajoutes une colonne avec cette formule et tu formates la cellule en format heure et tu incrémentes vers le bas
ensuite c'est plus facile de faire la somme

=SUBSTITUE(SUBSTITUE(A1;" H ";":");" MIN";"")*1
ou encore comme cela pour traiter le nombre d'espace qui pourrait être variable
  • =SUBSTITUE(SUBSTITUE(SUBSTITUE(A1;" ";"");"H";":");"MIN";"")*1


A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.
Cette réponse vous a-t-elle aidé ?  
Vaucluse 20862 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 14 décembre 2017 Dernière intervention - 21 nov. 2016 à 19:58
Bonsoir Mike
sur le même principe on peut aussi directement écrire:
=SOMMEPROD((SUPPRESPACE(GAUCHE(SUBSTITUE(A1:A5;" H ";":");NBCAR(A1:A5)-6))*1)*1)

crdlmnt
roro > Vaucluse 20862 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 14 décembre 2017 Dernière intervention - 21 nov. 2016 à 20:43
Ah ben oui ca marche direct là

Merci beaucoup
Vaucluse 20862 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 14 décembre 2017 Dernière intervention - Modifié par Vaucluse le 21/11/2016 à 19:18
0
Utile
Bonjour
si:
  • vos données sont en format texte
  • les lettres H et MIN sont toujours séparées des valeurs par un blanc


cette formule (à adapter) vous donnera le résultat pour les valmeurs citées collées en A1:A5

=SOMMEPROD((GAUCHE($A$1:$A$5;TROUVE("H";$A$1:$A$5)-1)*1)*60)+SOMMEPROD((STXT($A$1:$A$5;TROUVE("H";$A$1:$A$5)+2;2)*1)*1))/1440

dans une cellule formatée en heure / HH:MM

si ça ne convient pas, déposez un exemple de votre liste dans un modèle Excel sur:
http://www.cjoint.com
et revenez ici coller le lien donné sur le site
crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
0
Utile
Merci pour vos réponse

Malheureusement excel m'indique que la formule comporte des erreurs quand je la colle dans B1
ci suit le lien du fichier
http://www.cjoint.com/c/FKvtiyTBllA
Merci d'avance
0
Utile
Merci Mike_31

Ca fonctionne bien , plus qu a faire la somme ensuite

Merci encore
Mike-31 15895 Messages postés dimanche 17 février 2008Date d'inscriptionContributeurStatut 14 décembre 2017 Dernière intervention - Modifié par Mike-31 le 22/11/2016 à 09:05
0
Utile
Re,

ta discussion ouverte en doublon ici sera certainement fermée ou supprimée par la médiation.
alors à ma proposition sur le post 2 complète ma formule dans une colonne que tu incrémentes vers le bas

=SIERREUR(SUBSTITUE(SUBSTITUE(SUBSTITUE(A1;" ";"");"H";":");"MIN";"")*1;"")

ensuite une simple formule exemple si ta formule est en colonne D =SOMME(D1:D50) voire =SOMME(D:D)

en calcul direct sur la proposition de l'ami Vaucluse il est possible d'améliorer sa formule en matricielle que je lui laisse le soin d'apporter
A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.