Signaler

Lien hypertexte vers onglet [Résolu]

Posez votre question Robert2036 13Messages postés samedi 23 avril 2016Date d'inscription 23 octobre 2016 Dernière intervention - Dernière réponse le 20 oct. 2016 à 21:30
Bonjour à toutes et à tous,
Dans le fichier joint j'aurai voulu, mais sans macro, que chaque formule de la colonne "A" renvoient aux onglets correspondants du classeur, sachant que j'ai tronqué le fichier mais que ce qui reste est juste. Dans A4 c'est simple car 1ère semaine, mais comme les autres cellules A2, A3,etc, ne sont pas nécessairement en continu et c'est voulu, je voulais par lien hypertexte ou autre formule sélectionner les onglets correspondants.
Merci à toutes celles et ceux qui se pencherons sur ce problème et sur le temps qu'ils prennent avec courtoisie et gentillesse pour nous aider.
Encore merci à tous les autres qui m'ont aidé de par le passé.

http://www.cjoint.com/c/FJtsQLcJqxu
Afficher la suite 
Utile
+0
moins plus
Bonjour,

En A4 tu peux mettre cette formule :
=SI(B4="";"";LIEN_HYPERTEXTE(GAUCHE(STXT(CELLULE("nomfichier");TROUVE("[";CELLULE("nomfichier"));100);TROUVE("]";STXT(CELLULE("nomfichier");TROUVE("[";CELLULE("nomfichier"));100)))&1& "èS!A1";1& "èS!"))

Comme c'est un peu lourd tu peux aussi mettre en C1 par exemple pour récupérer le nom du classeur :
=GAUCHE(STXT(CELLULE("nomfichier");TROUVE("[";CELLULE("nomfichier"));100);TROUVE("]";STXT(CELLULE("nomfichier");TROUVE("[";CELLULE("nomfichier"));100)))

puis en A5 tu simplifie ainsi :
=SI(B5="";"";LIEN_HYPERTEXTE($C$1&2& "èS!A1";2& "èS!"))

et tu peux continuer ainsi pour les autres lignes.
Ajouter un commentaire
Utile
+0
moins plus
Bonjour gbinforme,
Merci d'avoir répondu aussi vite.
Lorsque tu parles de "nomdefichier" est-ce-que je dois mettre le chemin complet du fichier c:\etc... ? dans C1 il me marque "VALEUR" dans A4 "#REF!" et dans A5 "VALEUR". Comme ces formules sont pour moi inconnues et dépassent mes compétences je me disais que les erreurs venaient du fait de trouver le chemin du fichier. Lorsque je cliquerai sur la cellule par exemple A4 ,est-ce que cela sélectionnera l'onglet correspondant 4èS automatiquement?
Merci encore pour ton aide car là je suis perdu.
Cordialement
Robert2036
Ajouter un commentaire
Utile
+0
moins plus
Bonjour Robert2036,

Comme les exemples valent mieux qu'un long discours, je te renvoie ton classeur avec les formules en C1 A4 et A5 qui te permettent d'aller dans les feuilles 1 et 2.
Il faut que le classeur soit sauvegardé sur ton disque pour que cela fonctionne.

http://www.cjoint.com/c/FJuqMNzzobl

Dans les feuilles 1 et 2 je t'ai rajouté un petit bouton qui te permet de retourner à l'accueil : tu peux le copier et le coller dans les autres feuilles si cela te convient.
Ajouter un commentaire
Utile
+0
moins plus
Rebonjour gbinforme,
Super ta réponse, c'est exactement ce que je voulais ; dans Excel il y à tellement à faire que quelques années me seront nécessaires pour n'en connaître qu'un peu.
Encore merci pour ta grande aide.
Bravo !
Cordialement.
Robert2036
gbinforme 12902Messages postés lundi 18 octobre 2004Date d'inscription ContributeurStatut 6 décembre 2016 Dernière intervention - 20 oct. 2016 à 21:30
dans Excel il y à tellement à faire que quelques années me seront nécessaires pour n'en connaître qu'un peu.
C'est ce qui arrive à tout le monde et plus tu en apprends, plus tu te rends compte que ce que tu pourrais utiliser est une immensité à découvrir.
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !