Signaler

Remplacer nom de feuille dans formule

Posez votre question cfl0fl0 7Messages postés samedi 10 septembre 2016Date d'inscription 19 octobre 2016 Dernière intervention - Dernière réponse le 19 oct. 2016 à 17:37
Bonjour,

dans A1 j'ai cette formule (S1 est le nom de ma feuille)
=S1.$F$7+S1.$F$8+S1.$F$9+S1.$AC$7+S1.$AC$8+S1.$AC$9+S1.$AZ$7+S1.$AZ$8+S1.$AZ$9+S1.$BW$7+S1.$BW$8+S1.$BW$9+S1.$CT$7+S1.$CT$8+S1.$CT$9+S1.$DQ$7+S1.$DQ$8+S1.$DQ$9+S1.$EN$7+S1.$EN$8+S1.$EN$9
dans A2 je voudrais changer S1 par S2(nom de ma seconde feuille)
dans A3 je voudrais changer S1 par S3....
Comment faire sans avoir à retaper la formule à chaque fois?

Merci pour vos réponses
Afficher la suite 
Utile
+0
moins plus
Bonjour
faite par exemple en colonne A la liste de vos noms de feuilles en commençant en ligne 1 pour l'exemple
la formule (un peu simplifièe,) deviendrait


=SOMME(INDIRECT(A1&"!F7:F9");INDIRECT(A1&"!AC7:AC9");INDIRECT(A1&"!AZ7:AZ9");INDIRECT(A1*"!BW7:BW9");INDIRECT(A1&"!CT7:CT9");INDIRECT(A1$"!DQ7:DQ8");INDIRECT(A1&"!EN7:EN8"))
la formule s'adressera au nom de feuille inscrit en A qui s'incrémente en descendant
respectez bien les signes (n'oubliez pas le ! derriére le 1° guillemet à chaque adresse)
Par contre les adresses, entre guillemets ne s'incrémentent pas et ne nécessitent pas de $

en complément si vos noms de feuilles sont construits sans blancs aves la lettre S suivi d'une valeur num ( 1 à 52 par exemple) vous pouvez éviter la liste des noms de feuilles en remplaçant dans tous les postes de la formule A1 par "S"&LIGNE(A1)pour la première feuille

donc par exemple:
.....INDIRECT("S"&LIGNE(A1)&"!D7:D9").......

LIGNE(A1) =1 et va s(incrémenter en LIGNE(A2) =2 etc..


et si des feuilles n'existent pas écrivez:

=SIERREUR(toute la formule);"") pour éviter un affichage d'erreur

crdlmnt
Ajouter un commentaire
Utile
+0
moins plus
je ne dois pas être douée parce que j'ai un message d'erreur
Vaucluse 18321Messages postés lundi 23 juillet 2007Date d'inscription ContributeurStatut 9 décembre 2016 Dernière intervention - 16 oct. 2016 à 15:00
vous écrvez quelle formule?
et quel est ce lmessage?
quels sont vos noms de feuille?
Répondre
Ajouter un commentaire
Utile
+0
moins plus
=SOMME(INDIRECT(C19&"!J7:!J9");INDIRECT(C19&"!AG7:!AG9"))

en C19 j'ai S1 (le nom de ma feuille)

Ca y est, j'y suis arrivée mais dans votre exemple il manquait des !

Merci beaucoup de votre aide.
Ajouter un commentaire
Utile
+0
moins plus
Est il possible dans la cellule d'à côte de copier cette même formule mais d'augmenter de 1 le nom des cellules, c'est à dire

=SOMME(INDIRECT(C19&"!J7:!J9");INDIRECT(C19&"!AG7:!AG9"))

où J7:J9 doit devenir K7:k9 mais C19 doit rester C19

Quand je fais un "copier/coller" les cellules additionnes restent les mêmes mais C19 se transforme en D19
albkan 1858Messages postés samedi 26 mars 2016Date d'inscription 9 décembre 2016 Dernière intervention - 19 oct. 2016 à 17:37
Bonjour cfl0fl0,

D'abord, je recopie texto ta formule :

=SOMME(INDIRECT(C19&"!J7:!J9");INDIRECT(C19&"!AG7:!AG9"))

Note que les deux « ! » en gras (donc juste après les « : ») sont en trop ;
donc ça devient :

=SOMME(INDIRECT(C19&"!J7:J9");INDIRECT(C19&"!AG7:AG9"))

------------------------------------------------------

Tu dois mettre un caractère « $ » devant une colonne qui doit rester fixe ;
de même devant une ligne qui doit rester fixe (le cas échéant).

=SOMME(INDIRECT($C19&"!J7:J9");INDIRECT($C19&"!AG7:AG9"))

Si ton problème est réglé, merci d'aller en haut de page
pour cliquer sur « Marquer comme résolu ».

Cordialement.  😊
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !