Signaler

Restriction de modification d'un document Word [Résolu]

Posez votre question Marlmig 33Messages postés samedi 29 août 2015Date d'inscription 6 décembre 2016 Dernière intervention - Dernière réponse le 10 oct. 2016 à 09:46
Bonjour,
J'ai crée un formulaire d'inscription sous Word que je souhaite protéger afin de ne pas modifier les intitulés. J'ai toutefois une zone de texte en vertical que je souhaite laisser libre d'accès.
Or la protection, permet le remplissage du formulaire mais ne me laisse pas ma zone de texte.
Auriez-vous une solution à me proposer ?

Merci :)
Afficher la suite 
Utile
+2
moins plus
Bonjour Marlmig

Plutôt que de tout refaire, tu aurais pu simplement insérer une cellule de tableau à la place de la zone de texte et y mettre un champ de formulaire... et le tour était joué !

Maintenant que tu as tout refait, je te conseille quand même d'utiliser une cellule de tableau à la place de la zone de texte. Ainsi tu pourras y mettre un contrôle de contenu comme pour le reste. Et pour protéger, tu pourras utiliser la protection habituelle avec un mot de passe.

L'intérêt d'une cellule de tableau est que le comportement sera le même que pour le texte, alors que la zone de texte refuse les champs et autres contrôles...

m@rina
Ajouter un commentaire
Utile
+1
moins plus
Les filles je n'y arrive pas...
Il doit y avoir quelque chose que je ne fais pas correctement.

Je vais reprendre vos explications une par une mais si ça vous soûle je comprendrais.
J'ai remplacé toutes les anciennes zones de contenues héritées par celle du groupe "contrôles" de l'onglet développeur.
Ensuite j'ai coupé coller mes deux zones de textes sur un document vierge.
J'ai groupé tout mon document puis coller mes zones de texte.
Si j'ai bien compris, je ne devrais pas avoir besoin de protéger le document, il devrait être inaccessible comme tel (sauf mes zones de texte) du fait de l'avoir groupé. C'est bien ça ?
Bon et bien ce n'est pas le cas. Je peux toujours le modifier grrrrrr !
En ce qui concerne l’intégration d'une cellule de tableau sur le côté, ça me décale toute ma mise en page.
m@rina 13111Messages postés mardi 12 juin 2007Date d'inscription ContributeurStatut 9 décembre 2016 Dernière intervention - 4 oct. 2016 à 18:06
Bonjour Marlmig

Je t'ai indiqué une méthode plus simple que l'utlisation de la zone de texte.
Je t'ai refait rapidement le document. J'ai pas remis les contrôles partout, c'est juste pour que tu vois comment ça fonctionne.

J'ai donc mis en bas, à la place de ta zone de texte pas pratique, une cellule de tableau dans lequel il y a un contrôle de contenu.
J'ai protégé le formulaire comme tu le fais habituellement sauf que je n'ai pas mis de mot de passe.

Fichier ici :
http://www.cjoint.com/c/FJeqdEXumSl

m@rina
Répondre
Marlmig 33Messages postés samedi 29 août 2015Date d'inscription 6 décembre 2016 Dernière intervention - 10 oct. 2016 à 09:46
Merci Marina !!!!
Répondre
Ajouter un commentaire
Utile
+0
moins plus
Bonjour Marlmig,

Dans un formulaire protégé "à l'ancienne", seul le contenu d'une section peut être laissé libre. Or, j'imagine que ta zone de texte verticale n'occupe pas une section.

Toutefois, depuis Word 2007, si tu utilises les contrôles de contenu et non les anciens contrôles (contrôles hérités) dans l'onglet [Développeur], tu peux protéger tout le document sauf ta zone de texte et bien sûr les contrôles de contenu, en utilisant la commande "Grouper" | "Groupe" dans le même onglet [Développeur].
Pour cela, tu sélectionnes tout sauf la zone de texte qui doit être ancrée dans un paragraphe que tu n'engloberas pas dans ta sélection (le dernier par exemple), et tu "groupes".

Dans ce cas, tu n'utilises plus la commande "Protéger le document" ("Restrictions de modifications").
Marlmig 33Messages postés samedi 29 août 2015Date d'inscription 6 décembre 2016 Dernière intervention - 29 sept. 2016 à 17:34
Bonjour Claire, merci pour ta réponse très rapide.
Je crois comprendre ce que tu m'explique en revanche je n'ai pas accès à l'option "grouper' dans le développeur. Il est grisé. Je te joints mon document, peut-être desselleras-tu un problème dans ma mise en forme (si tu as le temps bien-sur)
Merci pour ton aide.

http://www.cjoint.com/c/FIDpHKLs8Ao
Répondre
C-Claire 4044Messages postés samedi 8 novembre 2014Date d'inscription 3 octobre 2016 Dernière intervention - 29 sept. 2016 à 18:29
Marlmig,

pas le temps tout de suite de regarder ton document.
Je vois simplement qu'il s'agit d'un .doc. Tu es en mode compatibilité "97-2003".
C'est pour cela que tu n'as pas accès aux nouvelles fonctionnalités. Il faut que tu l'enregistres au format . docx.
Si cela peut te faire avancer avant que je revienne plus tard ce soir ou demain matin ou que quelqu'un d'autre intervienne entre temps.

C-Claire
Répondre
C-Claire 4044Messages postés samedi 8 novembre 2014Date d'inscription 3 octobre 2016 Dernière intervention Marlmig - 29 sept. 2016 à 19:41
Marlmig,,

j'ai regardé ton formulaire. Je te confirme que pour obtenir ce que tu demandes, il faut l'enregistrer au format .docx.
Ensuite, il faut supprimer tous les champs que tu as créés (champs Texte et Cases à cocher) et les remplacer par les nouveaux contrôles de contenu de l'onglet [Développeur]. C'est rapide.
Pour ta zone de texte verticale, tu la sélectionnes, tu la coupes, tu cliques tout en bas de ton document et tu colles.
Tu sélectionnes ensuite tout le document sauf le dernier paragraphe et tu groupes.
Bref, revoir mon message précédent ;-)


C-Claire
Répondre
Marlmig 33Messages postés samedi 29 août 2015Date d'inscription 6 décembre 2016 Dernière intervention - 3 oct. 2016 à 15:17
Merci Claire pour toutes ces explications. J'ai bien groupé l'ensemble de mes zones et ajouter ensuite mes zones de texte. J'en suis à l'étape de protéger le document et je n'ai pas compris ce qu'il faut faire...
"Dans ce cas, tu n'utilises plus la commande "Protéger le document" ("Restrictions de modifications")" Que dois-je utiliser ?
Merci beaucoup,
Le Boulet !
Répondre
C-Claire 4044Messages postés samedi 8 novembre 2014Date d'inscription 3 octobre 2016 Dernière intervention - 3 oct. 2016 à 15:25
Marlmig,

"Que dois-je utiliser ?"
Plus rien ;-) Si tu as respecté la procédure, les utilisateurs ne peuvent pas modifier le document sauf les zones qui n'appartiennent pas au "groupe".
Cette technique répond à ton problème de laisser la zone de texte libre et le reste protégé. Toutefois, elle ne prévoit pas l'affectation d'un mot de passe.

Pour déprotéger, il faut sélectionner le texte groupé et choisir "Dissocier" dans la commande "Grouper" de l'onglet [Développeur].

C-Claire
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !