Impossible de verrouiller /var/lib/dpkg/lock [Résolu/Fermé]

larson57000 - 27 nov. 2009 à 13:42 - Dernière réponse : supermega boss 417 Messages postés samedi 21 juillet 2012Date d'inscription 2 août 2013 Dernière intervention
- 18 août 2012 à 22:55
Bonjour,
sa veut dire quoi ?
Impossible de verrouiller /var/lib/dpkg/lock - open (11 Ressource temporairement non disponible)
il me le dit pour certain paquets que j'installe via le terminal

pour compiz apres la manipe "$ apt-cache search compiz" vla ce qui me donne tout a l'aire d'y etre

compiz-bcop - Compiz option code generator
compizconfig-backend-gconf - Settings library for plugins - OpenCompositing Project
desktop-effects-kde - compiz setup tool for KDE
libcompizconfig0 - Settings library for plugins - OpenCompositing Project
libcompizconfig0-dev - Development file for plugin settings - OpenCompositing Project
compiz-fusion-plugins-extra - Collection de greffons supplémentaires issus d'OpenCompositing pour Compiz
cairo-clock - An analog clock drawn with vector-graphics
compiz-fusion-bcop - Compiz Fusion option code generator
compizconfig-backend-kconfig - KConfig Settings library for plugins - OpenCompositing Project
compizconfig-settings-manager - Compiz configuration settings manager
emerald - Decorator for compiz-fusion
fusion-icon - tray icon to launch and manage Compiz Fusion
kicker-compiz - modified pager applet for Kicker made to work with Compiz
libcm-dev - Support code for compositing managers - development files
libcm7 - Support code for compositing managers
libemeraldengine0 - Decoration engines for compiz-fusion
pdfcube - PDF document viewer with 3D effects
python-compizconfig - Compiz configuration system bindings
screenlets - Widget-like mini-applications for GNOME
simdock - A fast and customizable dockbar
simple-ccsm - Simple Compizconfig settings manager
compiz-fusion-plugins-main - Collection of plugins from OpenCompositing for Compiz
compiz-kde - OpenGL window and compositing manager - KDE window decorator
kicker-taskbar-compiz - modified Kicker taskbar applet made to work with compiz
compiz - OpenGL window and compositing manager
compiz-core - OpenGL window and compositing manager
compiz-dev - OpenGL window and compositing manager - development files
compiz-gnome - OpenGL window and compositing manager - GNOME window decorator
compiz-plugins - OpenGL window and compositing manager - plugins
libdecoration0 - Compiz window decoration library
libdecoration0-dev - Compiz window decoration library - development files
Afficher la suite 

4 réponses

mamiemando 28092 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 13 décembre 2017 Dernière intervention - 27 nov. 2009 à 14:03
+27
Utile
1
Tout d'abord, merci de faire un sérieux effort sur l'orthographe.

Ca veut dire quoi ?
Impossible de verrouiller /var/lib/dpkg/lock - open


Cela signifie qu'un autre gestionnaire de paquets (synaptic, aptitude, apt-get...) est lancé ou a été quitté salement. Si tu es sûr aucun gestionnaire de paquet n'est lancé, il suffit de supprimer ce fichier :

sudo rm /var/lib/dpkg/lock


Je précise que ce problème est évoqué de manière ultra fréquent sur les forums et je t'invite quand tu as un message d'erreur à faire un minimum de recherches au préalable.

Pour compiz après la manip "$ apt-cache search compiz" voilà ce qui me donne, tout a l'air d'y être

Si tu prends le temps de lire :
http://doc.ubuntu-fr.org/apt-cacher-server

... ou encore :

man apt-cache


... tu verras qu'apt-cache ne fait que chercher les paquets potentiellement installables. Il ne tient pas compte de ce qui est installé ou non sur ton PC. Il sert uniquement à rechercher le nom d'un paquet. Par exemple si tu veux installer compiz sous gnome, on voit assez rapidement qu'il faut installer le paquet "compiz-gnome" par exemple via synaptic.
http://doc.ubuntu-fr.org/synaptic

Bonne chance
Cette réponse vous a-t-elle aidé ?  
supermega boss 417 Messages postés samedi 21 juillet 2012Date d'inscription 2 août 2013 Dernière intervention - 18 août 2012 à 22:55
merci ça ma beaucoup aidé sauf... que je ne suis pas sous Ubuntu 9.10, je suis sous Ubuntu 12.04 LTS
larson57000 - 28 nov. 2009 à 13:02
0
Utile
ok tu a raison je devrais plus chercher et je l'ai fais mais tous n'ai pas tres cler parfois mais surtout merci de ton aide linuzien (et aussi comment ou on vas pour le "resolu" le dire je ne trouve pas)
mamiemando 28092 Messages postés jeudi 12 mai 2005Date d'inscriptionModérateurStatut 13 décembre 2017 Dernière intervention - 29 nov. 2009 à 01:22
0
Utile
Vu que tu n'es pas enregistré sur le site, tu ne peux pas mettre le sujet en résolu, mais je m'en occupe.

Bonne continuation