[CUPS] Impossible de s'authentifier en root [Fermé]

Signaler
-
 salebete -
Bonjour,

Depuis quelques jours, j'essaye d'installer un serveur CUPS sur une machine distante virtuelle linux "Redhat". Je suis connecté sur cette machine en root soit par putty soit par VMware me permettant de récupérer une interface graphique.

Je n'ai eu aucun problème particulier lors de l'installation mais j'en rencontre un lors de sa configuration. En effet pour paramétrer cups, je dispose d'une interface disponible en local depuis cette adresse : http://localhost:631/admin.

Le problème est qu'il me demande alors un username/password mais que même le mot de passe root ne fonctionne pas. Cela fait plusieurs jours que je tourne en rond en ajoutant "root" dans les goups lp & lpadmin (/etc/groups), que je déclare un utilisateur particulier dans les groupes, que j'essaye des versions antérieurs de CUPS, que je configure le fichier cupsd.conf ... en vain.

Message d'erreur après quelques tentatives :

401 Unauthorized
Entrez votre nom d'utilisateur et votre mot de passe ou bien identifiez-vous en tant que "root" pour accéder à cette page. Si vous utilisez l'authentification Kerberos, assurez-vous de disposer d'un ticket Kerberos valide.

Je commence à croire que le problème pourrait venir d'un autre endroit que CUPS lui-même ... plus général peut-être. Je ne suis pas vraiment un linuxien alors si quelqu'un pourrait m'éclairer sur ce problème, ce serait sympa ;-)

Merci d'avance.

10 réponses

Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
102
alors c'est quand meme dingue cette histoire !

essaie voir de creer un utilisateur cupsys dans shadow

adduser cupsys shadow

ça devrait marcher ya pas de raison !
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 83389 internautes nous ont dit merci ce mois-ci

Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
102
ben d'autres pistes heu... si j'étais devant la machine en cherchant peut être mais là, je ne vois pas trop...

je sais qu'il ya un bug tout bete ou en fait il y a l'interface web qui avait été desactivée par defaut, puis reactivée mais sans activer l'authentification, et dans ce cas on ajoute cupsys et les autres user à shadow et ça passe.

j'ai essayé de biaiser en te faisant commenter la ligne correspondant à l'authentification mais bon ça ne marche pas.

donc plan B mais sans conviction, essaie de commenter ça:

# Restrict access to the admin pages...
<Location /admin>

#Order allow,deny
</Location>

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 83389 internautes nous ont dit merci ce mois-ci

Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
102
Salut,

tu n'utilises pas CUPS via SAMBA par hasard?
Salut,

Non, je n'utilise pas Samba.

J'ai avancé un peu sur le fichier de config cupsd.conf où j'ai ajouté sur l'une des premières lignes :
# Administrator user group...
SystemGroup sys root,lp,lpadmin

En root, cette méthode ne fonctionne toujours pas mais en revanche avec un user quelconque j'arrive sur une autre erreur dans cups dont voici le log error :
I [07/Oct/2008:14:08:39 +0200] cupsdAuthorize: Username "root" has no shadow password!
I [07/Oct/2008:14:08:55 +0200]Installing config file "/etc/cups/cupsd.conf"...
I [07/Oct/2008:14:08:56 +0200]Unable to open config file "/etc/cups/cupsd.conf.N" - Permission denied

En root, il semble que je ne suis pas dans le "Shadow" ???
En user classique, il semble que je n'ai pas tous les droits ???

Merci pour ton aide.
Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
102
l'utilisateur cupsys est-il dans le groupe shadow?

tu peux poster ton cupsd.conf?
Je n'ai pas de cupsys ni dans le groupe shadow ni ailleurs. Il me semble que ce service n'est actif que sur certaines librairies, moi je dispose que du service cups (que je peux gérer en faisant un "service cups restart" par exemple).

Le cupsd.conf est quasiment celui d'origine pour le moment :
#
# "$Id: cupsd.conf.in 7199 2008-01-08 00:16:30Z mike $"
#
# Sample configuration file for the Common UNIX Printing System (CUPS)
# scheduler. See "man cupsd.conf" for a complete description of this
# file.
#

# Log general information in error_log - change "info" to "debug" for
# troubleshooting...
LogLevel info

# Administrator user group...
SystemGroup sys root,lp,lpadmin


# Only listen for connections from the local machine.
Listen localhost:631
Listen /var/run/cups/cups.sock

# Show shared printers on the local network.
Browsing On
BrowseOrder allow,deny
BrowseAllow all

# Default authentication type, when authentication is required...
DefaultAuthType Basic

# Restrict access to the server...
<Location />
Order allow,deny
</Location>

# Restrict access to the admin pages...
<Location /admin>

Order allow,deny
</Location>

# Restrict access to configuration files...
<Location /admin/conf>
AuthType Default
Require user @SYSTEM
Order allow,deny
</Location>

# Set the default printer/job policies...
<Policy default>
# Job-related operations must be done by the owner or an administrator...
<Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job CUPS-Move-Job>
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>

# All administration operations require an administrator to authenticate...
<Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
AuthType Default
Require user @SYSTEM
Order deny,allow
</Limit>

# All printer operations require a printer operator to authenticate...
<Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After CUPS-Accept-Jobs CUPS-Reject-Jobs>
AuthType Default
Require user @SYSTEM
Order deny,allow
</Limit>

# Only the owner or an administrator can cancel or authenticate a job...
<Limit Cancel-Job CUPS-Authenticate-Job>
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>

<Limit All>
Order deny,allow
</Limit>
</Policy>

#
# End of "$Id: cupsd.conf.in 7199 2008-01-08 00:16:30Z mike $".
#

~~~~~~~~~~~~~~~~

Dès que je déclare un nouveau compte sur la machine et que j'essaye de me connecter à CUPS avec celui-ci, j'ai le même message à chaque fois au niveau du log-error de Cups : "I [XXX] cupsdAuthorize: Username "xxx" has no shadow password!

Pourtant si je fais un vi de /etc/shadow, je vois bien ce compte avec un code chiffré.
Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
102
Donc tu confirmes que tes users sont dans le groupe shadow, ok.

essaie de commenter cette ligne:

# Default authentication type, when authentication is required...
# DefaultAuthType Basic

Relance CUPS et dis nous ce que ça donne

Désolé, ça ne marche pas pour autant.

Ma démarche :
- Mise en commentaire de la ligne
- Redémarrage du service cups
- Test négatif, toujours la même erreur dans le log-error : no shadow password

Allez, on continue, merci beaucoup gregool.
Bonjour,

Effectivement, ça devient dingue cette histoire.

J'ai testé en ajoutant l'utilisateur cupsys dans le shadow mais c'est la même chose.

Je ne vois vraiment pas comment résoudre le problème ... toujours ce même message dans les logs : Username "root" ha no shadow password!

J'ai testé une version antérieur de CUPS ... même chose évidemment.

D'autres pistes ? Merci.
Je viens d'essayer en commantant la ligne indiquée mais c'est toujours la même chose.

Par contre, j'ai tout repris de zéro. C'est à dire que j'ai désinstaller proprement & réinstaller cups d'origine ... sans toutes mes modifications de groupes ...

Bizarrement, il me demande plus de mot de passe quand je tente d'accéder à la partie administration mais j'ai un beau message d'erreur qui est maintenant :
Erreur 413 : Request entity too large

Avec cette fois-ci dans le fichier error-log :
E [08/Oct/2008:14:00:43 +0200] Unable to create request file /var/spool/cups/00000007: Permission denied
E [08/Oct/2008:14:00:43 +0200] cupsdReadClient: Unable to write 78 bytes to /var/spool/cups/00000007: Bad file descriptor

J'ai l'impression d'avoir un peu avancé mais au final c'est quasiment le même problème d'accès. Je suis toujours connecté en "root" et les dossiers Var & Spool sont gérés par le root. En revanche, les dossiers cups & tmp (dans cups) ont l'air d'être gérés par le group "lp".

Il faut peut-être creuser dans ce sens-là ?

PS : Si j'ajoute la ligne AuthType Basic dans le fichier de conf au niveau de la location admin ... il demande alors un mot de passe pour rentrer dans la partie administration & comme d'habitude cela ne fonctionne pas.
Messages postés
667
Date d'inscription
jeudi 25 janvier 2007
Statut
Membre
Dernière intervention
8 janvier 2010
102
et tu essaies avec un user du groupe lp tu as aussi ce pb?
Bonjour,
je réponds un peu tard mais je viens d'être confronté au même problème.

fedora 17 et imprimante hp-laserjet- p1102w

Je suis allé dans le menu de fedora, adminsitration, utilisateurs et groupes (il faut donner le mot de passe de root) et j'ai cliqué sur mon nom. Dans mon profil, j'ai coché dans les groupes le sys et fermer le tout.

Tout s'est alors bien passé et j'ai pu installé mon imprimante avec hptool

Alors, si ça peut encore servir