Menu

PHP ne peut charger l'extension mysql [Résolu/Fermé]

Messages postés
301
Date d'inscription
jeudi 19 juin 2008
Statut
Membre
Dernière intervention
13 février 2018
- - Dernière réponse :  Endoril - 3 févr. 2010 à 13:47
Bonjour,
C'est un problème a priori commum à beaucoup de monde mais aucune des solutions trouvées ne marche dans mon cas.

Ma config :

XP Pro
Apache : 2.0.63
PHP : 5.2.6
PhpMyAdmin : 2.11.7
MYSQL : 5.0.45

J'ai essayé de modifier le path et PHPRC et aussi le extension_dir

J'ai même mis la librairie dans le répertoire bin d'apache.

Rien ne fonctionne

Auriez-vous une idée SVP. Merci.
Afficher la suite 

2 réponses

Messages postés
301
Date d'inscription
jeudi 19 juin 2008
Statut
Membre
Dernière intervention
13 février 2018
5
0
Merci
Ca y est cela marche.

J'ai tout desinstallé puis j'ai installé la version 2.0c de Wampserver. Seul problème c'est qu'il ne lance pas MYSQL. J'ai donc du le customizer, installé la version 5.0.45 de MYSQL et de le laisser en démarrage automatique.

@ +
Bonjour à tous,

Je suis en stage dans une entreprise et je dois mettre en place GLPI. Je dois obligatoirement utiliser IIS car la boite utilise MS le plus possible, je n'ai donc pas le droit de mettre en place un serveur Apache (je dis ça pour éviter qu'on vienne me dire que IIS c'est pourri et qu'il faut mettre Apache)

J'utilise IIS version 6, php version 5.2.8, MySQL version 5.1.30 et GLPI version 0.71.5.

J'ai moi aussi ce fameux message d'erreur lors de l'installation de GLPI : "Vous devez compiler votre php avec l'extension Mysql."

J'ai bien copier le fichier "libmysql.dll" dans "C:\WINDOWS\system32".
J'ai bien copier le fichier "php.ini" dans "C:\WINDOWS" et décommenter les lignes ";extension=php_mysql.dll" et ";extension=php_mysqli.dll"
J'ai bien entrer le chemin des extensions "C:\PHP\ext" dans php.ini
J'ai bien copier les fichiers "php5isapi.dll" et "php5ts.dll" dans "C:\WINDOWS\system32\inetsrv".
J'ai essayé d'ajouter le filtre mais ça ne change rien.

Je ne sais pas quoi faire d'autre donc si quelqu'un a une idée, je suis preneur.
Merci.
> Otimov -
Bonjour,

J'ai eu un problème similaire.
Il fait copier libmysql.dll dans le répertoire Windows et non system32.

Ca c'est pour Mysql...

Concernant GLPI : dans PHP.ini tu dois également mettre => max_execution_time = 3000 (au lieu de 30)

redémarre IIS => démarrer/exécuter/cmd/ => iisreset

En espérant que cela résoudra ton problème, merci de me dire ce que ca donne ;)
0
Merci
Re,

Désolé libmysql.dll va bien dans System32 ;)

essaie juste max_execution_time = 3000 ^^