Bannière Flash et lien externe [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
mercredi 11 juin 2008
Statut
Membre
Dernière intervention
12 juin 2008
-
cammarow
Messages postés
3
Date d'inscription
mercredi 11 juin 2008
Statut
Membre
Dernière intervention
12 juin 2008
-
Bonjour,

J'ai conçu une bannière publicitaire pour un jeu concours.
Toute la bannière est recouverte par un bouton invisible (inséré dans l'animation elle-même) qui renvoie vers la page explicative du site organisateur.
Mon problème est que l'URL que je rentre dans la fonction "getURL()" n'est pas reprise telle qu'elle par Flash. Elle semble s'arrêter au premier slash.

Voici mon code:

on (release) {
    getURL ("http://www.monsite.fr/index.php?page=JeuConcours", "_parent");
}  


L'adresse qui est retenue une fois l'animation compressée et publiée est celle-ci :
"http://www.monsite.fr/"


Je ne comprend pas pourquoi la deuxième partie de l'URL n'est pas prise en compte!

Une explication?

Merci d'avance!

1 réponse

Messages postés
353
Date d'inscription
dimanche 20 mai 2007
Statut
Contributeur
Dernière intervention
6 juillet 2010
40
Petite rectification ... c'est le point d'interrogation qui n'est pas pris en compte ;-) ... pourquoi? je sais pas te le dire .... mais si non rewritte ton site ... ou plus simple tu envoie le visiteur sur une page "d'attente" genre http://www.monsite.fr/index2.php et tu insert une redirection automatique vers la dite page ...

bien à toi
seb
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 86817 internautes nous ont dit merci ce mois-ci

cammarow
Messages postés
3
Date d'inscription
mercredi 11 juin 2008
Statut
Membre
Dernière intervention
12 juin 2008

D'accord !!! je n'avais pas pensé au "?". Merci beaucoup pour ton aide Seb!

Bonne soirée
cammarow
Messages postés
3
Date d'inscription
mercredi 11 juin 2008
Statut
Membre
Dernière intervention
12 juin 2008

J'apporte moi-même une rectification :

J'ai testé une autre solution qui consiste simplement à stocker le lien dans une variable dans un premier temps (avec le point d'interrogation), puis à appeler cette variable dans le getURL().

Cette solution FONCTIONNE ! Allez savoir pourquoi...

Je suis content d'avoir participé sur ce forum, je résous mes problèmes tout seul !