Attribuer une valeure numérique à un mot ...et que ce mot reste affiché [Résolu]

Signaler
Messages postés
22
Date d'inscription
dimanche 16 juin 2019
Statut
Membre
Dernière intervention
26 décembre 2019
-
eriiic
Messages postés
23238
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 janvier 2020
-
Bonjour,

J'utilise un fichier excel pour guise de planning professionnel annuel.
Pourriez-vous me dire s'il existe un moyen (pas trop compliqué ...je ne suis pas blonde mais j'en ai parfois le potentiel :)) d'attribuer une valeur numérique à un mot (et que ce mot reste affiché) ?

Pour être plus précise, je souhaiterais que, lorsque je tape CA (pour congé annuel) le CA reste affiché dans la cellule, mais que la valeur numérique de cette cellule soit 7 ...

J'espère avoir été assez claire dans ma demande :)

En espérant que vous pourrez me venir en aide :)

Merci par avance :)

6 réponses

Messages postés
6492
Date d'inscription
jeudi 13 septembre 2007
Statut
Contributeur
Dernière intervention
28 janvier 2020
440
Messages postés
22
Date d'inscription
dimanche 16 juin 2019
Statut
Membre
Dernière intervention
26 décembre 2019

Bonjour,

Merci Cs le pivert :)



C'est très gentil d'avoir pris du temps pour m'aider, malheureusement cela n'est pas vraiment ce que je souhaiterais ... En effet ajouter un commentaire à une cellule fait qu'on voit le commentaire lorsqu'on place la souris sur la cellule en question ... Or, en ce qui me concerne, je souhaiterais visualiser d'un seul coup toutes les cellules qui comportent le mot CA (je leur attribuerais une mise en forme conditionnelle pour bien distinguer tous les CA que j'aurais posés au cours de l'année) mais en même temps je souhaiterais que la valeur numérique de cette cellule soit 7 afin de compter ces CA dans ma balance horaire ....

J'espère ne pas être trop obscure dans mes souhaits :)
cs_Le Pivert
Messages postés
6492
Date d'inscription
jeudi 13 septembre 2007
Statut
Contributeur
Dernière intervention
28 janvier 2020
440
Une solution en vba:

Faire Alt F11 pour accéder à l'éditeur
Aller dans le module en sélectionnant la feuille concernée en haut à gauche
Coller cette macro qui se déclenchera au double clic sur la cellule contenant un CA dans la colonne A (a adapter)

Option Explicit
Private Sub Worksheet_BeforeDoubleClick(ByVal Target As Range, Cancel As Boolean)
If Not Application.Intersect(Target, Range("A:A")) Is Nothing Then ' a adapter la colonne
If Target.Value = "CA" Then
Target.Value = "7"
Else
Target.Value = "CA"
End If
End If
End Sub


Voilà

@+ Le Pivert
Celinette21300
Messages postés
22
Date d'inscription
dimanche 16 juin 2019
Statut
Membre
Dernière intervention
26 décembre 2019

Merci beaucoup le pivert !!! :)
Je viens seulement de prendre connaissance de ta réponse...entre temps un ami qui me veut du bien m'avait renseigné ....
En tout cas merci pour ton aide !
Bonjour,
Votre problème est trop difficile pour moi !
Je profite seulement de votre passage pour vous demander si vous avez pu utiliser Freelang ?
Cordialement.
Celinette21300
Messages postés
22
Date d'inscription
dimanche 16 juin 2019
Statut
Membre
Dernière intervention
26 décembre 2019

Bonjour Eugene,

oui je l'utilise .. je vous remercie à nouveau :)
Re-bonjour,
Je verrais bien une solution consistant à créer deux cellules contiguës dans un même cadre, A1 et B1 par exemple, A1 ayant une mise en forme conditionnelle en fonction de la présence de la mention CA, B1 contenant une formule =si(a1="CA";7;"") et faisant l'objet d'une mise en forme analogue à celle de A1, la condition étant la présence du chiffre 7. Çà marche, mais cela ne correspond peut- être pas à ce que vous recherchez, et pourrait bien m'attirer les quolibets des puristes de ce forum...
Mais la solution proposée par cs_le Pivert est très certainement LA solution adéquate...
Messages postés
50827
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
29 janvier 2020
11 897
... sinon dans toute formule utilisant la valeur de CA on ajoute cette correspondance !
Ainsi, avec le texte "CA" dans la cellule B9, et la valeur 7 à attribuer à CA, la formule
=B9/12*7,5%
devra s'écrire
=SI(B9="CA";7;0) /12*7,5%
Messages postés
16053
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 janvier 2020
2 860
Bonjour à tous

je me demande le but du truc et à quoi correspond 7

a tout hasard: on compte le nombre de CA et on multiplie par 7 ???

si oui, les CA se trouve dans une colonne ou disséminer dans plusieurs colonnes ?
eriiic
Messages postés
23238
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 janvier 2020
5 883
Bonjour à tous,
Salut Michel,

J'allais le dire :
=NB.SI(B2:B9;"CA")*7

eric