Excel supprimer chiffres

Signaler
-
via55
Messages postés
11475
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 décembre 2019
-
Bonjour,

Je cherche une formule pour supprimer tous les chiffres d'une cellule Excel
Exemple
Maison1393939
Supprimer les chiffres et garder le texte sachant que c'est différent dans la compo

6 réponses

Messages postés
11475
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 décembre 2019
1553
Essaie cette formule avec la 1ere valeur en B2
=SIERREUR(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(GAUCHE(B2;TROUVE("-";B2)-1);"0";"");"1";"");"2";"");"3";"");"4";"");"5";"");"6";"");"7";"");"8";"");"9";"");B2)

S'il existe encore des cas non prévus il faut fournir ton fichier comme demandé
Messages postés
11475
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 décembre 2019
1553
Bonjour

Que veux tu dire c'est différent dans la compo ?
Donnes plusieurs exemples ou mieux fournis ton fichier en le postant sur mon-partage.fr, en copiant le lien créé et en revenant le coller ici

As-tu regardé les réponses ici :
https://www.commentcamarche.net/forum/affich-30096721-suppression-de-chiffres-dans-un-texte

Cdlmnt
Via

Merci pour ton retour
Il s'agit d'une liste : indice qualification et tranche année dans une même cellule
Exemple
EMPLA1-2ANS
TECHNB10-12ans
AGTMHQA
La compo différe dans le sens où il n'y a pas tjr le même nombre de lettre et qu' il n'y a pas de séparateur après le A ou B
Messages postés
11475
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 décembre 2019
1553
Ce n'est déjà pas que les chiffres à supprimer mais les - et les ans

Y a-t-il toujours un tiret ?
Y a-t-il des cellules sans chiffres comme le suggère ton 3eme exemple AGTMHQA ?

Oui exactement
C'est pour ça que c'est compliqué, car ce n'est jamais identique