Calcul chiffre d'affaire

- - Dernière réponse : Vaucluse
Messages postés
24308
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 août 2019
- 6 août 2019 à 07:47
Bonjour,

Je voudrais faire un calcul de mon chiffre d'affaire en comparatif n-1.
Exemple pour calcul fin juillet, je voudrais que mon total reprenne les 7 premiers mois de l'année n et les 7 premiers mois de l'année n-1 (sans avoir à supprimer les derniers mois de l'année n-1).
Je voudrais si cela est possible taper 7 dans une case et mon calcul se ferait sur les 7 premiers mois de mes 2 années.
J'espère que j'ai été assez clair et je vous remercie pour vos réponses

Cordialement

Thierry
Afficher la suite 

4 réponses

Messages postés
2448
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
22 août 2019
269
0
Merci
Bonjour à tous,

Utilise la fonction décaler()
Ça ne te parait pas clair ?
C'est la seule qui me vient a l'esprit, n'ayant pas connaissance de ton fichier.

Crdlmt
Commenter la réponse de DjiDji59430
0
Merci
Bonjour,
Je vous envoie en première approche ce petit modèle qui était dans un coin de mon ordinateur, voyez si cela peut vous être utile.
Il fonctionne en renseignant les cellules Q5 et R5
On saisit les CA dans les cellules C4 à N5, en bleu.
https://cjoint.com/c/IHfrjrsuPDG
Le même en cumulé :
https://cjoint.com/c/IHfsj64omYG
Commenter la réponse de Oscar
0
Merci
Rectificatif du tableau en cumulé :
https://cjoint.com/c/IHgeKqtlP6G
Commenter la réponse de Oscar
Messages postés
24308
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 août 2019
4727
0
Merci
Bonjour
les dates 2018 en feuil1 colonne A, les montants en B
les dates 2019 en feuil2 en A les montants en B
pour des champs de ligne 2 à 500
pour avoir les résultat en feuille 3
en A1 entrer le N° du mois
en B1 pour 2018: =SOMMEPROD(MOIS(Feuil1!$A$2:A500)<=A1)*(Feuil1!$B$2:$B$500))
en C1 pour 2019: =SOMMEPROD(MOIS(Feuil2!$A$2:$A$500)<=A1)*(Feuil2!$B$2:$B$500))


ou alors si vos données sont en continu dans la même plage pour les deux ans (ou plus):
de ligne 2 à ligne 1000
date en A montants en B
en C2 le N° du mois
en D1 année 2018
en E1 année 2019
en D2
=SOMMEPROD((ANNEE($A$2:$A$1000)=D1)*(MOIS($A$2:$A$1000)=$C2)*($B$2:$B$1000))
formule à tirer en E2 (attention aux signes $)
crdlmnt
Commenter la réponse de Vaucluse