Menu

Problème avec une fonction Si [Résolu]

Messages postés
3
Date d'inscription
jeudi 16 mai 2019
Statut
Membre
Dernière intervention
16 mai 2019
-
Bonjour, je suis nouveau membre et j’espère avoir placé ma question au bon endroit, désolé si ce n'est pas le cas...

Je souhaites afficher dans une cellule un texte en fonction de certains critères.
Je veux que le texte qui s'affiche soit en rapport avec la valeur de 4 cellules qui chacune peuvent avoir une valeur différentes ou bien la même.

En fait je veux que la cellule avec la plus petite valeur affiche un texte, sur ma cellule contenant la fonction, qui lui est propre, et si elles ont toutes la même valeur rien ne s'affiche.
J'ai donc pensé utiliser la fonction si, voici la formule que j'ai tenté mais il apparaît #VALEUR!....
=SI((D7=C7=D16=C16);"";SI((D7<C7;D16;C16);"SCENARIO 3";SI((C7<D7;D16;C16);"SCENARIO 1";SI((D16<D7;C7;C16);"SCENARIO 4";SI((C16<D16;D7;C7);"SCENARIO 2";"")))))

Si vous avez une solution plus simple je suis preneur car je me suis peut être compliqué la vie...

Merci par avance, bonne journée à tous :)
Afficher la suite 

Votre réponse

1 réponse

Messages postés
1754
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
17 mai 2019
703
0
Merci
Bonjour,

Il est impossible dans Excel de faire D7=C7=D16=C16.

Vous passez par 4 valeurs différentes avec beaucoup de scénario possible. Il faut tout d'abord essayer de réfléchir sur les type de combinaison possible .

Je vois pas ce que vous voulez dire par ca par exemple : (C7<D7;D16;C16)

Une explication ou votre fichier ( en enlevant les données confidentiel ) via http://cjoint.com pourrait être utile

A Vaincre sans péril, on triomphe sans gloire.
Pierre Corneille, Le Cid 
Lord_Caldlow
Messages postés
3
Date d'inscription
jeudi 16 mai 2019
Statut
Membre
Dernière intervention
16 mai 2019
-
Bonjour,

Merci pour votre réponse rapide.
Par (C7<D7;D16;C16) je veux dire que si C7 est inférieur à ces 3 autres cellules, alors...
Désolé c'est vrai que c'était difficile de bien me faire comprendre, voici une image d'une feuille excel que j'ai créé en exemple pour vous aider à mieux comprendre.




Merci par avance.
diablo13800
Messages postés
1754
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
17 mai 2019
703 -
Vous n'avez que 5 Scénarii possibles? Dans ce cas il vous faut passer par des SI ( comme vous l'avez fait) et des ET ( ou Ou suivant les cas.)

Exemple pour votre premier scénario :
=Si(Et(C7=D7;C7=C16;C7=D16);"Scénario 1";Si(ET(C7<D7;C7<C16;C7<D16);"Scénario 4"; ....))

Je pense que vous voyez ça :)

Il faut bien distinguer chaque Scénario dans les ET.

Après pour les formules avec vos minimums vous pouvez utilisez ce type de formule:
=Si(Min(C7;D7;C16;D16)=C7;"C7 est le minimum";Si(Min(C7;D7;C16;D16)=D7;"La c'est D7"))

La fonction Min fait le travail de comparaison pour avoir la plus petite valeur et donc optimiser votre formule :)
Lord_Caldlow
Messages postés
3
Date d'inscription
jeudi 16 mai 2019
Statut
Membre
Dernière intervention
16 mai 2019
-
Génial! Merci beaucoup pour la réponse rapide!

Ma formule fonctionne nickel :)
=SI(ET(C7=D7;D7=D16;D16=C16);"";SI(MIN(C7;D7;D16;C16)=C7;"SCENARIO 1";SI(MIN(C7;D7;D16;C16)=C16;"SCENARIO 2";SI(MIN(C7;D7;D16;C16)=D7;"SCENARIO 3";SI(MIN(C7;D7;D16;C16)=D16;"SCENARIO 4";"")))))

Bonne journée à vous :)
diablo13800
Messages postés
1754
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
17 mai 2019
703 -
C'est parfait si ca fonctionne :)
N'hésitez pas à passer le sujet en résolu ca peut aider d'autre personnes dans des situations similaires
Commenter la réponse de diablo13800