Menu

Image avec zones cliquables ne fonctionne pas

Messages postés
99
Date d'inscription
mercredi 11 octobre 2006
Statut
Membre
Dernière intervention
15 avril 2019
- - Dernière réponse : jordane45
Messages postés
25320
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
26 avril 2019
- 15 avril 2019 à 09:43
Bonjour,
J'ai crée un bandeau HTML incorporant une image avec plusieurs zones cliquables, renvoyant à différents liens.
à l'édition, il n'y a aucunes zone cliquables alors qu'elles sont parfaitement dans le code html

Voici le lien sur ce bandeau
https://promosdusines.com/Bandeau1.html
et voici le code source ;
view-source:https://promosdusines.com/Bandeau1.html

Une fois que les zones cliquables fonctionneront, je souhaite que cette image et ses zones cliquables soient également responsives afin de s'adapter à tous le écrans.
Pour l'image seule je sais le faire en mettant les dimensions à 100% mais les zones cliquables ne suivent pas



Pouvez vous m'aider sur une ou ces deux questions


Configuration: Windows / Firefox 66.0
Afficher la suite 

Votre réponse

2 réponses

Messages postés
25320
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
26 avril 2019
1961
0
Merci
Bonjour,

à l'avenir, merci de poster le code source DIRECTEMENT sur le forum ( en utilisant les balises de code )
Explications disponibles ici: https://codes-sources.commentcamarche.net/faq/11288-les-balises-de-code

Ensuite, dans l'attribut usemap tu as oublié le #

Commenter la réponse de jordane45
Messages postés
99
Date d'inscription
mercredi 11 octobre 2006
Statut
Membre
Dernière intervention
15 avril 2019
0
Merci
Voici le code source de mon image avec zones cliquables qui ne fonctionnent pas :
<img src="img/cms/BandeauFr.jpg" alt="Promotions des usines directement dans votre caddie" width="855" height="150" usemap="Map" border="0" />
<map name="Map" id="Map">
<area shape="rect" coords="325,1,564,29" href="https://promosdusines.com/" alt="Site Français" title="Site Français"/>
<area shape="rect" coords="326,31,564,58" href="https://promosausfabriken.com/" alt="Site Allemagne" title="Site Allemagne"/>
<area shape="rect" coords="325,60,563,89" href="https://promozionidallefabbriche.com/" alt="Site Italie" title="Site Italie"/>
<area shape="rect" coords="326,91,564,120" href="https://promosdefabricas.com/" alt="Site Espagne" title="Site Espagne"/>
<area shape="rect" coords="326,122,564,148" href="https://promosfromfactories.com/" alt="Site Anglais" title="Site Anglais" />
<area shape="rect" coords="5,5,318,146" href="https://promosdusines.com" alt="Promos des usines directement dans votre caddie" title="Promos des usines directement dans votre caddie"/>
</map>

Merci par avance pour votre aide
jordane45
Messages postés
25320
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
26 avril 2019
1961 -
Et bien ???
Non seulement tu n'as pas appliqué la coloration syntaxique (l'utilisation des balises de code que je t'ai demandé d'appliquer et pour laquelle je t'ai donné un lien explicatif....)
mais en plus.. tu n'as pas lu ma réponse (la solution à ton souci... ) concernant le # manquant........
Fais un minimum d'effort... merci !
Commenter la réponse de traderpierre