Menu

Calcul de tranches horaires appartenant à des plages différentes...... NEW

Messages postés
11
Date d'inscription
samedi 2 février 2019
Dernière intervention
10 février 2019
-
Bonjour,
Je cherches une formule matricielle pour effectuer des calculs de durée indexés à des tranches horaires ... Et j'ai dû arréter les maths à l'époque de Pythagore (au programme bien sûr)... alors c'est plutôt du chinois pour moi, bien que j'aime les chinois!
J'ai vu une formule pondue par M. JvDo qui me semble complexe certe mais qui répondrait à mes besoins si tenté que les variables soit les bonnes et au bons endroits...
RAPPEL de mes CONSIGNES: exemple du 28 janvier 2019
1-Renseigner les temps des cellules en violet (saisie manuelle des données) - OK
2-Je cherche une formule matricielle pour avoir la durée exacte par tranche horaire travail/trajet indemnisé de façon identique - NOK
3-En déduire les coûts par tranche sur une intervention - OK
4-Attention à déduire les temps de pause déjeuner diner des sous totaux dans les formules NOK
5- est ce que les formats de cellule sont bien choisies? NOK
Afficher la suite 

Votre réponse

7 réponses

Messages postés
11
Date d'inscription
samedi 2 février 2019
Dernière intervention
10 février 2019
JvDo
Messages postés
1905
Date d'inscription
mercredi 27 juillet 2005
Dernière intervention
18 février 2019
934 -
Bonjour,

Ton fichier est considéré comme dangereux par Chrome....

Cordialement
Commenter la réponse de Minos72
Messages postés
436
Date d'inscription
lundi 2 juillet 2018
Dernière intervention
20 février 2019
40
0
Merci
BonjourJvDo,

Si tu as le souci de sécurité de ce fichier sur Chrome ,j'ai le même sur Firefox,mais il n'y a rien de dangereux dans ce fichier ,je l'ai ouvert ,je pense qu'il s'agit d'un problème sécurité avec Windows.
J'ai ouvert d'autres fichiers et c'est pareil,je cherche la solution pour cet inconvénient.
Crdlt
JvDo
Messages postés
1905
Date d'inscription
mercredi 27 juillet 2005
Dernière intervention
18 février 2019
934 -
Bonjour JCB40,

Je ne peux même pas le télécharger !(clic droit\enregistrer la cible sous)
En revanche, ça passe sur monpartage.

Cordialement
Commenter la réponse de JCB40
Messages postés
11
Date d'inscription
samedi 2 février 2019
Dernière intervention
10 février 2019
0
Merci
Salut les gars je tentes de remettre le fichier zippé cette fois!
https://www.cjoint.com/c/IBfvIoQTzwh
Commenter la réponse de Minos72
Messages postés
11
Date d'inscription
samedi 2 février 2019
Dernière intervention
10 février 2019
0
Merci
Let's me know if it's now ok!
Commenter la réponse de Minos72
Messages postés
11
Date d'inscription
samedi 2 février 2019
Dernière intervention
10 février 2019
0
Merci
Pour Rappel : les cellules en violet sont des cellules de saisies.
En M5, je veux calculer le nombre total d'heure travail trajet déduction faite des pauses repas;
En M6, je souhaite mes heures de travail-trajet en journée comprises entre N2 et N4
En P5 et Q5; qui sont deux plages non contigües avec un cout horaire identique; je les additionnes en R5 pour déduire mon cout globale de tranche intermédiaire en S5.
Pareil pour les heures de nuit.
En V5 et X5; j'affiche des temps de trajet (pour avoir l’info en visuel) mais c'est les kilomètre qui m'importe pour le calcul des indemnité Kilométrique;
Pour les repas : Z5 et AA5; j’émets l'hypothèse de mettre une condition temporelle à savoir si pause déjeuner supérieur à 10 Min, je considère qu'il y a repas et donc le forfait repas est dû par le client est donc présent en Z5 (Idem pour AA5).
Minos72
Messages postés
11
Date d'inscription
samedi 2 février 2019
Dernière intervention
10 février 2019
-
HA oui j’allais oublier si deux cellule de la colonne Code Client en B affiche deux fois de suite le code d'un même client alors l’hôtel et le petit déjeuner sont dus! en AB5 et AC5
Minos72
Messages postés
11
Date d'inscription
samedi 2 février 2019
Dernière intervention
10 février 2019
-
Merci d'avance de l’intérêt que vous porterez à cette demande d'aide!
Commenter la réponse de Minos72
Messages postés
1905
Date d'inscription
mercredi 27 juillet 2005
Dernière intervention
18 février 2019
934
0
Merci
J’ai réussi à ouvrir le fichier, avec des alertes de securite dans tous les sens.
Je ne vois pas de formule JvDo à adapter.
En revanche :
Tu devrais utiliser l’adressage semi absolu quand tu fais référence aux lignes 2 ou 4 (colonnes AC, AA, Z, U, S, Q, N:Q). Mettre N$2 au lieu de N2 par exemple.
Tu devrais utiliser AB$2 au lieu de 92 en colonne AB. Si tu veux pouvoir gérer une évolution des indemnités dans le temps, il faudra prévoir une table horodatée des montants et utiliser un RECHERCHEV() pour récupérer le bon montant en fonction de la date en colonne A:A.
C’est normal d’avoir hotel+petit dej alors qu’il y a un trajet retour?
Quand tu parles de « en M6, je souhaite...... » tu veux parler de N5 sans doute.
Tu as déjà des formules partout... elles ne te conviennent pas?
Pour le format des heures, si tu risques de dépasser les 24h en durée, il faut utiliser un format [h]:mm.

Cordialement
Minos72
Messages postés
11
Date d'inscription
samedi 2 février 2019
Dernière intervention
10 février 2019
-
Je ne vois pas de formule JvDo à adapter: En fait si mon heure de fin depasse 23:59 en L5 par exemple alors tous mes calculs deviennent faux!
En revanche :
Tu devrais utiliser l’adressage semi absolu quand tu fais référence aux lignes 2 ou 4 (colonnes AC, AA, Z, U, S, Q, N:Q). Mettre N$2 au lieu de N2 par exemple.Oui exact Merci !
Tu devrais utiliser AB$2 au lieu de 92 en colonne AB. Si tu veux pouvoir gérer une évolution des indemnités dans le temps, il faudra prévoir une table horodatée des montants et utiliser un RECHERCHEV() pour récupérer le bon montant en fonction de la date en colonne A:A. OK à je vais potasser cette formule!
C’est normal d’avoir hotel+petit dej alors qu’il y a un trajet retour? Non, l'ajout en B6 d'un code client identique à B5 est une action manuelle erronée de ma part, mais j'ai voulu intégrer une condition d'indemnisation de nuit d’hôtel sur un déplacement d'intervention sur une journée. Pour avoir un calcul automatisé en AB5 et AC5 via la colonne B
Quand tu parles de « en M6, je souhaite...... » tu veux parler de N5 sans doute.Exact 2ieme bourde! j'en connais un qui va payer l'apéro! désolé!
Tu as déjà des formules partout... elles ne te conviennent pas? Elle ne fonctionne pas toujours dans tous les cas que j'ai essayé
Pour le format des heures, si tu risques de dépasser les 24h en durée, il faut utiliser un format [h]:mm. Ok mais ca ne change rien à la fausseté de mes calculs dès lors que je dépasse minuit en L5 par exemple
JvDo
Messages postés
1905
Date d'inscription
mercredi 27 juillet 2005
Dernière intervention
18 février 2019
934 -
1) Peux-tu indiquer en lien la discussion où tu as trouvé une de mes formules qui te conviendrait.
Je n'ai pas envie de réinventer le fil à couper l'eau chaude.

J'ai l'impression que tu n'as pas de problème avec la formule en colonne M:M
Donc, :
2) indique les cellules qui ne fonctionnent pas
3) pour chacune de ces cellules, fournis des jeux de tests avec des horaires réels (si un écart de plus de 24h ne peut se produire, pas besoin de le tester).
4) donne les résultats attendus.

Cordialement
Minos72
Messages postés
11
Date d'inscription
samedi 2 février 2019
Dernière intervention
10 février 2019
-
Ci joint la formule evoqué dans mes propos précédents issue de tes interventions sur le forum....
Commenter la réponse de JvDo
Messages postés
1905
Date d'inscription
mercredi 27 juillet 2005
Dernière intervention
18 février 2019
934
0
Merci
Bonjour,

alors, en N8 :
=SOMMEPROD((SI($L8>$C8;--(LIGNE($1:$1440)>=ARRONDI(1440*$C8;0))*(LIGNE($1:$1440)<1440*$L8);1-(LIGNE($1:$1440)<ARRONDI(1440*$C8;0))*(LIGNE($1:$1440)>=ARRONDI(1440*$L8;0))))*(SI(N$4>N$2;(LIGNE($1:$1440)>=ARRONDI(1440*N$2;0))*(LIGNE($1:$1440)<ARRONDI(1440*N$4;0));1-(LIGNE($1:$1440)<ARRONDI(1440*N$2;0))*(LIGNE($1:$1440)>=ARRONDI(1440*N$4;0)))))/1440-(G8-F8)

en P8 avec recopie en Q8 :
=SOMMEPROD((SI($L8>$C8;--(LIGNE($1:$1440)>=ARRONDI(1440*$C8;0))*(LIGNE($1:$1440)<1440*$L8);1-(LIGNE($1:$1440)<ARRONDI(1440*$C8;0))*(LIGNE($1:$1440)>=ARRONDI(1440*$L8;0))))*(SI(P$4>P$2;(LIGNE($1:$1440)>=ARRONDI(1440*P$2;0))*(LIGNE($1:$1440)<ARRONDI(1440*P$4;0));1-(LIGNE($1:$1440)<ARRONDI(1440*P$2;0))*(LIGNE($1:$1440)>=ARRONDI(1440*P$4;0)))))/1440

en T8 :
=SOMMEPROD((SI($L8>$C8;--(LIGNE($1:$1440)>=ARRONDI(1440*$C8;0))*(LIGNE($1:$1440)<1440*$L8);1-(LIGNE($1:$1440)<ARRONDI(1440*$C8;0))*(LIGNE($1:$1440)>=ARRONDI(1440*$L8;0))))*(SI(T$4>T$2;(LIGNE($1:$1440)>=ARRONDI(1440*T$2;0))*(LIGNE($1:$1440)<ARRONDI(1440*T$4;0));1-(LIGNE($1:$1440)<ARRONDI(1440*T$2;0))*(LIGNE($1:$1440)>=ARRONDI(1440*T$4;0)))))/1440-(J8-I8)

Tu aurais intérêt à mettre un modulo sur V8.

Toutes ces formules supposent que les heures de déjeuner sont entre 7h30 et 17h et que les heures de dîner sont après 17h.

Cordialement
Minos72
Messages postés
11
Date d'inscription
samedi 2 février 2019
Dernière intervention
10 février 2019
-
Merci JvDo .... je tests ça et je reviens vers toi !
Commenter la réponse de JvDo