Copier des valeurs si deux libellés sont identiques [Résolu]

Messages postés
5
Date d'inscription
mardi 22 janvier 2019
Statut
Membre
Dernière intervention
1 février 2019
- - Dernière réponse : moonya22
Messages postés
5
Date d'inscription
mardi 22 janvier 2019
Statut
Membre
Dernière intervention
1 février 2019
- 22 janv. 2019 à 14:24
Bonjour,

J'ai une feuille comprenant deux tableaux. Il ya un tableau qui reprend l'ensemble des libellés d'articles (c'est sur ce tableau que je souhaite copier mes valeurs) et un tableau qui n'a quelques libellés d'articles.

Pour être plus clair, je vous montre :




Par exemple, l'abricot frais, l'abricot oreillon l'abricot sec et agitateur bois figure dans le second tableau, mais entre ces articles il y en a qui ne figure pas dans le premier tableau. Je voudrais donc copier les valeurs du premier tableaux (colonne VAL) vers les valeurs du second tableau (colonne VAL vide) mais que pour les articles en communs.


Merci par avance !
Afficher la suite 

1 réponse

Messages postés
24573
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2019
4824
0
Merci
Bonjour
en supposant , ce que l'image ne montre pas, que votre image est casée en A1et donc que la colonne VAL est la colonne J il y a deux options possibles car vous ne précisez pas:
soit chercher avec uniquement le nom du produit en colonne H avec cette formule, en J2
=SIERREUR(RECHERCHEV(H2;A:C;3;0);"non trouvée")
soit inclure le conditionnement (ce n'est pas toujours le même dans les deux tableaux
soit donc dans ce cas:
=SIERREUR(INDEX($C$2:$C$500;EQUIV(H2&I2;$A$2:$A$500&$B$2:$B$500;0));"non trouvée")
cette dernière formule est matricielle, elle doit être entrée avec la touche Enter en maintenant les touches ctrl et shift enfoncées
(elle s'affiche automatiquement entre accolades dans la barre de formule)
elle est assez lourde et il vaut lieux limiter les adresses au nombre de lignes utiles (ici 2 à 500)
dans les deux cas, le code SIERREUR évite un affichage de défaut en cas d'absence. Vous pouvez placerce que vous voulez entre les deux derniers guillemets ou les laisser seuls pour avoir une cellule "blanche"

crdlmnt

moonya22
Messages postés
5
Date d'inscription
mardi 22 janvier 2019
Statut
Membre
Dernière intervention
1 février 2019
-
Bonjour,

Merci pour votre réponse, j'ai essayé de le réaliser mais cela me copie les valeurs. Je vous joins une nouvelle capture avec les cellules adéquates. Je voudrais savoir, à quoi correspondent les valeurs 3;0 dans la première condition que vous m'avez soumise ?

.

Merci encore
Vaucluse
Messages postés
24573
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
14 octobre 2019
4824 -
Bonjour

à priori vous ne cherchez pas la bonne valeur.
C'est celle en M qu'il faut aller chercher dans D, sauf erreur de compréhension
soit donc en O2 la formule:
=SIERREUR(RECHERCHEV(M2;D:F;3;0);"")

la formule:
  • prend la valeur de M
  • cherche dans la colonne D (1° de la plage indiquée) sur quelle ligne elle se troue
  • renvoie la valeur sur la même ligne de la 3° colonne (d'où le 3)de la plage, soit F

le 0 est un code excel qui impose à la formule de ne trouver que des valeurs exactes. Sans ce 0, la formule trouve la ligne de la valeur inférieure la plus proche à condition que la plage soit classée en ordre croissant (alpha ou num) selon la 1° colonne
crdlmnt
moonya22
Messages postés
5
Date d'inscription
mardi 22 janvier 2019
Statut
Membre
Dernière intervention
1 février 2019
-
Super ! Merci pour l'ensemble de vos explications très claires ! Je vais essayer sur des tableaux un peu plus complexe.

Merci encore et bonne journée!

Cordialement.
Commenter la réponse de Vaucluse