Menu

Rajouter une journée à une date complète

Messages postés
1
Date d'inscription
jeudi 3 janvier 2019
Dernière intervention
3 janvier 2019
- - Dernière réponse : michel_m
Messages postés
15609
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
16 janvier 2019
- 3 janv. 2019 à 10:04
Bonjour à tous.

Tout d'abord bonne année ;-)

Mon soucis est le suivant :

ma date : MERCREDI 02 JANVIER 2019

Mon souhait avoir le résultat : JEUDI 03 JANVIER 2019
ainsi de suite jusqu'au MARDI 31 DECEMBRE et si possible sans les week end.

Je vous remercie d'avance de me dire si cela est possible.

Bonne journée
Afficher la suite 

Votre réponse

3 réponses

Messages postés
5187
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
11 janvier 2019
763
0
Merci
Bonjour Olivier1356

le premier jour est en A1
mettre en A2 cette formule
=SI(JOURSEM(A1+1;2)>5;A1+3;A1+1)
Puis tirer la formule vers le bas jusqu4 la ligne 261

Commenter la réponse de PHILOU10120
Messages postés
16799
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 janvier 2019
4976
0
Merci
Bonjour,
Salut Philou meilleurs vœux https://www.cjoint.com/c/IAdiIkFb5Ej

avec une première date ouvrée en A2 la formule en A3 formatée en format personnalisé jjjj jj mm aaaa puis incrémenté vers le bas, il suffira de changer la date en A2 pour le mois suivant

pour ma part j'aurais écrit
=SI(JOURSEM(A2;2)<5;A2+1;A2+3)
pour arrêter la série en fin de mois
=SI(MOIS(A2+1)=MOIS($A$2);SI(JOURSEM(A2;2)<5;A2+1;A2+3);"")
et avec une gestion d'erreur
=SIERREUR(SI(MOIS(A2+1)=MOIS($A$2);SI(JOURSEM(A2;2)<5;A2+1;A2+3);"");"")
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Commenter la réponse de Mike-31
Messages postés
15609
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
16 janvier 2019
3576
0
Merci
Bonjour

Il faut qu'en A1 tu écrives ta date sous la forme 2/1/19
en suite dans A2
=SERIE.JOUR.OUVRE(A1;1) tu obtiens 43468... t' inquiètes pas!
et tu tires vers le bas (43830=31/12/19)


pour obtenir le format littéraire, tu sélectionnes la colonne A jusqu'à 43830 et:

ruban accueil- nombre- date- *mercredi 14 mars 2001

maintenant, si tu veux aussi sans les jours fériés, fais signe

Commenter la réponse de michel_m