Menu

Augmentation pourcentage à un nombre négatif [Résolu]

- - Dernière réponse : Mike-31
Messages postés
16855
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 février 2019
- 19 déc. 2018 à 20:52
Bonjour, j'ai besoin d'aide !!! en A1 j'ai un nombre négatif (-200). À ce nombre, je veux additionner une croissance de 10% (en B1). Et le résultat en C1. Ma formule fonctionne pour les nombres positifs mais pas pour les nombres négatifs.
- 200 + 10% j'arrive à un résultat de -220 mais je devrais augmenter ma valeur et obtenir un résultat de -180.



Configuration: Windows / Chrome 71.0.3578.98
Afficher la suite 

Votre réponse

3 réponses

Messages postés
16855
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 février 2019
5034
0
Merci
Bonsoir,
si tu calcules le % d'une valeur négative exemple -200 cela te donne A2*10% soit -20 et -200+-20 = -220 ce qui est logique.
maintenant tu peux faire dire ce que tu veux à une valeur dans ce cas il faut écrire =A2-A2*10%
si tes valeurs dans ta plage sont positives et négatives il faut tester la valeur avec une conditionnelle
=SI(A2>0;A2+A2*10%;A2-A2*10%)
et si tu as des cellules vides qu'il convient à ignorer
=SI(A2="";"";SI(A2>0;A2+A2*10%;A2-A2*10%))

si ton taux de croissance est en B2
=SI(A2="";"";SI(A2>0;A2+A2*B2;A2-A2*B2))

A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Commenter la réponse de Mike-31
0
Merci
10-4 !!! Un gros merci.
Commenter la réponse de Michel
Messages postés
16855
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 février 2019
5034
0
Merci
Re,

alors je passe le statut de la discussion en résolu
Commenter la réponse de Mike-31