Rien ne s affiche quand j'ouvre mon index.html [Résolu]

- - Dernière réponse :  nkefroid - 13 déc. 2018 à 20:02
Bonjour,



Configuration: Windows / Chrome 70.0.3538.110


voici mon code html :

<!DOCTYPE html>
<html>
<!-- Head -->
<head>
<meta charset="utf-8">
<title> Traductrice professionnelle</title>
<!-- CSS -->
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/bulma/0.7.2/css/bulma.min.css">
<link rel="stylesheet" href="src/css/main.css">
<!-- CSS -->
<!-- Font -->
<link href="https://fonts.googleapis.com/css?family=Shadows+Into+Light" rel="stylesheet">
<script defer src="https://use.fontawesome.com/releases/v5.6.0/js/all.js"/>
<!-- Font -->
</head>
<!-- Head -->


<!-- body -->
<body>
<!-- Header -->
<header> Mes services
<div class="block">
<header class="header">
<a href="#" class="header-logo">Traductrice professionnelle</a>
<nav class="header-menu">
<a href="#">Accueil</a>
<a href="#">Mes services</a>
<a href="#">A propos</a>
<a href="#">Mes clients</a>
<a href="#">Me contacter</a>
</nav>
</header>
</div>
<!-- Header -->
<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"></script>
<script src="src/js/main.js"></script>
</body>
<!-- body -->

</html>


Pourriez-vous me signaler si une erreur se trouve dedans, car quand j'ouvre mon index.html, rien ne s'ouvre!

Merci d'avance.
Afficher la suite 

3 réponses

Messages postés
1264
Date d'inscription
mardi 2 décembre 2003
Statut
Contributeur
Dernière intervention
13 décembre 2018
246
0
Merci
Bonjour,
Il faudrait aussi avoir accès au fichier .css
pas de probleme :
/*
HEADER
  • /

header {
width: 100%;
margin-left: 0;
margin-right: 0;
height: 70px;
line-height: 70px;
background-color: #2c3e50;
}
header header-logo{
color: #FFFFFF;
font-family: 'Shadows Into Light', cursive;
float: left;


}
head {
background-color: chocolate
}
Commenter la réponse de zum
Messages postés
1264
Date d'inscription
mardi 2 décembre 2003
Statut
Contributeur
Dernière intervention
13 décembre 2018
246
0
Merci
Un premier souci sur le code html:


<!DOCTYPE html>
<html>
<!-- Head -->
<head>
<meta charset="utf-8">

<!-- CSS -->

<link rel="stylesheet" type="texte/css" href="main.css" />
<!-- CSS -->
<!-- Font -->


<!-- Font -->
<title> Traductrice professionnelle</title>
</head>
<!-- Head -->


<!-- body -->
<body>



Suppression des balises
script
et ceux qui concerne les
font
, qui doivent se trouver dans le code .css
Commenter la réponse de zum
0
Merci
Je crois, savoir : mes balises <a> ont un probleme, elles n-affichent aucun texte.
Par exemple avec ce code je ne vois rien...
<!DOCTYPE html>
<html>
<head>


<meta charset="utf-8">
<title>mdrr test</title>

<link rel="stylesheet" href="src/css/main.css">

</head>


<body>

<header role='header'>
<nav class="menu" role='naviagtion'>
<div class="m-left">
<h3> Traductice professionnelle </h3>
</div>
<div class="m-left">
<a href="#">Accueil</a>
<a href="#">Mes clients</a>
<a href="#">A propos</a>
<a href="#">Me contacter</a>
</div>
</nav>
</header>
</body>

</html>
telliak
Messages postés
3471
Date d'inscription
mercredi 20 septembre 2006
Statut
Membre
Dernière intervention
20 octobre 2019
631 -
Salut,
chez moi, tel quel, sans CSS, cela s'affiche correctement.
<nav class="menu" role='naviagtion'> : navigation peut-être correspondrait mieux à ce que tu veux ?
> telliak
Messages postés
3471
Date d'inscription
mercredi 20 septembre 2006
Statut
Membre
Dernière intervention
20 octobre 2019
-
Bonjour, le problème précédent est résolu mais j'en ai un nouveau...
Premièrement, quand je met mon <a href='#' class="m-link"> <i class="fas fa-home"></i> Accueil</a> un trait blanc dégeulasse apparaît.
http://prntscr.com/lulaw7
Deuxièmement, je ne trouve pas la commande pour ajouter une réaction au texte (m.link:hover)

Merci d'avance,
NekFroid.
telliak
Messages postés
3471
Date d'inscription
mercredi 20 septembre 2006
Statut
Membre
Dernière intervention
20 octobre 2019
631 -
C'est sympa de laisser chercher la solution à problème résolu :(
> telliak
Messages postés
3471
Date d'inscription
mercredi 20 septembre 2006
Statut
Membre
Dernière intervention
20 octobre 2019
-
Sincèrement désolé...
Commenter la réponse de nekfroid